Subject: RE: On VPLS and Routing Protocols

From: "Shah, Himanshu" <[email-masked]>
Date: Thu, 31 Jul 2003 11:06:36 -0400

I don't know if we need to cover those cases.
There is a problem only when CEs behind a PE
can talk to one sets of CEs and not to others 
for a given VPLS instance.  

And so with that logic, if a PE is having a PW problem 
for a given VPLS instance, it should 'block' the whole 
VPLS instance (i.e. PW bundle as well as local ports 
that are member of that VPLS instance).

/himanshu

> -----Original Message-----
> From: Eric Rosen [mailto:[email-masked]]
> Sent: Wednesday, July 30, 2003 2:35 PM
> To: Alex Zinin
> Cc: [email-masked]
> Subject: Re: On VPLS and Routing Protocols 
> 
> 
> 
> >> 3. When node A looses the PW to node Z, make sure nodes B..Y
> >> simulate loss of connectivity to A and Z too, so all CEs
> >> have a consistent view and VPN routing converges properly.
> >> I.e. PW failure triggers simulation of 2 node failures.
> 
> Alex> IF we decide to go this route, the simplest way to do 
> this is for A
> Alex> and Z to logically put all other PWs they have 
> logically down (stop
> Alex> sending outgoing and drop incoming traffic on them) 
> when they see a PW
> Alex> failure. This way, the two-way connectivity of all 
> other CEs with
> Alex> those attached to A and Z will be broken and VPN routing will
> Alex> reconverge properly. No extra message exchange, no additional
> Alex> signaling--everything is a node-local decision.
> 
> But this doesn't handle the case where  A and Z, for some 
> reason, either (a)
> never find out about  each other, or (b) never succeed in  
> setting up PWs to
> each other in the first place.  Also,  if node Z happens to 
> go down, doesn't
> this make all the PWs go down?  
> 
> I really don't think this can be done based on local knowledge. 
> 
>

---

From: Eric Rosen <[email-masked]>
Date: Thu, 31 Jul 2003 12:53:12 -0400

Eric> But  this doesn't  handle the  case where  A and  Z, for  some reason,
Eric> either (a)  never find out about  each other, or (b)  never succeed in
Eric> setting up PWs to each other in the first place. 

Himanshu> I don't know if we need  to cover those cases.  There is a problem
Himanshu> only when CEs behind  a PE can talk to one sets  of CEs and not to
Himanshu> others for a given VPLS instance.

It seems to me that that will happen in these cases. 

Eric> Also, if node Z  happens to go down, doesn't this make  all the PWs go
Eric> down? 

I'll keep  saying this  until someone explains  to me  why it isn't  a fatal
flaw.