Subject: RE: ARP mediation to working group draft

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 12 Nov 2003 21:29:20 -0500

CE does not post ARP request until he knows
the IP address of the remote CE. Hence, the draft
says that during discovery process, Group addressed
IP frames should be propagated.

For example, OSPF hello packets (addressed to multicast
IP address) are forwarded to remote CE. This allows 
Ethernet CE to learn his neighbor's IP address. Once
IP address is known, Ethernet CE would do ARP to that
IP address to initiate database exchange.

Hope this clears up the importance of allowing multicast
traffic flow during CE discovery phase.

/himanshu

-----Original Message-----
From: Mustapha Aissaoui [mailto:[email-masked]]
Sent: Wednesday, November 12, 2003 6:22 PM
To: Andrew G. Malis
Cc: [email-masked]
Subject: Re: ARP mediation to working group draft

Andy,
I have the following comment on this draft. Section 4.2 does not
seem to be right. An ethernet attached CE cannot discover the IP
address of the remote CE using an ARP request since it does not know
this very IP address. Instead, it can make its own IP address known
to the PE by broadcasting a gratuitous ARP. The PE can also make the
learned IP address of the remote CE known by also generating a
gratuitous ARP associating the remote IP address with its own MAC
address.

Mustapha.
-------------
"Andrew G. Malis" wrote:
>
> Based on Vach's comments in the L2VPN meeting, I would like to request that
> draft-shah-ppvpn-arp-mediation-03.txt become a l2vpn WG draft.  That'll
> also get it back into the I-D directory. :-)
> 
> Thanks,
> Andy

---

From: Mustapha Aissaoui <[email-masked]>
Date: Wed, 12 Nov 2003 22:37:35 -0500

Himanshu,
see below.

Mustapha.
---------
> the IP address of the remote CE. Hence, the draft

Well this is not what Section 4.2 says. I guess what you need to
explain in this section is that the PE will learn the IP address of
the Ethernet attached CE when it receives the ARP message from this
CE. But the Ethernet attached CE is generating this ARP message not
to learn the remote CE IP address, which it has already learned, but
the MAC address to associate with it.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 13 Nov 2003 00:57:31 -0500

Mustapha,

Once this is a working group draft, we'll make sure this point is clarified.

Thanks,
Andy

-----------