Subject: Who do VLAN translation in LDP-VPLS? PE-rs or MTU-s?

From: Du Wenhua <[email-masked]>
Date: Thu, 18 Mar 2004 16:29:00 +0800

Hi,all，

 11.  Hierarchical VPLS model using Ethernet Access Network of <draft-ietf-l2vpn-vpls-ldp-01.txt> say 

>   If customer VLANs need to be treated as service delimiter (e.g., 
>   customer UNI port is a multiplexed port), then the MTU-s needs to 
>   have the additional capability of translating a customer VLAN (C-
>   VLAN) to a P-VLAN in order to resolve overlapping VLAN-ids used by 
>   different customers. Therefore, the MTU-s device in this model can be 
>   considered as a typical bridge with this additional UNI capability.

    In my option, it is not a good idea to let the MTU-s device to do VLAN translation. There are 3 reason:
   1)As we known, MTU-s are low cost devices,  are made by the standard commercial chips. These chips has no VLAN translation function.
   2) On the another side, many MTU-s(a.k.a ethernet switch) have been installed in the carrier network already. It is very difficult to upgrade these ethernet switch to support VLAN translation.
   3)[PWE3-ETHERNET]<draft-ietf-pwe3-ethernet-encap-05.txt> defines the VLAN translation function for PW. <LSP-VPLS> say VPLS supports such PW defined by [PWE3-ETHERNET]. So I think PE-rs support VLAN translation also.

    In summary, I suggest to move the VLAN translation function from the MTU-s to PE-rs. PE-rs are more powerful and more expensive. PE-rs is more easy to do VLAN translation, which is defened in <draft-ietf-pwe3-ethernet-encap-05.txt>.
    MTU-s is just a typical bridge, no additional UNI capability, no VLAN translation.

　　　　　　　　Yours	
		
　　　　　　　　Du Wenhua
    　　　　　　　　　　2004-03-18

---

From: Ali Sajassi <[email-masked]>
Date: Thu, 18 Mar 2004 09:16:26 -0800

At 04:29 PM 3/18/2004 +0800, Du Wenhua wrote:
>Hi,all£¬
>    1)As we known, MTU-s are low cost devices,  are made by the standard 
> commercial chips. These chips has no VLAN translation function.

And I am talking about low-cost bridges based on IEEE 802.1ad that can 
perform this functionality. Take a look at IEEE 802.1ad rev. D2.

>    2) On the another side, many MTU-s(a.k.a ethernet switch) have been 
> installed in the carrier network already. It is very difficult to upgrade 
> these ethernet switch to support VLAN translation.

Many deployed Bridges/MTU-s in carrier networks can support predecessor 
version of 802.1ad standard (QinQ) that have similar capabilities. You 
cannot eat your cake and have it too.
If you want to use
a) Ethernet access network and
b) allow muxed UNI port and
c) don't restrict customer VLAN assignment,
then MTU-s need to support VLAN translation (e.g., based on 802.1ad). But 
if you want to restrict customer VLAN assignment or use PW between your 
u-PE and n-PE, then you don't need this feature.

>    3)[PWE3-ETHERNET]<draft-ietf-pwe3-ethernet-encap-05.txt> defines the 
> VLAN translation function for PW. <LSP-VPLS> say VPLS supports such PW 
> defined by [PWE3-ETHERNET]. So I think PE-rs support VLAN translation also.

But for that you need MPLS access network and your u-PE needs to support 
MPLS PW (e.g., your MTU-s becomes PE-r) and this is different from section 
11.2 whose title is "H-VPLS model using Ethernet Access Network". Besides, 
if you use MPLS PW between u-PE and n-PE, then you wouldn't need VLAN 
traslation to begin with since each customer VLAN gets mapped to a 
different PW.

>     In summary, I suggest to move the VLAN translation function from the 
> MTU-s to PE-rs. PE-rs are more powerful and more expensive. PE-rs is more 
> easy to do VLAN translation, which is defened in 
> <draft-ietf-pwe3-ethernet-encap-05.txt>.

I think you might have misunderstood the scenario for H-VPLS with Ethernet 
access network. Hope the above explanation helps in clarifying it.

-Ali

>¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡Yours
>
>¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡Du Wenhua
>     ¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡2004-03-18