Subject: question on hybrid learning and draft-ietf-ppvpn-vpls-ldp-01.txt

From: narasimhan g <[email-masked]>
Date: Fri, 26 Mar 2004 14:54:53 -0800 (PST)

Hello,
 
I have a question regarding hybrid learning.  My question
is regarding the following text  in section 8.1.1 last paragrah.
 
"When an access port is shared among multiple customers, a reserved VLAN per customer domain must be used to carry STP/MSTP traffic"...  
 
I have the following questions regarding this statement. 
 
1. Can the customer domain ( say A ) have a few vlans ( eg., 100, 200 and 300 )  and B have vlans ( 400, 500 and 600) on the same port?
 
2., Does it mean that one of the vlans in each customer domain is reserved for sending/receiving STP/MSTP BPDUs?  Say vlan 100 for 
customer domain A and 500 for customer domain B? Is this to be done through configuration on both the VPLS PE and the customer node?  Also can regular data frames be also sent on this reserved vlan?
 
3. Does it really matter to the VPLS PE which of the customer vlans the STP/MSTP BPDUS are received?
 
Would really appreciate any reply
 
thanks,
 
narasim
 
--------------------------------------------------------------------

---------------------------------
Do you Yahoo!?
Yahoo! Finance Tax Center - File online. File on time.

---

From: "Marc Lasserre" <[email-masked]>
Date: Sun, 28 Mar 2004 00:06:12 +0100

Narasim,

See my answers inline.

Thanks,
Marc
  ----- Original Message ----- 
  From: narasimhan g 
  To: [email-masked] 
  Sent: March 26, 2004 23:54
  Subject: question on hybrid learning and draft-ietf-ppvpn-vpls-ldp-01.txt

  Hello,

Yes, it is possible.

  2., Does it mean that one of the vlans in each customer domain is reserved for sending/receiving STP/MSTP BPDUs?  Say vlan 100 for 
  customer domain A and 500 for customer domain B? Is this to be done through configuration on both the VPLS PE and the customer node?  Also can regular data frames be also sent on this reserved vlan?
STP/MSTP BPDUs must be VLAN tagged in order for VPLS PEs to know which VPLS domain to forward BPDUs to.
This VLAN tag can be any of the customer's VLANs. Both CE and PE devices would have to be configured with the
corresponding VLAN tag. Regular frames can be sent on this VLAN.

No, it does not since the only requirement is for a PE to know where to forward such BPDUs.

  thanks,

  narasim

------------------------------------------------------------------------------
  Do you Yahoo!?
  Yahoo! Finance Tax Center - File online. File on time.

---

From: Ali Sajassi <[email-masked]>
Date: Mon, 29 Mar 2004 01:24:05 -0800

Marc,

I think it needs to be assumed that in a qualified mode, if multiple 
customers are getting multiplexed over the same PE's port, then the BPDU 
frames of a given customer will have the same service tag as the data for 
that customer (e.g., there should be no need for any reserved tag for 
customer's BPDUs inside the PE). Lets go over the following scenarios:

1) A standard bridge is used to multiplex the traffic from multiple 
customers over a single port:
In this case, the untagged BPDU traffic from the standard bridge would 
represent the traffic for all the customers and thus the PE needs to 
participate in customers' BPDUs and once it does that it can mark the BPDUs 
for each customer with the same service tag as the data for that customer 
and thus direct that into the proper filtering database.

2) A new Provider Bridge (802.1ad) is used to multiplex the traffic from 
multiple customers over a single port:
In this case, the Provider Bridge does the work and does the proper tagging 
of the customers' BPDUs and as the result, the BPDU traffic for each 
customer will carry the same service tag as the customer traffic. 
Furthermore, if there are multiple service instances for a given customer, 
then each such service instance would carry its own BPDUs which would have 
the same service tag as its corresponding data for that service. If what I 
am saying is not very clear, then I would recommend going over sections 5.2 
through 5.9 of 802.1ad.

Regards,
Ali

At 12:06 AM 3/28/2004 +0100, Marc Lasserre wrote:
>From: <mailto:[email-masked]>narasimhan g
>To: <mailto:[email-masked]>[email-masked]
>"When an access port is shared among multiple customers, a reserved VLAN 
>per customer domain must be used to carry STP/MSTP traffic"...
>
>1. Can the customer domain ( say A ) have a few vlans ( eg., 100, 200 and 
>300 )  and B have vlans ( 400, 500 and 600) on the same port?
>
>
>Yes, it is possible.
>
>2., Does it mean that one of the vlans in each customer domain is reserved 
>for sending/receiving STP/MSTP BPDUs?  Say vlan 100 for
>customer domain A and 500 for customer domain B? Is this to be done 
>through configuration on both the VPLS PE and the customer node?  Also can 
>regular data frames be also sent on this reserved vlan?
>
><http://taxes.yahoo.com/filing.html>Yahoo! Finance Tax Center - File 
>online. File on time.

---

From: narasimhan g <[email-masked]>
Date: Mon, 29 Mar 2004 14:36:00 -0800 (PST)

Thanks Marc, Sajassi for your answers.
 
narasim

Ali Sajassi <[email-masked]> wrote:
Marc,

I think it needs to be assumed that in a qualified mode, if multiple customers are getting multiplexed over the same PE's port, then the BPDU frames of a given customer will have the same service tag as the data for that customer (e.g., there should be no need for any reserved tag for customer's BPDUs inside the PE). Lets go over the following scenarios:

1) A standard bridge is used to multiplex the traffic from multiple customers over a single port:
In this case, the untagged BPDU traffic from the standard bridge would represent the traffic for all the customers and thus the PE needs to participate in customers' BPDUs and once it does that it can mark the BPDUs for each customer with the same service tag as the data for that customer and thus direct that into the proper filtering database.

2) A new Provider Bridge (802.1ad) is used to multiplex the traffic from multiple customers over a single port:
In this case, the Provider Bridge does the work and does the proper tagging of the customers' BPDUs and as the result, the BPDU traffic for each customer will carry the same service tag as the customer traffic. Furthermore, if there are multiple service instances for a given customer, then each such service instance would carry its own BPDUs which would have the same service tag as its corresponding data for that service. If what I am saying is not very clear, then I would recommend going over sections 5.2 through 5.9 of 802.1ad.

Regards,
Ali

See my answers inline.
 
Thanks,
Marc 
   ----- Original Message ----- 
   From: narasimhan g 
   To: [email-masked] 
   Sent: March 26, 2004 23:54 
   Subject: question on hybrid learning and draft-ietf-ppvpn-vpls-ldp-01.txt

   Hello, 

    

 Yes, it is possible. 

    

    
   thanks, 
    
   narasim 

   Do you Yahoo!?