Subject: Re: wg last call on ldp-based vpls solutions

From: Yakov Rekhter <[email-masked]>
Date: Fri, 16 Apr 2004 07:47:19 -0700

Folks,

>From the spec (Section 10.3):

   When more than two domains need to be connected, a full mesh of
   inter-domain spokes is created between border PEs.

Consider the following example (it shows only the border PEs):

   Domain A         Domain B       Domain C        Domain D

        A-PE1---B-PE1    B-PE2---C-PE1    C-PE2---D-PE1
       
        A-PE2---B-PE3    B-PE4---C-PE3    C-PE4---D-PE2

What are the inter-domain spokes that would be required in this example ?

Yakov.

---

From: "Marc Lasserre" <[email-masked]>
Date: Tue, 20 Apr 2004 00:33:02 +0200

Yakov,

The VPLS-LDP draft specifies the use of a single active full mesh at a time.
For instance, in your example, only the northern path would be active, with
a corresponding full mesh of all PE1s or PE1a-PE2b-PE2c-PE1d.

A future draft could specify how redundant inter-domain connectivity is
achieved
(election of border PE, and protocol between PEs within one domain to
indicate
loss of connectivity).

Marc

PS: I am travelling and have limited access to email for the next 8 days.

----- Original Message ----- 
From: "Yakov Rekhter" <[email-masked]>
To: <[email-masked]>
Cc: "Loa Andersson" <[email-masked]>; "Thomas Narten" <[email-masked]>; "Alex
Zinin" <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: April 16, 2004 16:47
Subject: Re: wg last call on ldp-based vpls solutions

---

From: Yakov Rekhter <[email-masked]>
Date: Tue, 20 Apr 2004 02:54:13 -0700

Marc,

> achieved (election of border PE, and protocol between PEs within one 
> domain to indicate loss of connectivity).

Please list the missing pieces in the current draft.

Yakov.

---

From: "Vach Kompella" <[email-masked]>
Date: Tue, 20 Apr 2004 08:45:40 -0700

I don't think that's a meaningful request.  Will you also list the
missing pieces of every draft you submit, or do you admit that there are
things that we think of after the fact, improvements that come with
experience and reflection?

-Vach 

> -----Original Message-----
> From: Yakov Rekhter [mailto:[email-masked]] 
> Sent: Tuesday, April 20, 2004 2:54 AM
> To: Marc Lasserre
> Cc: [email-masked]; Loa Andersson; Thomas Narten; Alex Zinin; 
> [email-masked]; [email-masked]
> > The VPLS-LDP draft specifies the use of a single active 
> full mesh at a 
> > time. For instance, in your example, only the northern path 
> would be 
> > active, with a corresponding full mesh of all PE1s or 
> > PE1a-PE2b-PE2c-PE1d.
> > 
> > A future draft could specify how redundant inter-domain 
> connectivity 
> > is achieved (election of border PE, and protocol between PEs within 
> > one domain to indicate loss of connectivity).
>

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 26 Apr 2004 08:43:49 -0700

Vach,

> experience and reflection?

We are not talking about all the "things that we think of after the fact".
All I am asking is to say in the draft that specifications of redundant
inter-domain connectivity is outside the scope of the draft. This is
pretty much what Marc said in his reply to my original e-mail.

Yakov.

---

From: Eric Rosen <[email-masked]>
Date: Mon, 26 Apr 2004 13:43:10 -0400

> say   in  the   draft  that   specifications  of   redundant  inter-domain
> connectivity is outside the scope of the draft. 

This  sort  of  thing  would  generally be  handled  by  the  auto-discovery
protocol, and  it's already been  noted that the auto-discovery  protocol is
out of scope for this draft.

---

From: Kireeti Kompella <[email-masked]>
Date: Mon, 26 Apr 2004 11:34:47 -0700 (PDT)

> out of scope for this draft.

I don't see what redundant inter-domain connectivity has to do with
auto-discovery.  There is text in the draft on redundant spoke
connections (section 10.2 in -02 version), and on multi-domain service
(section 10.3); so clearly both inter-domain and redundancy are in
scope.  Redundant inter-domain connectivity is currently not
specified, so it makes sense to state that.

Kireeti.
-------

---

From: Eric Rosen <[email-masked]>
Date: Mon, 26 Apr 2004 16:13:13 -0400

Kireeti> I don't see what redundant inter-domain connectivity has to do with
Kireeti> auto-discovery. 

It's  possible that  I'm confused  about just  what you  mean  by "redundant
inter-domain connectivity".  I thought this was a matter of determining just
which pairs of border routers  are connected by pseudowires, and reacting to
failures  by  potentially choosing  different  pairs.   Isn't  it the  auto-
discovery  protocol which tells  you which  pairs of  routers to  connect by
pseudowires?

Kireeti> so clearly both inter-domain and redundancy are in scope. 

Actually, I think inter-domain is not in the charter ;-)