Subject: MAC Learning for forwarding traffic

From: Vishal Zinjuvadia <[email-masked]>
Date: Thu, 22 Apr 2004 22:50:50 -0700 (PDT)

Hi,

The draft-ietf-l2vpn-vpls-ldp-02.txt explains how
source MAC Addresses of traffic destined to unknown
unicast or broadcast destination is learned. But I
could not find how we learn source MAC address of
traffic destined to learned Destination MAC Addresses
(Forwarded traffic). Let us assume a customer is
connected to PE1, PE2 and PE3 in a provider network.
An Ethernet frame with Source Address X and
Destination Address Y enters the Provider’s network at
PE1. Destination Y is not learned at PE1 so the frame
is broadcast to PE2 and PE3 who learn Source Address
X. Now when PE2 receives an Ethernet frame with Source
Address Y and Destination address X, it sends it to
PE1 only since X is learned on the virtual circuit to
PE1. So how does PE3 know about the MAC Address Y? It
will still flood traffic destined to the MAC Address Y
to both PE1 and PE2 instead of forwarding it to PE2
only.

Thanks,
Vishal

		
__________________________________
Do you Yahoo!?
Yahoo! Photos: High-quality 4x6 digital prints for 25¢
http://photos.yahoo.com/ph/print_splash

---

From: "Vishal Sharma" <[email-masked]>
Date: Tue, 27 Apr 2004 12:16:18 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Vishal Zinjuvadia
> Sent: Thursday, April 22, 2004 10:51 PM
> To: [email-masked]
> Subject: MAC Learning for forwarding traffic
>
>
> Hi,
>
> Destination Address Y enters the Providers network at

That is correct. But PE3 will (eventually) learn of MAC
address Y (that is, that it is located behing PE2), when it receives
a response from Y to traffic it sent (flooded) to Y.

-Vishal