Subject: RE: multicast pruning in VPLS, IPLS etc

From: "Shah, Himanshu" <[email-masked]>
Date: Thu, 11 Nov 2004 12:13:04 -0500

That is not what I am proposing. Let me explain with an example.
1) there are 3 PEs in an VPLS/IPLS instance, PE-A, PE-B and PE-C
2) Lets say PE-A has 10 ACs in the VPLS/IPLS instance
3) PE-A does IGMP snooping on all 10 ACs
4) PE-A gets a join on AC-1 for Multicast address M1.
5) PE-A advertises PW label 101 to PE-B and PE-C (hence the mp2p PW).
6) PE-A includes label 101 and AC-1 in replication
7) PE-A gets anothoer join on AC-6, PE-A includes AC-6 in replication
   (note no new PW label advertisement)
8) When PE-B or PE-C receives a MAC-DA to M1, it uses label 101 to send 
   the packet to PE-A
9) When PE-A receives packet on PW label 101, it replicates to AC-1 and
   and AC-6
10) Now lets say PE-B gets join for multicast address M1. He advertises
    PW label 102 to PE-A and PE-C.
11) If PE-C receives a packet to M1 DA, he would send the packet out to
    PE-A on PW label 101 and to PE-B on label 102.
12) and so on and so forth. This has been described in IPLS draft.

What I am suggesting is a 'multicast PW' that is created for each multicast MAC address only when join is received.

hope this clears up..

/himanshu

-----Original Message-----
From: Marc Lasserre [mailto:[email-masked]]
Sent: Thursday, November 11, 2004 10:24 AM
To: Shah, Himanshu; [email-masked]
Subject: Re: multicast pruning in VPLS, IPLS etc

Himanshu,

Pre-setting multipoint PWs with all peer PEs at the first join, and relying 
on PIM/IGMP snooping means that traffic is replicated in the core and 
filtered out at the egress points. This prevents traffic from being sent to 
receivers that did not join but it does not optimize traffic replication 
between PEs.

Marc

----- Original Message ----- 
From: "Shah, Himanshu" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, November 10, 2004 4:55 PM
Subject: multicast pruning in VPLS, IPLS etc

> We heard two presentations yesterday about multicast
> pruning for VPLS.
>
> We (IPLS authors) would like to offer yet another option
> which applies to VPLS as well.
>
> In IPLS we have discussed in detail about mp2p PW and
> we have a dedicated mp2p PW per IPLS instance dedicated
> for multicast/broadcast/unknown traffic. We think this
> mp2p PW concept applies very well also for multicast pruning.
>
> In this concept, PE would snoop local IGMP and PIM joins and leaves.
> For a first local join, PE would erect a mp2p PW for that multicast MAC 
> address
> to all the member PEs of the VPLS/IPLS instance. And remove the
> PW for the last leave, remove the Mp2p PW. All the mechanisms for
> establishing and processing data packets is described in the draft wrt
> mp2p pw.  End result is the existence of multiple PWs (one each for a
> multicast address).
>
> There are some restrictions, such as direct host connection, etc, but 
> would
> work for most other cases that were described during the presentations.
>
> Any opinions??
>
> /himanshu
>
>

---

From: Ali Sajassi <[email-masked]>
Date: Fri, 12 Nov 2004 10:07:25 -0800

Himanshu,

A few comments/questions ...

1) The scheme you described still uses ingress PE replication, right ?

2) Since you are not doing any snooping over these set of MPtP PWs, I 
assume that for each multicast group, you will need to setup a set of MP2P 
PWs, right ?

3) If you need to setup the MP2P PWs for each multicast group, then there 
is a potential of dropping the initial customer multicast traffic because 
of the time it takes to establish the MP2P PWs (e.g., delay between 
out-of-band signalling and in-band signaling). This would also exist with 
BGP-based signaling scheme.

So basically the common denominator among all these three multicast 
schemes, is the snooping of the ACs. And as we had some discussion during 
the meeting, there can be several potential issues with the snooping 
(specially with respect to PIM). I think we should concentrate on these 
snooping issues first.

-Ali

At 12:13 PM 11/11/2004 -0500, Shah, Himanshu wrote:
>What I am suggesting is a 'multicast PW' that is created for each 
>multicast MAC address only when join is received.
>
>hope this clears up..
>
>/himanshu
>