Subject: RE: supporting both Ethernet PW and Ethernet VLAN PW on the sameVSI on the same PE

From: "Ali Sajassi \(sajassi\)" <[email-masked]>
Date: Thu, 23 Feb 2006 13:58:51 -0800

________________________________

	From: Asheesh Jadav [mailto:[email-masked]] 
	Sent: Thursday, February 23, 2006 1:53 PM
	To: [email-masked]
	Subject: Re: supporting both Ethernet PW and Ethernet VLAN PW on
the sameVSI on the same PE

	Hi,

	  Can there also be a case where you need both these types of
PWs to the same peer simultaneously for the same VSI? If so, when would
this scenario arise?
	[AS] No, by definition, there is only one PW per pair of PEs per
VPLS instance (per VSI/PE).

	-Ali 

	TIA,

	Asheesh

	----- Original Message ----- From: "Tao Gu" <gu at
centecnetworks.com>
	To: <l2vpn at ietf.org>
	Sent: Wednesday, January 11, 2006 8:11 AM
	Subject: supporting both Ethernet PW and Ethernet VLAN PW on the
same VSI on the same PE

	Hi folks,

	According to section 8 in draft-ietf-l2vpn-vpls-ldp-08.txt,

	A VPLS MAY have both Ethernet and Ethernet VLAN PWs. However, if
a PE is not able to support both PWs simultaneously, it SHOULD send a
Label Release on the PW messages that it cannot support with a status
code "Unknown FEC" as given in [RFC3036].
	My understanding is that a VSI on the same PE (say PE1) can
support both types of PWs, i.e., using a Ethernet PW to connect to PE2
while using a Ethernet VLAN PW to connect to PE3. Can anyone confirm
this? 

	Tao,

	This is correct as long as peer PEs support the corresponding PW
types.

	Marc

	
	Thanks a lot in advance.

	Best regards,

	Tao Gu

	--
	Tao Gu

	
	Centec Networks Inc.
	www.centecnetworks.com

	tgu at centecnetworks.com
	Tel (0512) 62885358 ext 815
	Fax (0512) 62885870
	Cell 136-4621-3957

---

From: "Asheesh Jadav" <[email-masked]>
Date: Thu, 23 Feb 2006 14:18:14 -0800

So is it possible to have a mix-and-match of VLAN tagged and untagged
services on a pair of PEs per VSI or is there never a need for this
case? 

Thanks,

Asheesh

From: Ali Sajassi (sajassi) [mailto:[email-masked]] 
Sent: Thursday, February 23, 2006 1:59 PM
To: Asheesh Jadav; [email-masked]
Subject: RE: supporting both Ethernet PW and Ethernet VLAN PW on the
sameVSI on the same PE

	

	Hi,

	-Ali 

	TIA,

	Asheesh

	Hi folks,

	

	Tao,

	Marc

	
	
	Thanks a lot in advance.

	Best regards,

	Tao Gu

	--
	Tao Gu

	
	
	Centec Networks Inc.
	www.centecnetworks.com

---

From: "Ali Sajassi \(sajassi\)" <[email-masked]>
Date: Thu, 23 Feb 2006 14:25:03 -0800

VPLS instance is defined as a single broadcast domain (e.g., analogous
to a VLAN in IEEE 802.1ad). So, you can have a mix of tagged and
untagged frames within a VSI but that would imply that all those tagged
and untagged frames share the same broadcast domain which further imply
they need to have a unique MAC addresses across them (no overlapping of
MAC addresses are allowed in this case).
 
-Ali

	From: Asheesh Jadav [mailto:[email-masked]] 
	Sent: Thursday, February 23, 2006 2:18 PM
	To: Ali Sajassi (sajassi); [email-masked]
	Subject: RE: supporting both Ethernet PW and Ethernet VLAN PW on
the sameVSI on the same PE

	So is it possible to have a mix-and-match of VLAN tagged and
untagged services on a pair of PEs per VSI or is there never a need for
this case? 

	Thanks,

	Asheesh

	Subject: RE: supporting both Ethernet PW and Ethernet VLAN PW on

		

		From: Asheesh Jadav [mailto:[email-masked]] 
		Sent: Thursday, February 23, 2006 1:53 PM
		To: [email-masked]
		Subject: Re: supporting both Ethernet PW and Ethernet
VLAN PW on the sameVSI on the same PE

		Hi,

		  Can there also be a case where you need both these
types of PWs to the same peer simultaneously for the same VSI? If so,
when would this scenario arise?
		[AS] No, by definition, there is only one PW per pair of
PEs per VPLS instance (per VSI/PE).

		-Ali 

		TIA,

		Asheesh

		----- Original Message ----- From: "Tao Gu" <gu at
centecnetworks.com>
		To: <l2vpn at ietf.org>
		Sent: Wednesday, January 11, 2006 8:11 AM
		Subject: supporting both Ethernet PW and Ethernet VLAN
PW on the same VSI on the same PE

		Hi folks,

		According to section 8 in
draft-ietf-l2vpn-vpls-ldp-08.txt,

		A VPLS MAY have both Ethernet and Ethernet VLAN PWs.
However, if a PE is not able to support both PWs simultaneously, it
SHOULD send a Label Release on the PW messages that it cannot support
with a status code "Unknown FEC" as given in [RFC3036].
		My understanding is that a VSI on the same PE (say PE1)
can support both types of PWs, i.e., using a Ethernet PW to connect to
PE2 while using a Ethernet VLAN PW to connect to PE3. Can anyone confirm
this? 

		
		Tao,

		This is correct as long as peer PEs support the
corresponding PW types.

		Marc

		
		
		Thanks a lot in advance.

		Best regards,

		Tao Gu

		--
		Tao Gu

		
		
		Centec Networks Inc.
		www.centecnetworks.com

---

From: "Ali Sajassi \(sajassi\)" <[email-masked]>
Date: Thu, 23 Feb 2006 14:37:42 -0800

raw mode.
 
-Ali

	Sent: Thursday, February 23, 2006 2:36 PM

	But in such a case how would one decide the PW type between the
PEs for this VSI? 

	Thanks,

	Asheesh

	Sent: Thursday, February 23, 2006 2:25 PM

	VPLS instance is defined as a single broadcast domain (e.g.,
analogous to a VLAN in IEEE 802.1ad). So, you can have a mix of tagged
and untagged frames within a VSI but that would imply that all those
tagged and untagged frames share the same broadcast domain which further
imply they need to have a unique MAC addresses across them (no
overlapping of MAC addresses are allowed in this case).

	-Ali

		Subject: RE: supporting both Ethernet PW and Ethernet

		So is it possible to have a mix-and-match of VLAN tagged
and untagged services on a pair of PEs per VSI or is there never a need
for this case? 

		Thanks,

		Asheesh

		Subject: RE: supporting both Ethernet PW and Ethernet

			

			From: Asheesh Jadav [mailto:[email-masked]] 
			Sent: Thursday, February 23, 2006 1:53 PM
			To: [email-masked]
			Subject: Re: supporting both Ethernet PW and
Ethernet VLAN PW on the sameVSI on the same PE

			Hi,

			  Can there also be a case where you need both
these types of PWs to the same peer simultaneously for the same VSI? If
so, when would this scenario arise?
			[AS] No, by definition, there is only one PW per
pair of PEs per VPLS instance (per VSI/PE).

			-Ali 

			TIA,

			Asheesh

			----- Original Message ----- From: "Tao Gu" <gu
at centecnetworks.com>
			To: <l2vpn at ietf.org>
			Sent: Wednesday, January 11, 2006 8:11 AM
			Subject: supporting both Ethernet PW and
Ethernet VLAN PW on the same VSI on the same PE

			Hi folks,

			A VPLS MAY have both Ethernet and Ethernet VLAN
PWs. However, if a PE is not able to support both PWs simultaneously, it
SHOULD send a Label Release on the PW messages that it cannot support
with a status code "Unknown FEC" as given in [RFC3036].
			My understanding is that a VSI on the same PE
(say PE1) can support both types of PWs, i.e., using a Ethernet PW to
connect to PE2 while using a Ethernet VLAN PW to connect to PE3. Can
anyone confirm this? 

			

			 
			Tao,

			Marc

			

			
			 
			Thanks a lot in advance.

			Best regards,

			Tao Gu

			--
			Tao Gu

			

			
			 
			Centec Networks Inc.
			www.centecnetworks.com

---

From: "Asheesh Jadav" <[email-masked]>
Date: Thu, 23 Feb 2006 14:36:15 -0800

But in such a case how would one decide the PW type between the PEs for
this VSI? 

Thanks,

Asheesh

 

-Ali

	 

	Thanks,

	Asheesh

	 

		Hi,

		-Ali 

		TIA,

		Asheesh

		Hi folks,

		

		

		Tao,

		Marc

		

		
		 
		Thanks a lot in advance.

		Best regards,

		Tao Gu

		--
		Tao Gu

		

		
		 
		Centec Networks Inc.
		www.centecnetworks.com