Subject: RE: draft-kompella-l2vpn-l2vpn-02

From: Kireeti Kompella <[email-masked]>
Date: Sun, 1 Apr 2007 20:42:52 -0700 (PDT)

Ali,

On Fri, 30 Mar 2007, Ali Sajassi (sajassi) wrote:

> Because of a few implementation of this solution, we are in favor of
> progressing it as informational RFC; otherwise, we would not even
> suggest the status of informational RFC for this draft. I think what
> people are saying is that before we talk about standard-track RFC, we
> need to really look at some of the issues that are related to this draft
> such as inter-AS as well as we need to look at interoperability issue
> between this solution and the current standard-track solution.

Inter-AS is NOT in the L2VPN charter, so it makes no sense to use that 
to block the progress of this document.  In point of fact, the 
inter-AS solution for this document is much more mature than that of 
alternative solutions, and perhaps more to the point, there have been 
inter-AS *deployments* since March 2004.

> So, I
> think progressing this draft as informational RFC is a good step till
> these issues are addressed.
>
> Cheers,
> Ali
>
>
> ________________________________
>
> 	From: Ian Stanley [mailto:[email-masked]]
> 	Sent: Friday, March 30, 2007 3:19 PM
> 	To: Dutta, Pranjal (Pranjal); Max Ng; Ali Sajassi (sajassi);
> [email-masked]; Bruno De Troch; Shane Amante; [email-masked]
> 	Subject: Re: draft-kompella-l2vpn-l2vpn-02
>
>
> 	Interesting debate and positioning, but one question of clarity
> please..."how does the market indicate its need to you to start the
> process for standard track"
>
> 	I would have thought that with many implementations of this
> would be enough
>
> 	Cheers
> 	Ian
>
>
> 	On 30/3/07 5:53 PM, "Dutta, Pranjal (Pranjal)"
> <[email-masked]> wrote:Dutta, Pranjal (Pranjal)
>
>
>
> 		My "support" meant supporting Ali's comment. I hope it
> didn't mean
> 		something else :-). Yes, my preference is only for
> *informational*.
>
> 		-----Original Message-----
> 		From: Max Ng [mailto:[email-masked]]
> 		Sent: Friday, 30 March, 2007 1:06 PM
> 		To: Dutta, Pranjal (Pranjal); 'Ali Sajassi (sajassi)';
> 		[email-masked]; 'Bruno De Troch'; 'Shane Amante';
> [email-masked]
> 		Subject: RE: draft-kompella-l2vpn-l2vpn-02
>
> 		A lot has been mentioned and discussed. My preference is
> still to go
> 		with
> 		informational on grounds that we focus on what has
> already been agreed
> 		upon
> 		and rid the confusion. Should the market in the near
> future decide
> 		otherwise, we can progress it to Standard track.
>
> 		-----Original Message-----
> 		From: Dutta, Pranjal (Pranjal)
> [mailto:[email-masked]]
> 		Sent: Friday, March 30, 2007 2:41 PM
> 		To: Ali Sajassi (sajassi); [email-masked]; Bruno
> De Troch; Shane
> 		Amante; [email-masked]
> 		Subject: RE: draft-kompella-l2vpn-l2vpn-02
>
> 		Completely support this. The l2vpn-sig already adopted
> for LDP based
> 		method.
> 		We have wide deployments for both SS-PW and MS-PW with
> LDP signaling for
> 		PWE3.
>
> 		-Pranjal
>
> 		-----Original Message-----
> 		From: Ali Sajassi (sajassi) [mailto:[email-masked]]
> 		Sent: Friday, 30 March, 2007 11:11 AM
> 		To: [email-masked]; Bruno De Troch; Shane Amante;
> [email-masked]
> 		Subject: RE: draft-kompella-l2vpn-l2vpn-02
>
>
> 		And the current standard-track solution is based on the
> PWE3 control
> 		protocol (RFC 4447).
>
> 		-Ali
>
> 		> -----Original Message-----
> 		> From: Renwei Li [mailto:[email-masked]]
> 		> Sent: Thursday, March 29, 2007 6:37 PM
> 		> To: Ali Sajassi (sajassi); 'Bruno De Troch'; 'Shane
> Amante';
> 		> [email-masked]
> 		> Subject: RE: draft-kompella-l2vpn-l2vpn-02
> 		>
> 		> When we decide something to be a standard track RFC or
> 		> informational RFC, do we need to take into account how
> many
> 		> deployments there are? If so, I see more
> implementations and
> 		> deployments based on pwe3-control-protocol draft.
> 		>
> 		> On the other hand, a standard should be unique unless
> it is
> 		> intended to potentially obsolete the other ones. Do we
> intend
> 		> to obsolete other drafts using this new one?
> 		>
> 		> Just some quick thoughts...
> 		>
> 		> Renwei
> 		>
> 		>
> 		>
> 		>
> 		>
> 		> -----Original Message-----
> 		> From: Ali Sajassi (sajassi) [mailto:[email-masked]]
> 		> Sent: Thursday, March 29, 2007 3:31 PM
> 		> To: Bruno De Troch; Shane Amante; [email-masked]
> 		> Subject: RE: draft-kompella-l2vpn-l2vpn-02
> 		>
> 		> ... And I know many more networks that don't have such
> 		> deployment and some of them plan to do theirs based on
> the
> 		> standard-track solution specified in the
> l2vpn-signaling
> 		> draft. So, as I have said previously, given that we
> have a
> 		> comprehensive solution which is standard-track, there
> is no
> 		> need for another one. However, as mentioned before, I
> 		> wouldn't mind this draft to become informational RFC.
> 		>
> 		> -Ali
> 		>
> 		> > -----Original Message-----
> 		> > From: Bruno De Troch [mailto:[email-masked]]
> 		> > Sent: Thursday, March 29, 2007 1:17 PM
> 		> > To: Shane Amante; [email-masked]
> 		> > Subject: RE: draft-kompella-l2vpn-l2vpn-02
> 		> >
> 		> > I know multiple networks where this is already
> deployed, so
> 		> I prefer
> 		> > it to become a standard.
> 		> >
> 		> >
> 		> > Cheers,
> 		> >
> 		> > Bruno
> 		> >
> 		> > > -----Original Message-----
> 		> > > From: Shane Amante [mailto:[email-masked]]
> 		> > > Sent: Wednesday, March 21, 2007 17:27
> 		> > > To: [email-masked]
> 		> > > Subject: draft-kompella-l2vpn-l2vpn-02
> 		> > >
> 		> > > I was approached by several people outside the
> hallway just
> 		> > after the
> 		> > > L2VPN WG meeting expressing confusion over a poll
> in the
> 		> room about
> 		> > > making this draft a WG document, in particular
> over the 'Intended
> 		> > > Status' of this WG draft, e.g.: Informational or
> Standards Track.
> 		> > > Unfortunately, we were abruptly cut off after
> running over
> 		> > our time at
> 		> > > the end of the meeting, in order so they could
> convert
> 		> the room over
> 		> > for
> 		> > > the IETF plenary session, so I didn't have time to
> clarify
> 		> > it.  So, my
> 		> > > apologies for the confusion.
> 		> > >
> 		> > > Let me now ask a hopefully more precise question
> here: How
> 		> > many people
> 		> > > are in favor of making the aforementioned draft a
> WG
> 		> draft *if* the
> 		> > > 'Intended Status' is Standards Track?
> 		> > >
> 		> > > Thanks,
> 		> > >
> 		> > > -shane
> 		> >
> 		>
> 		>
>
>
>
>
>
>
>
>
>
>
> 	Regards,
> 	Ian Stanley
> 	National Manager
> 	Architecture & Design
> 	IP & Data
> 	Core Networks | Engineering
> 	02 9396 8508
> 	0419 257221
>
> 	This communication may contain CONFIDENTIAL or copyright
> information of Telstra Corporation Limited (ABN 33 051 775 556). If you
> are not an intended recipient, you MUST NOT keep, forward, copy, use,
> save or rely on this communication, and any such action is unauthorised
> and prohibited. If you have received this communication in error, please
> reply to this email to notify the sender of its incorrect delivery, and
> then delete both it and your reply. Thank you.
>
>
>
>

Kireeti.
-------

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 2 Apr 2007 09:55:03 -0400

I agree, and think that this is why at least 3 people (myself  
included) have suggested
that it be progressed as an individual informational, not a WG  
informational.

	--Tom

> Ian,
>
> Because of a few implementation of this solution, we are in favor  
> of progressing it as informational RFC; otherwise, we would not  
> even suggest the status of informational RFC for this draft. I  
> think what people are saying is that before we talk about standard- 
> track RFC, we need to really look at some of the issues that are  
> related to this draft such as inter-AS as well as we need to look  
> at interoperability issue between this solution and the current  
> standard-track solution. So, I think progressing this draft as  
> informational RFC is a good step till these issues are addressed.
>
> Cheers,
> Ali
>
> please...”how does the market indicate its need to you to start the  
> process for standard track”
>
> I would have thought that with many implementations of this would  
> be enough
>
> Cheers
> Ian
>
>
> On 30/3/07 5:53 PM, "Dutta, Pranjal (Pranjal)" <pdutta@alcatel- 
> lucent.com> wrote:Dutta, Pranjal (Pranjal)
>
> My "support" meant supporting Ali's comment. I hope it didn't mean
> something else :-). Yes, my preference is only for *informational*.
>
> [email-masked]; 'Bruno De Troch'; 'Shane Amante'; [email-masked]
> A lot has been mentioned and discussed. My preference is still to go
> with
> informational on grounds that we focus on what has already been agreed
> upon
> and rid the confusion. Should the market in the near future decide
> From: Dutta, Pranjal (Pranjal) [mailto:[email-masked]]
> To: Ali Sajassi (sajassi); [email-masked]; Bruno De Troch; Shane
> Amante; [email-masked]
> Completely support this. The l2vpn-sig already adopted for LDP based
> method.
> We have wide deployments for both SS-PW and MS-PW with LDP  
> signaling for
> PWE3.
>
> -Pranjal
>
> To: [email-masked]; Bruno De Troch; Shane Amante; [email-masked]
> And the current standard-track solution is based on the PWE3 control
> protocol (RFC 4447).
>
> -Ali
>
> > To: Ali Sajassi (sajassi); 'Bruno De Troch'; 'Shane Amante';
> > [email-masked]
> > informational RFC, do we need to take into account how many
> > deployments there are? If so, I see more implementations and
> > On the other hand, a standard should be unique unless it is
> > intended to potentially obsolete the other ones. Do we intend
> > deployment and some of them plan to do theirs based on the
> > standard-track solution specified in the l2vpn-signaling
> > draft. So, as I have said previously, given that we have a
> > comprehensive solution which is standard-track, there is no
> > > I know multiple networks where this is already deployed, so
> > I prefer
> > > it to become a standard.
> > >
> > >
> > > Cheers,
> > >
> > > Bruno
> > >
> > > > I was approached by several people outside the hallway just
> > > after the
> > > > L2VPN WG meeting expressing confusion over a poll in the
> > room about
> > > > making this draft a WG document, in particular over the  
> 'Intended
> > > > Status' of this WG draft, e.g.: Informational or Standards  
> Track.
> > > > Unfortunately, we were abruptly cut off after running over
> > > our time at
> > > > the end of the meeting, in order so they could convert
> > the room over
> > > for
> > > > the IETF plenary session, so I didn't have time to clarify
> > > it.  So, my
> > > > Let me now ask a hopefully more precise question here: How
> > > many people
> > > > are in favor of making the aforementioned draft a WG
> > draft *if* the
> information of Telstra Corporation Limited (ABN 33 051 775 556). If  
> you are not an intended recipient, you MUST NOT keep, forward,  
> copy, use, save or rely on this communication, and any such action  
> is unauthorised and prohibited. If you have received this  
> communication in error, please reply to this email to notify the  
> sender of its incorrect delivery, and then delete both it and your  
> reply. Thank you.
>

---

From: "Ali Sajassi \(sajassi\)" <[email-masked]>
Date: Mon, 2 Apr 2007 10:49:17 -0700

Kireeti,

Nice try :-) Although the charter doesn't include inter-AS and needs to
be updated (as per charter text itself), the assumption all along has
been that all L2VPN solutions will cover inter-AS. As the matter of
fact, the L2VPN-requirement RFC (RFC 4665) has a clear set of
requirements for inter-AS. Furthermore, the L2VPN-framework RFC (RFC
4664) also covers inter-AS. And last but not least, all the current
standard-track VPLS and VPWS solutions do cover inter-AS scenarios. So,
I would say we should spend our efforts in fixing the problem rather
than bypassing it.

Cheers,
Ali

> From: Kireeti Kompella [mailto:[email-masked]] 
> Sent: Sunday, April 01, 2007 8:43 PM
> To: Ali Sajassi (sajassi)
> Cc: Ian Stanley; [email-masked]
> > need to really look at some of the issues that are related to this 
> > draft such as inter-AS as well as we need to look at 
> interoperability 
> > issue between this solution and the current standard-track solution.
> 
> Inter-AS is NOT in the L2VPN charter, so it makes no sense to 
> use that to block the progress of this document.  In point of 
> fact, the inter-AS solution for this document is much more 
> mature than that of alternative solutions, and perhaps more 
> to the point, there have been inter-AS *deployments* since March 2004.
> 
> > So, I
> > 	I would have thought that with many implementations of 
> this would be 
> > enough
> >
> > 	Cheers
> > 	Ian
> >
> >
> > 		informational on grounds that we focus on what 
> has already been 
> > agreed
> > 		upon
> > 		To: Ali Sajassi (sajassi); 
> [email-masked]; Bruno De Troch; 
> > Shane
> > 		Amante; [email-masked]
> > 		We have wide deployments for both SS-PW and 
> MS-PW with LDP signaling 
> > for
> > 		PWE3.
> >
> > 		-Pranjal
> >
> > 	This communication may contain CONFIDENTIAL or 
> copyright information 
> > of Telstra Corporation Limited (ABN 33 051 775 556). If you 
> are not an 
> > intended recipient, you MUST NOT keep, forward, copy, use, save or 
> > rely on this communication, and any such action is unauthorised and 
> > prohibited. If you have received this communication in 
> error, please 
> > reply to this email to notify the sender of its incorrect delivery, 
> > and then delete both it and your reply. Thank you.
> >
> >
> >
> >
> 
> Kireeti.
> -------
>