Subject: Re: I-D ACTION:draft-ietf-l2vpn-vpls-bridge-interop-04.txt

From: "Peng He" <[email-masked]>
Date: Wed, 1 Oct 2008 10:10:31 -0400

Just a small question regarding the following draft:

Page 15 bottom and Page 16 top..

" ... then the MSTP protocol can be used to partition the access
network into several loop-free spanning tree topologies where Ethernet
service instances (S-VLANs) are  distributed among these tree
topologies."

Does the above context mean you separate/partition the access network
by MSTP 'regions'? and one S-VLAN per region for example? by 'spanning
tree topologies' and 'these tree topologies' you mean 'regions'?
Thanks a lot.

Regards,
Peng

2008/9/29  <[email-masked]>:
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Layer 2 Virtual Private Networks Working Group of the IETF.
>
>        Title           : VPLS Interoperability with CE Bridges
>        Author(s)       : D. Mohan, A. Sajassi
>        Filename        : draft-ietf-l2vpn-vpls-bridge-interop-04.txt
>        Pages           : 19
>        Date            : 2008-9-29
>
> One of the main motivations behind VPLS is its ability to provide
>   connectivity not only among customer routers and servers/hosts but
>   also among customer IEEE bridges. VPLS is expected to deliver the
>   same level of service that current enterprise users are accustomed
>   to from their own enterprise bridged networks or their Ethernet
>   Service Providers.
>
>   When CE devices are IEEE bridges, then there are certain issues and
>   challenges that need to be accounted for in a VPLS network. The
>   majority of these issues have currently been addressed in the IEEE
>   802.1ad standard for provider bridges and they can be leveraged for
>   VPLS networks. This draft extends the PE model described in RFC 4664 based on IEEE 802.1ad bridge module and illustrates a clear
>   demarcation between IEEE bridge module and IETF LAN emulation
>   module. By doing so, it describes that the majority of
>   interoperability issues with CE bridges can be delegated to 802.1ad
>   bridge module, thus removing the burden on IETF LAN emulation module
>   within a VPLS PE.
>
> A URL for this Internet-Draft is:
>
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>
>
>

---

From: Maarten Vissers <[email-masked]>
Date: Fri, 03 Oct 2008 10:08:25 +0200

Ali, Dinesh, 

In this draft you present the 802.1ad Bridge Module model in Figure 2.
Looking at this model I noticed that it is not completely reflecting all
services supported by 802.1ad Provider Edge Bridges. 802.1ad specifies the
following servive interfaces:
1) port-based service interface
2) C-Tagged service interface
3) S-Tagged service interface.

The current Figure 2 supports only the C-Tagged service interface.
To model the port-based and S-Tagged service interfaces it is necessary to
extend Figure 2 as illustrated below. Two sets of CEs are added; 
- CEs that interconnect via a S-Tagged LAN (S-LAN) interface and connect to
a S-VLAN mux/demux function ==> S-Tagged services
- CEs that interconnect via an Untagged LAN (U-LAN), or Priority-Tagged LAN
(P-LAN), or a C-Tagged LAN, or a S-Priority Tagged LAN (SP-LAN) ==>
port-based service interfaces.

                   +-------------------------------+ 
                   |  802.1ad Bridge Module Model  |  
             U-LAN |                               | 
        +---+P-LAN |  +------+      +-----------+  | 
        |CE |---------|C-VLAN|------|           |  | 
        +---+C-LAN |  |bridge|------|           |  | 
                   |  +------+      |           |  | 
                   |     o          |   S-VLAN  |  | 
                   |     o          |           |  | 
             U-LAN |     o          |   Bridge  |  | 
        +---+P-LAN |  +------+      |           |  | 
        |CE |---------|C-VLAN|------|           |  | 
        +---+C-LAN |  |bridge|------|           |  | 
                   |  +------+      |           |  |
                   |                |           |  |
        +---+S-LAN |  +------+      |           |  | 
        |CE |---------|S-VLAN|------|           |  | 
        +---+      |  |(d)mux|------|           |  | 
                   |  +------+      |           |  | 
                   |     o          |           |  | 
                   |     o          |           |  | 
                   |     o          |           |  | 
        +---+S-LAN |  +------+      |           |  | 
        |CE |---------|S-VLAN|------|           |  | 
        +---+      |  |(d)mux|------|           |  | 
                   |  +------+      |           |  |
             U-LAN |                |           |  |
        +---+P-LAN |                |           |  | 
        |CE |-----------------------|           |  | 
        +---+C-LAN |                |           |  | 
            SP-LAN |     o          |           |  | 
                   |     o          |           |  | 
             U-LAN |     o          |           |  | 
        +---+P-LAN |                |           |  | 
        |CE |-----------------------|           |  | 
        +---+C-LAN |                |           |  | 
            SP-LAN |                +-----------+  |
                   |                               | 
                   +-------------------------------+ 
                                      
               Extended Figure 2. The Model of 802.1ad Bridge Module 
                 (added port-based and S-Tagged service interfaces)

Furthermore there can be C-VLAN mux/demux functions located between the
C-VLAN Bridge and S-VLAN Bridge to support bundled C-VLAN services.

             U-LAN |                                      | 
        +---+P-LAN |  +------+             +-----------+  | 
        |CE |---------|C-VLAN|-------------|           |  | 
        +---+C-LAN |  |bridge|-------------|           |  | 
                   |  |      |             |           |  |
                   |  |      |  +------+   |  S-VLAN   |  |
             U-LAN |  |      |--|C-VLAN|---|           |  |
        +---+P-LAN |  |      |--|(d)mux|   |  Bridge   |  | 
        |CE |---------|      |  +------+   |           |  | 
        +---+C-LAN |  |      |             |           |  | 
                   |  +------+             |           |  |

		Figure 2 extension to model bundled C-VLAN service

Is it possible to extend Figure 2 in draft-ietf-l2vpn-vpls-bridge-interop to
illustrate all service interfaces and service types?

Regards,
Maarten

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: 29 September 2008 19:00
To: [email-masked]
Cc: [email-masked]
Subject: I-D ACTION:draft-ietf-l2vpn-vpls-bridge-interop-04.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Layer 2 Virtual Private Networks Working
Group of the IETF.

    
   VPLS networks. This draft extends the PE model described in RFC 4664
based on IEEE 802.1ad bridge module and illustrates a clear 

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-l2vpn-vpls-bridge-interop-04.
txt