Subject: IETF 77 L2VPN WG follow-up items

From: Shane Amante <[email-masked]>
Date: Sun, 4 Apr 2010 08:03:52 -0600

Hi everyone,

Enclosed are a list of notes that I took during the most recent L2VPN WG meeting @ IETF 77 in Anaheim, CA, USA.  Please review and let us know if you have any questions.  If you have technical comments on one or more drafts in the list below, please start a new thread, so it's easier to track in the archives.

As stated during the WG meeting, we need to complete outstanding items on our WG Charter page, *before* we take on new WG items.  So, we welcome people to thoroughly review and provide comments on: ARP-MED, IPLS, MIB, OAM and Multicast (VPLS multicast & VPMS) work products!

Thanks!

Giles & Shane

---snip---
Follow-up Items from L2VPN WG meeting @ IETF 77

1)  ARP-MED & IPLS + IPv6 changes:
    - draft-ietf-l2vpn-arp-mediation-13
    - draft-ietf-l2vpn-ipls-09
      + Nick DelRegno, Andy Malis and Pranjal Dutta to provide thorough
      reviews, particularly on IPv6 portions, during WG Last Call.
      + The co-chairs welcome additional people to provide comprehensive
      reviews during WG Last Call.
      + WG Last Call will start Monday, April 5th.  Co-chairs will issue mails
      to L2VPN mailing list to capture issues/concerns during Last Call.

2)  SNMP MIB:
    - draft-ietf-l2vpn-vpls-mib-03: H-VPLS MIB
      + Authors believe they addressed all outstanding comments.
      + 3 implementations of this MIB.
      + Should be ready for WG Last Call prior to next IETF?
      + Draft to only address H-VPLS.  PBB-VPLS to be pursued in separate
      MIB if the need should arise.
      + Please review MIB and send comments/questions to Mailing List.
    - draft-kkoushik-snmp-context-map-mib-02: SNMP Context Mapping MIB
      + Issued new version of this draft.
      + Plan is to submit this as an Individual Informational draft, not
      related to the L2VPN WG, (or any other WG).

3)  MAC Flush Loop Detection in VPLS:
    - draft-ietf-l2vpn-vpls-ldp-mac-opt-01
      + Although there was a concern that the current draft only addresses
      Control Plane loop detection and /not/ Data Plane loop detection,
      there was very good support @ WG meeting (6 - 8 for; 1 against) to move
      this forward as a WG draft "as is", (just addressing Control Plane LD
      for now).  Data Plane Loop Detection can be added to this draft, or as
      a separate draft, at a later point in time should be there WG consensus
      to do so.
      + Co-chairs to follow-up with call on WG mailing list to make the
      doc "as is" a WG draft before next IETF.

4)  Extensions to LDP MAC Withdraw for PBB-VPLS:
    - draft-balus-l2vpn-pbb-ldp-ext-02
      + Addressed previous comments on existing draft.
      + Co-authors suggested merging the above draft with
      draft-ietf-l2vpn-vpls-ldp-mac-opt-01 (LDP Extensions for Optimized MAC
      Withdrawl in H-VPLS), in order to have a single consolidated document
      that covers all optimized LDP Extensions for Optimized MAC withdrawl
      for all underlying Ethernet technologies.
      + There were 10 people @ WG meeting that agreed to merge the two drafts,
      and 1 objection.
      + Co-chairs to follow-up with call on WG mailing list to merge
      the two drafts together before next IETF.

5)  Multicast/VPLS:
    - draft-ietf-l2vpn-vpls-mcast-06: Rahul mentioned that Wim Henderickx to
    provide review prior to WG Last Call.

6)  VPMS:
    - draft-raggarwa-l2vpn-p2mp-pw-02: Rahul to issue new Individual I-D 
    containing only BGP Auto Discovery portions of the aforementioned draft,
    which are relevant to L2VPN WG.  P2MP PW portions are being taken up by
    the PWE3 WG.

7)  Active/Active Multihoming:
    - draft-sajassi-l2vpn-rvpls-bgp-00: Routed VPLS using BGP
      + Was presented by Ali at WG meeting
    - draft-raggarwa-mac-vpn-00: BGP MPLS Based MAC VPN
      + Was published immediately after WG meeting, but not discussed.
    - As I, and others, mentioned at the WG meeting, Active/Backup Multihomed
    CE's have been part of the architecture of VPLS from the beginning;
    however, Active/Active Multihoming has /not/.  Therefore, we're going to
    consider this work as not in the L2VPN WG's charter.
    - People can still work on forming a good _requirements_ (not, solutions!)
    doc that may be used as input during a WG recharter in the future.

8)  E-TREE:
    - draft-key-l2vpn-vpls-etree-02
    - draft-jiang-l2vpn-vpls-pe-etree-00
    - draft-ietf-l2vpn-vpls-mib-03
    - Two important things to note about this work:
      a)  Please look at the above comments with respect to:
      draft-raggarwa-l2vpn-p2mp-pw-02.  This, along with associated work in
      PWE3, may address some of the E-TREE requirements.  However, this work
      is specific to VPMS.
      b)  Any other work related to E-TREE is currently out-of-scope of
      the L2VPN WG charter.  People can work on a candidate set of
      requirements that may be considered during a WG recharter in the future.

---

From: Yong Lucy <[email-masked]>
Date: Sun, 04 Apr 2010 10:42:04 -0500

Hi Shane,

draft-key-l2vpn-etree-frwk-02 was also presented in the meeting. The
follow-up item is to look at latest VPMS work.

Regards,
Lucy

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Shane Amante
> Sent: Sunday, April 04, 2010 9:04 AM
> To: [email-masked]
> Subject: IETF 77 L2VPN WG follow-up items
> 
> Hi everyone,
> 
> Enclosed are a list of notes that I took during the most recent L2VPN WG
> meeting @ IETF 77 in Anaheim, CA, USA.  Please review and let us know if
> you have any questions.  If you have technical comments on one or more
> drafts in the list below, please start a new thread, so it's easier to
> track in the archives.
> 
> As stated during the WG meeting, we need to complete outstanding items on
> our WG Charter page, *before* we take on new WG items.  So, we welcome
> people to thoroughly review and provide comments on: ARP-MED, IPLS, MIB,
> OAM and Multicast (VPLS multicast & VPMS) work products!
> 
> Thanks!
> 
> Giles & Shane
> 
> ---snip---
>       requirements that may be considered during a WG recharter in the
> future.=

---

From: Shane Amante <[email-masked]>
Date: Sun, 4 Apr 2010 10:19:03 -0600

Lucy,

Yes it was.  Looks like a cut & paste error on my part.  My apologies & thanks!

-shane