Subject: I-D: Extension to LDP-VPLS for Ethernet Broadcast and Multicast

From: Simon Delord <[email-masked]>
Date: Wed, 8 Sep 2010 20:14:02 +1000

Hi L2VPN working group,

We have just updated "Extension to LDP-VPLS for Ethernet Broadcast and
Multicast"
http://tools.ietf.org/html/draft-delord-l2vpn-ldp-vpls-broadcast-exten-02

This draft takes a pragmatic approach to the broadcast/multicast bandwidth
efficiency problem in LDP-VPLS and proposes a simple solution for certain
common deployment scenarios. Section 2.2. Motivation talks about the
rationale.

We believe this simple solution will be applicable to a majority of LDP-VPLS
network, and can be complementary to the BGP-based solution in
draft-ietf-l2vpn-vpls-mcast-07.

Grateful if you could review and collaborate on the mailing list, or direct
to
the authors. In particular, we are keen to have feedback on the following,
- From an operator perspective, whether the Section 2.2. Motivation makes
  sense or not, applicable to your real environment or not
- From a vendor perspective, whether the proposed solution is feasible or
  not, any difficult hurdle in developing such a solution

Many thanks

Simon

---

From: Mach Chen <[email-masked]>
Date: Thu, 09 Sep 2010 15:57:59 +0800

Hi Simon,

I just read the draft, I think it's valueable especially when there is no 
BGP-solution or the operators do not want to deploy BGP in their network. 
>From the view of implementation, it will requrie to provide some interfaces 
for association one or more P2MP PW to a VPLS and some minor changes to 
forwarding rules and MAC learning, but it should not be difficult for some 
smart implementation.

Best regards,
Mach

--------------------------------------------------
From: "Simon Delord" <[email-masked]>
Sent: Wednesday, September 08, 2010 6:14 PM
To: <[email-masked]>
Subject: I-D: Extension to LDP-VPLS for Ethernet Broadcast and Multicast

---

From: <[email-masked]>
Date: Mon, 13 Sep 2010 11:00:41 +0200

Hi,
 
I do have some comments on the draft. 
 
- L2 vs. L3 issue and Motivation  
  I think this depends on the use case. In order to optimize the network (especially
  with large flows in a typical IPTV deployment) its necessary to do L3 snooping 
  (see above) but I know that there are some use cases, where the use of L3 information
  is critical. The need for increeasing ressources for state information is the typical
  tradeof compared to increasing bandwidth.
 
  From our point of view it is highly preferable (required) that a scalable solution 
  is able to work based on L3 information (at least to create the forwarding 
  states/trees and to map the IP Multicast traffic based on (S,G) to the trees).
  This behaviour should be flexible (we have also a requirement that we want the 
  typical broadcast model for a subset of multicast groups in order to
  be able to optimize join latencies for those groups).
  In addition, Source Specific Multicast only works well with L3 based information. 
 
- Control Plane Traffic
  Depending on the deployment scenario it might be necessary to send Control Plane
  packets (e.g. IGMP Messages) only from the source(s) towards the leaves and only
  from leaves towards source(s) (but not no other leaves).
 
Please let me know what you think.

Kind regards
Nicolai Leymann

Deutsche Telekom Netzproduktion GmbH
Fixed Mobile Engineering Germany
Nicolai Leymann
Winterfeldtstraße 21-27, 10781 Berlin, Germany
+49 30 8353-92761 (Phone)
+49 30 8353-92759 (Fax)
+49 170 2275345 (Mobile)
E-Mail: [email-masked]
www.telekom.de

Life is for sharing.

Deutsche Telekom Netzproduktion GmbH
Supervisory Board: Dr. Steffen Roehn (Chairman)
Board of Management: Dr. Bruno Jacobfeuerborn (Chairman), Albert Matheis, Klaus Peren
Commercial register: Amtsgericht Bonn HRB 14190
Registered office: Bonn
VAT identification no. DE 814645262

Big changes start small - conserve resources by not printing every e-mail.

  _____  

Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Simon Delord
Gesendet: Mittwoch, 8. September 2010 12:14
An: [email-masked]
Betreff: I-D: Extension to LDP-VPLS for Ethernet Broadcast and Multicast

Hi L2VPN working group,

We have just updated "Extension to LDP-VPLS for Ethernet Broadcast and Multicast"
http://tools.ietf.org/html/draft-delord-l2vpn-ldp-vpls-broadcast-exten-02

Grateful if you could review and collaborate on the mailing list, or direct to

Many thanks

Simon