Subject: draft-ietf-l2vpn-vpls-mcast-06

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Tue, 21 Sep 2010 12:43:18 +0200

Rahul,

On the draft-ietf-l2vpn-vpls-mcast-06 there is a mandatory requirement for P2MP RSVP and NOT for mLDP although it is possible.  Some service providers want to use mLDP iso RSVP here, so I believe we should be more flexible in the draft and allow both.
Is there a good reason to make only P2MP RSVP mandatory and not mLDP?

Cheers,
Wim

---

From: <[email-masked]>
Date: Tue, 21 Sep 2010 13:09:02 +0200

Hi,

I support this approach. This adds flexibility and I believe that the draft covers than more real world deployment scenarios.

  Regards

    Nic

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Henderickx, Wim (Wim)
Gesendet: Dienstag, 21. September 2010 12:43
An: Rahul Aggarwal
Cc: [email-masked]
Betreff: draft-ietf-l2vpn-vpls-mcast-06

Rahul,

Cheers,
Wim

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 21 Sep 2010 14:01:49 -0400

+1

Regards,
Jeff  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Tuesday, September 21, 2010 03:43
To: Rahul Aggarwal
Cc: [email-masked]
Subject: draft-ietf-l2vpn-vpls-mcast-06

Rahul,

Cheers,
Wim

---

From: Paul Unbehagen <[email-masked]>
Date: Tue, 21 Sep 2010 12:19:43 -0600

+1

--
Paul Unbehagen

---

From: Rahul Aggarwal <[email-masked]>
Date: Tue, 21 Sep 2010 18:36:18 -0700

Hi Wim,

> Is there a good reason to make only P2MP RSVP mandatory and not mLDP?

This is a side effect of P2MP LDP being relatively immature technology 
when this draft was originally written. While P2MP RSVP-TE was fairly 
mature and deployed. Hence it seemed practically reasonable to mandate 
P2MP RSVP-TE but not P2MP LDP.

If the WG wishes I have no problems in changing the relevant text. The 
text is:

"An implementation that supports this document MUST support
    RSVP-TE P2MP LSPs and MAY support LDP P2MP LSPs."

We have two choices:

1. Remove the sentence.

2. Replace it with:

""An implementation that supports this document MUST support
    RSVP-TE P2MP LSPs and MUST support LDP P2MP LSPs."

Which of the above does the WG prefer?

rahul

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 21 Sep 2010 21:46:32 -0400

I agree with Wim that both should be supported.

Tom

Sent from my iPhone

On Sep 21, 2010, at 9:36 PM, Rahul Aggarwal <[email-masked]> wrote:

> This is a side effect of P2MP LDP being relatively immature technology when this draft was originally written. While P2MP RSVP-TE was fairly mature and deployed. Hence it seemed practically reasonable to mandate P2MP RSVP-TE but not P2MP LDP.
> 
> If the WG wishes I have no problems in changing the relevant text. The text is:
>

---

From: <[email-masked]>
Date: Wed, 22 Sep 2010 09:27:30 +0200

Hi Rahul,

I agree with the choice2 for the text update
""An implementation that supports this document MUST support
    RSVP-TE P2MP LSPs and MUST support LDP P2MP LSPs."

Regards,
Fred

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Rahul Aggarwal
Envoyé : mercredi 22 septembre 2010 03:36
À : Henderickx, Wim (Wim)
Cc : [email-masked]
Objet : Re: draft-ietf-l2vpn-vpls-mcast-06

Attention, votre correspondant continue de vous ecrire a votre ancienne adresse en @francetelecom.com.
Veuillez lui demander de mettre a jour son carnet d'adresses avec votre nouvelle adresse en @orange-ftgroup.com.
Dans quelques semaines, nous refuserons definitivement les messages vers ce domaine.
En savoir plus:
<A HREF="http://pratique.itn.ftgroup/FR/catalogue/messagerie/boitesdemessagerie/Pages/fermeturedomainesftorange.aspx">http://pratique.itn.ftgroup/FR/catalogue/messagerie/boitesdemessagerie/Pages/fermeturedomainesftorange.aspx</A>
-------------------------------------------------------------------------------------------------------------------------

Hi Wim,

We have two choices:

1. Remove the sentence.

2. Replace it with:

rahul

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Wed, 22 Sep 2010 10:43:52 +0200

I would go for 2

-----Original Message-----
From: Rahul Aggarwal [mailto:[email-masked]] 
Sent: woensdag 22 september 2010 3:36
To: Henderickx, Wim (Wim)
Cc: [email-masked]
Subject: Re: draft-ietf-l2vpn-vpls-mcast-06

Hi Wim,

We have two choices:

1. Remove the sentence.

2. Replace it with:

rahul

---

From: <[email-masked]>
Date: Wed, 22 Sep 2010 11:20:45 +0200

Hi Rahul, 

I'm in favour of the second proposal (making RSVP-TE and mLDP a "MUST").

  Regards

    Nic

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Rahul Aggarwal
Gesendet: Mittwoch, 22. September 2010 03:36
An: Henderickx, Wim (Wim)
Cc: [email-masked]
Betreff: Re: draft-ietf-l2vpn-vpls-mcast-06

Hi Wim,

We have two choices:

1. Remove the sentence.

2. Replace it with:

rahul

---

From: Thomas Morin <[email-masked]>
Date: Wed, 22 Sep 2010 16:37:59 +0200

Hi Rahul,

>    RSVP-TE P2MP LSPs and MUST support LDP P2MP LSPs."

I support the second option.

Thanks,

-Thomas