Subject: draft-raggarwa-sajassi-l2vpn-evpn-04, Designated forwarder vs Split Horizon

From: Jasmeet Bagga <[email-masked]>
Date: Wed, 23 Nov 2011 08:55:11 -0800

Hi,

The draft mentioned in ${SUBJECT} enlists 2 mechanisms (designated forwarder
and  split horizon) for preventing multicast, broadcast and unknown
unicast traffic
originated by multihomed CE from being forwarded  back to the CE. Both these
mechanism cause the MES to not forward the traffic onto the ethernet segment
that the data originated from. My question is why do we need two mechanisms ?
Both split horizon and designated forwarder seem to be individually capable of
handling the above requirement ?

I am sure I am missing something here. If so please advise.

Thanks,
Jasmeet

---

From: "Balus, Florin Stelian (Florin)" <[email-masked]>
Date: Wed, 23 Nov 2011 11:27:53 -0600

Split horizon label ensures that a BUM packet received from the non-DF is not flooded back via the DF to the originator CE.

---

From: Jasmeet Bagga <[email-masked]>
Date: Wed, 23 Nov 2011 12:16:48 -0800

Florin,
Got it, thanks.
Its probably a good idea to mention this case explicitly under the
Split Horizon section. in the draft.
For the other cases
- BUM packets arriving at a multihomed MES from another MES not
multihomed to the same CE
- BUM packets arriving at a non-DF MES sent from the DF MES
just dropping the packets at the non-DF seems enough.

The draft sort of alludes to the case you mention but does not
explicitly mention it.

Thanks,
Jasmeet

---

From: Aldrin Isaac <[email-masked]>
Date: Wed, 23 Nov 2011 23:09:52 -0500

Hi Jasmeet, see my comments inline.

> multihomed to the same CE

Currently some form of MLAG would be required for active-active multihoming with a customer network across multiple CE.  Other possibilities are/need to be explored.

> just dropping the packets at the non-DF seems enough.

Yes -- see the following procedure for P2MP.

17.2. ESI MPLS Label: P2MP MPLS LSPs

   An MES that is using P2MP LSPs for sending broadcast, multicast or
   unknown unicast traffic, distributes to other MESes, that belong to
   the Ethernet segment or have an E-VPN in common with the Ethernet
   Segment, an upstream assigned "ESI MPLS label" in the Ethernet A-D
   route. This label is upstream assigned by the MES that advertises the
   route. This label MUST be programmed by the other MESes, that are
   connected to the ESI advertised in the route, in the context label
   space for the advertising MES. Further the forwarding entry for this
   label must result in NOT forwarding packets received with this label
   onto the Ethernet segment that the label was distributed for. This
   label MUST also be programmed by the other MESes, that import the
   route but are not connected to the ESI advertised in the route, in
   the context label space for the advertising MES. Further the
   forwarding entry for this label must be a POP with no other
   associated action.

Another procedure exists for handling this for ingress replication.