Subject: Document Action: 'IP-Only LAN Service (IPLS)' to Historic RFC (draft-ietf-l2vpn-ipls-16.txt)

From: The IESG <[email-masked]>
Date: Tue, 04 Nov 2014 04:50:04 -0800

The IESG has approved the following document:
- 'IP-Only LAN Service (IPLS)'
  (draft-ietf-l2vpn-ipls-16.txt) as Historic RFC

This document is the product of the Layer 2 Virtual Private Networks
Working Group.

The IESG contact persons are Adrian Farrel and Alia Atlas.

A URL of this Internet Draft is:
http://datatracker.ietf.org/doc/draft-ietf-l2vpn-ipls/

Technical Summary: 

   A Virtual Private LAN Service (VPLS) is used to interconnect 
   systems across a wide-area or metropolitan-area network, making it 
   appear that they are on a private LAN.  The systems which are 
   interconnected may themselves be LAN switches.  If, however, they 
   are IP hosts or IP routers, certain simplifications to the operation 
   of the VPLS are possible.  We call this simplified type of VPLS an 
   "IP-only LAN Service" (IPLS).  In an IPLS, as in a VPLS, LAN 
   interfaces are run in promiscuous mode, and frames are forwarded 
   based on their destination MAC addresses.  However, the maintenance 
   of the MAC forwarding tables is done via signaling, rather than via 
   the MAC address learning procedures specified in [IEEE 802.1D].  
   This draft specifies the protocol extensions and procedures for 
   support of the IPLS service. 

   The original intent was to provide an alternate solution to VPLS
   for those PE routers that were not capable of learning MAC address
   through data plane. This became a non-issue with newer hardware.
   The concepts put forth by this draft are still valuable and are
   adopted in one form or other by newer work such as Ethernet VPN
   in L2VPN Working Group and possible data center applications. At
   this point, no further action is planned to update this document
   and is published simply as a historic record of the ideas.

Working Group Summary:

   This document is an L2VPN Working Group document, and has been reviewed in 
   the working group through multiple iterations of the draft.  It was considered to be an 
   informational draft, with the last few iterations of the draft now cleaning up references.
   There was considerable debate during and after the WG last call which resulted in
   new revisions being issued to resolve various comments.

   After discussion with the serving AD, the document was changed to be Historic. Thus
   it presents a record of the working group discussions. The revised I-D was also 
   shown to the WG to check for any concerns.

Document Quality:

    The document provides a clear and concise set of requirements for IPLS - broken 
    down into different requirement areas.  As a requirements draft there is no protocol 
    implement.

Personnel:

     Document Shepherd: Andrew McLachlan ([email-masked])
     Area Director: Adrian Farrel ([email-masked])

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Tue, 4 Nov 2014 17:23:33 +0000

Himanshu,

Congrats! It only took 13 years for it to become a RFC :-) Look at the
bright side of it - it happened while you are still alive :-)

Cheers,
Ali