Subject: [L3sm] Fwd: Some background on the L3VPN Service YANG Model work

From: Qin Wu <[email-masked]>
Date: Thu, 12 Mar 2015 08:25:00 +0000

Dear authors of draft-l3vpn-service-yang:

I have been looking at the concept of a generic service template and obviously it would be

really helpful if the output of L3SM was extensible to other services.

Could we meet in Dallas to discuss this?

-Qin
-------- Forwarded Message --------
Subject:

[L3sm] Some background on the L3VPN Service YANG Model work

Date:

Wed, 4 Mar 2015 14:40:52 +0100

From:

Benoit Claise <[email-masked]><mailto:[email-masked]>

To:

[email-masked]<mailto:[email-masked]>

Dear all,

Let me give you some background on this new piece of work: The Layer Three Virtual Private Network Service Model (L3SM)

Three months ago, Adrian Farrel and I set up a design team to create a L3VPN service YANG model.
It needs to be clearly understood that this L3VPN service model is not an L3VPN configuration model. That is, it does not provide details for configuring network elements or protocols. Instead it contains the characteristics of the service, as discussed between the operators and their customers.  Therefore, that design team was composed of operators only.

That design team created a first draft: http://datatracker.ietf.org/doc/draft-l3vpn-service-yang/
Now that the draft has been posted, the work and discussion should continue in a public forum, i.e. this [email-masked]<mailto:[email-masked]> mailing list.

Next step? we're busy trying to create a new short-lived WG, focusing solely on this L3VPN service YANG model.
See the proposal at https://datatracker.ietf.org/doc/charter-ietf-l3sm/
If this WG is created (This proposal is on the IESG telechat this week for external review approval), this would be a good test for the IETF community: are we ready to standardize a first service YANG model? Personally, I believe we are.
IMO, the advantage/driver for this work is explained in the charter proposal:

The deliverable from this working group will provide information to evaluate the

set of YANG models that have already been developed or are under development,

and will help identify any missing models or details.  The deliverable can be

viewed as driving requirements for protocol configuration model so that the

service parameters can be mapped into inputs used by the protocol models.
Don't hesitate to forward this email.
    List address: [email-masked]<mailto:[email-masked]>
    Archive: http://www.ietf.org/mail-archive/web/l3sm/
    To subscribe: https://www.ietf.org/mailman/listinfo/l3sm

Regards, Benoit

---

From: Tina TSOU <[email-masked]>
Date: Fri, 13 Mar 2015 00:08:46 +0000

Dear Qin,

That is what l3sm chartered to.

What you are looking for is at SUPA, look at the first phase deliverable.

draft-zaalouk-supa-vpn-service-management-model

Thank you,
Tina

On Mar 12, 2015, at 4:30 PM, Qin Wu <[email-masked]<mailto:[email-masked]>> wrote:

-Qin
-------- Forwarded Message --------
Subject:

Date:

From:

To:

Dear all,

Regards, Benoit

---

From: Benoit Claise <[email-masked]>
Date: Wed, 18 Mar 2015 16:01:59 +0100

Dear Qin,

While it might tempting to extend the L3SM scope to a generic service 
template, L3SM is chartered to focus only on L3VPN.

Regards, Benoit
>     *Subject: *
>     *Date: *
>     *From: *
>     Benoit Claise <[email-masked]> <mailto:[email-masked]>
>
>     *To: *
>
>     	
>
>     [email-masked] <mailto:[email-masked]>
>
>
>
>     Dear all,
>
>     Let me give you some background on this new piece of work: The
>     Layer Three Virtual Private Network Service Model (L3SM)
>
>     Three months ago, Adrian Farrel and I set up a design team to
>     create a L3VPN _service _YANG model.
>     It needs to be clearly understood that this L3VPN _service _model
>     is not an L3VPN configuration model. That is, it does not provide
>     details for configuring network elements or protocols. Instead it
>     contains the characteristics of the service, as discussed between
>     the operators and their customers.  Therefore, that design team
>     was composed of operators only.
>
>     That design team created a first draft:
>     http://datatracker.ietf.org/doc/draft-l3vpn-service-yang/
>     Now that the draft has been posted, the work and discussion should
>     continue in a public forum, i.e. this [email-masked]
>     <mailto:[email-masked]> mailing list.
>
>     Next step? we're busy trying to create a new short-lived WG,
>     focusing solely on this L3VPN service YANG model.
>     See the proposal at
>     https://datatracker.ietf.org/doc/charter-ietf-l3sm/
>     <https://datatracker.ietf.org/doc/charter-ietf-l3sm/>
>     If this WG is created (This proposal is on the IESG telechat this
>     week for external review approval), this would be a good test for
>     the IETF community: are we ready to standardize a first service
>     YANG model? Personally, I believe we are.
>         List address: [email-masked] <mailto:[email-masked]>

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 18 Mar 2015 19:38:40 -0000

So I'm wondering here.
 
I think L3SM needs to keep a very tight focus on L3VPN, but at the same time it
might help to think a little about other services just as a way of informing the
work.
 
Conversely, I think that Qin's work could probably benefit a lot by
understanding what decisions and compromises went into the L3SM work. That would
enable him to see whether a generic service model makes any sense (in other
words, are there any pieces of the L3SM that are "generic"?) and if so where you
would draw the line between generic and specific.
 
Adrian
 
From: Benoit Claise [mailto:[email-masked]] 
Sent: 18 March 2015 15:02
To: Qin Wu; [email-masked]
Cc: [email-masked]
Subject: Re: Fwd: [L3sm] Some background on the L3VPN Service YANG Model work
 
Dear Qin,

While it might tempting to extend the L3SM scope to a generic service template,
L3SM is chartered to focus only on L3VPN.

Regards, Benoit
Dear authors of draft-l3vpn-service-yang:
I have been looking at the concept of a generic service template and obviously
it would be 
really helpful if the output of L3SM was extensible to other services. 
Could we meet in Dallas to discuss this?
 
-Qin
-------- Forwarded Message -------- 

Subject: 

Date: 

From: 
Benoit Claise  <mailto:[email-masked]> <[email-masked]>

To: 
[email-masked]

Dear all,

Let me give you some background on this new piece of work: The Layer Three
Virtual Private Network Service Model (L3SM)

Three months ago, Adrian Farrel and I set up a design team to create a L3VPN
service YANG model.
It needs to be clearly understood that this L3VPN service model is not an L3VPN
configuration model. That is, it does not provide details for configuring
network elements or protocols. Instead it contains the characteristics of the
service, as discussed between the operators and their customers.  Therefore,
that design team was composed of operators only.

That design team created a first draft:
http://datatracker.ietf.org/doc/draft-l3vpn-service-yang/ 
Now that the draft has been posted, the work and discussion should continue in a
public forum, i.e. this [email-masked] mailing list.

Next step? we're busy trying to create a new short-lived WG, focusing solely on
this L3VPN service YANG model.
See the proposal at https://datatracker.ietf.org/doc/charter-ietf-l3sm/
If this WG is created (This proposal is on the IESG telechat this week for
external review approval), this would be a good test for the IETF community: are
we ready to standardize a first service YANG model? Personally, I believe we
are. 
IMO, the advantage/driver for this work is explained in the charter proposal:
The deliverable from this working group will provide information to evaluate the
set of YANG models that have already been developed or are under development,
and will help identify any missing models or details.  The deliverable can be
viewed as driving requirements for protocol configuration model so that the
service parameters can be mapped into inputs used by the protocol models.
Don't hesitate to forward this email. 
    List address: [email-masked] 
    Archive: http://www.ietf.org/mail-archive/web/l3sm/ 
    To subscribe: https://www.ietf.org/mailman/listinfo/l3sm

Regards, Benoit