Subject: [L3sm] VPN model statets and parameters

From: Maxim Klyus <[email-masked]>
Date: Tue, 28 Apr 2015 12:54:15 +0000

Hello L3SM and SUPA,

Finally I decided to align all my proposal terminology and states to ITU-T (except Administrative State, because context a little bit different).

http://www.itu.int/rec/T-REC-X.731/en

rw - read/write
ro - read only

Administrative State (RW) - administrative decision service enabling/disabling

Enabled - service administratively enabled, service configuration structure unchanged, but service component states can be changed)
Disabled - service administratively disabled, service configuration structure unchanged, but service component states can be changed)

Operational State (RO) - Service operational state indicate current service state

Enabled - service is enabled and can operate normally or with some errors
Disabled - service disabled administratively or automatically based on some critical errors

Life Cycle State (RW) - Service Life Cycle Management and Configuration

Planned - service planed, service configuration prepared, resources temporary allocated and reserved
Installed - service managed, service configuration applied to service components, resources allocated and reserved
Removed - service removed, configuration removed from the service components and saved for history and resources are free now

Availability Status (RO) - Service availability status (health status) based on this parameter we can say if Operational State will be Enabled or Disabled

Degraded - service administratively enabled (Operational State = Enabled), but some of the service components have an errors.
Failed - service disabled based on SLA policy (Operational State = Disabled), because some of the service components have too many errors.

Actually "Availability Status" accordingly to ITU-T have many other states I'm not sure if need include all of them.

Science service configuration could be modified (expanded/reduced) - VPN instance will be unchanged but service components can be changed it will be useful to add Revision parameter.
Based on this parameter we can track configuration changes history and indicate last active configuration.

"Service Configuration Revision" - track service configuration changes.

Decision about operational service state can be very complicated it will be useful to add SLA Decision policy - parameter and do not add any states to VPN components.
Based on this parameter SP can implement some SLA decision policy per VPN service basis.

"SLA Decision Policy" - reference to SLA policy (set of specific rules and conditions) Service Operational State - Enabled / Disabled

Best Regards,
Maxim Klyus

________________________________
The information transmitted herein is intended only for the person or entity to which it is addressed and may contain confidential, proprietary and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from any computer.

---

From: Qin Wu <[email-masked]>
Date: Wed, 29 Apr 2015 03:02:43 +0000

Hi, Max:
Thanks for updating your proposal to get in line with ITU-T recommendation. Very interesting. A few comments on your proposal.
I am wondering how is Life Cycle state related to SLA parameter or service model? Is Life Cycle state maintained by service orchestrator or something that service orchestrator needs to tell customer?
How is SLA decision policy parameter mapped into inputs used by the protocol models underlying?
Is SLA decision policy part of business related model or not?

-Qin
发件人: Maxim Klyus [mailto:[email-masked]]
发送时间: 2015年4月28日 20:54
收件人: [email-masked]; [email-masked]
抄送: Juergen Schoenwaelder ([email-masked]); Qin Wu
主题: VPN model statets and parameters

Hello L3SM and SUPA,

rw - read/write
ro – read only

Administrative State (RW) – administrative decision service enabling/disabling

Enabled – service administratively enabled, service configuration structure unchanged, but service component states can be changed)
Disabled - service administratively disabled, service configuration structure unchanged, but service component states can be changed)

Operational State (RO) – Service operational state indicate current service state

Enabled – service is enabled and can operate normally or with some errors
Disabled – service disabled administratively or automatically based on some critical errors

Life Cycle State (RW) – Service Life Cycle Management and Configuration

Planned – service planed, service configuration prepared, resources temporary allocated and reserved
Installed – service managed, service configuration applied to service components, resources allocated and reserved
Removed – service removed, configuration removed from the service components and saved for history and resources are free now

Degraded – service administratively enabled (Operational State = Enabled), but some of the service components have an errors.
Failed - service disabled based on SLA policy (Operational State = Disabled), because some of the service components have too many errors.

Actually “Availability Status” accordingly to ITU-T have many other states I’m not sure if need include all of them.

Science service configuration could be modified (expanded/reduced) – VPN instance will be unchanged but service components can be changed it will be useful to add Revision parameter.
Based on this parameter we can track configuration changes history and indicate last active configuration.

“Service Configuration Revision” - track service configuration changes.

Decision about operational service state can be very complicated it will be useful to add SLA Decision policy – parameter and do not add any states to VPN components.
Based on this parameter SP can implement some SLA decision policy per VPN service basis.

“SLA Decision Policy” – reference to SLA policy (set of specific rules and conditions) Service Operational State – Enabled / Disabled

Best Regards,
Maxim Klyus

---

From: Maxim Klyus <[email-masked]>
Date: Wed, 29 Apr 2015 10:25:55 +0000

Hi Qin,

>>> “how is Life Cycle state related to SLA parameter or service model?”

There is no any relation between LC and SLA.

Science we talking about VPN in service context, but not just configuration context IMHO Life Cycle can be part of the model.

Example: I’m ordering VPN. SP preparing service configuration for me and feed it into orchestrator or something for test purpose. Like a result of this test SP can now give an answer for me if it will be possible to provide desirable VPN service for me or not, or how much time I need to wait? So if everything is ok, I can see my service state is Planned. Next I have a notice from SP I should pay it in the next 3 day or service will be Removed and all allocated resources for this service will be free. Within 3 days all resources will be reserved for me, we can even say service will be ready to use, but until I paid it state still be Planned. In case I will provide payments in time, my service will be Installed. When I finally decide to terminate my service it will be removed, but I still can see in history I used it before. So If I will decide in futureto reinstall it I just can use old service template and SP already have this old configuration in history.

>>>“Is Life Cycle state maintained by service orchestrator or something that service orchestrator needs to tell customer?”
LC can be used by both SP and customer like I described above.
SP – use it for service LCM management, planning and allocation resources.
Customer – use it just for own understanding of current service state. .

Maybe ”SLA” terminology I proposed confusing you. We can call it service-integrity-policy or whatever you like, but it doesn’t change the purpose it could be used.
It’s just reference to set of rules, and these rules can be related to technical VPN components parameters only (dropped packets, errors on interface, protocol states), some set of OAM for each VPN component… etc

>>> “How is SLA decision policy parameter mapped into inputs used by the protocol models underlying?”
Like I said above if we talking about OAM model service-integrity-policy can have reference to set of different OAM models and each OAM model can have different parameters adjusted for this specific VPN service.

>>> “Is SLA decision policy part of business related model or not?”
I think my “SLA decision policy” proposal is more technology related.
As I said this “SLA” terminology can be changed.

Best Regards,
Maxim Klyus

From: Qin Wu [mailto:[email-masked]]
Sent: Wednesday, April 29, 2015 6:03 AM
To: Maxim Klyus; [email-masked]
Cc: Juergen Schoenwaelder ([email-masked])
Subject: RE: VPN model statets and parameters

Hi, Max:

-Qin
发件人: Maxim Klyus [mailto:[email-masked]]
发送时间: 2015年4月28日 20:54
收件人: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
抄送: Juergen Schoenwaelder ([email-masked]<mailto:[email-masked]>); Qin Wu
主题: VPN model statets and parameters

Hello L3SM and SUPA,

rw - read/write
ro – read only

Best Regards,
Maxim Klyus

---

From: Qin Wu <[email-masked]>
Date: Wed, 29 Apr 2015 11:04:48 +0000

发件人: Maxim Klyus [mailto:[email-masked]]
发送时间: 2015年4月29日 18:26
收件人: Qin Wu; [email-masked]
抄送: Juergen Schoenwaelder ([email-masked])
主题: RE: VPN model statets and parameters

Hi Qin,

[Qin]: Interesting example, it seems you enable customer to control when the service is instantiated or de-instantiated, set service start time or end time, is this your proposal?

[Qin]: Customer can know the current state returned by the service orchestrator using Restconf, why both service model?

[Qin]: where to model these rules? It seems what you propose is more related to how to manage the service model and how to track the process of mapping service model to network element and protocol configuration model. If the answer is yes, I am afraid it is not in the scope of L3SM charter and different vendor can provide different mapping process and different service provider
Can offer different mapping process.

[Qin]: I don’t think OAM model is a good example since LIME WG focuses on defining base OAM model, any other technology specific model will be developed in the responsible protocol WG
Can be adjusted or augmented with technology specific, e.g., TRILL OAM YANG model (https://tools.ietf.org/html/draft-ietf-trill-yang-oam-00) or TRILL performance measurement YANG model will use LIME base model as basis and extend it with TRILL OAM specifics.
I don’t think service model should be mapped to different technology specific OAM model.

Best Regards,
Maxim Klyus

From: Qin Wu [mailto:[email-masked]]
Sent: Wednesday, April 29, 2015 6:03 AM
To: Maxim Klyus; [email-masked]<mailto:[email-masked]>
Cc: Juergen Schoenwaelder ([email-masked]<mailto:[email-masked]>)
Subject: RE: VPN model statets and parameters

Hi, Max:

-Qin

Hello L3SM and SUPA,

rw - read/write
ro – read only

Best Regards,
Maxim Klyus

---

From: Maxim Klyus <[email-masked]>
Date: Wed, 29 Apr 2015 12:32:26 +0000

>>> “[Qin]: Interesting example, it seems you enable customer to control when the service is instantiated or de-instantiated, set service start time or end time, is this your proposal?”

[Max]: My initial proposal just add Life Cycle State in the model if you think it will be more logical to add start/stop dates instead of using states I don’t mind because dates still can be converted to states until ntp/local time synchronized well.

>>> “[Qin]: where to model these rules? It seems what you propose is more related to how to manage the service model and how to track the process of mapping service model to network element and protocol configuration model. If the answer is yes, I am afraid it is not in the scope of L3SM charter and different vendor can provide different mapping process and different service provider Can offer different mapping process.”

[Max]: You are right each SP can manage its own way, so my proposal just have a reference, because we don’t care how SP will implement it internally and what will be the mapping, we just give SP possibility to do that based on one parameter.

>>> “[Qin]: Customer can know the current state returned by the service orchestrator using Restconf, why both service model?”

[Max]: I just mentioned this parameter can be useful for SP and customer as well.

>>> “[Qin]: I don’t think OAM model is a good example since LIME WG focuses on defining base OAM model, any other technology specific model will be developed in the responsible protocol WG
Can be adjusted or augmented with technology specific, e.g., TRILL OAM YANG model (https://tools.ietf.org/html/draft-ietf-trill-yang-oam-00) or TRILL performance measurement YANG model will use LIME base model as basis and extend it with TRILL OAM specifics.
I don’t think service model should be mapped to different technology specific OAM model.”

[Max]: I don’t mentioned OAM example like an exact example of implementation. I don’t insist system integrity check should be part of the model and my proposal just was based on service context, because in my understanding it is important to define where is the line when the service ceases to be a service.

Best Regards,
Max

Sent: Wednesday, April 29, 2015 2:05 PM

发件人: Maxim Klyus [mailto:[email-masked]]
发送时间: 2015年4月29日 18:26
收件人: Qin Wu; [email-masked]<mailto:[email-masked]>
抄送: Juergen Schoenwaelder ([email-masked]<mailto:[email-masked]>)
主题: RE: VPN model statets and parameters

Hi Qin,

Best Regards,
Maxim Klyus

Hi, Max:

-Qin

Hello L3SM and SUPA,

rw - read/write
ro – read only

Best Regards,
Maxim Klyus

---

From: Qin Wu <[email-masked]>
Date: Thu, 30 Apr 2015 06:00:16 +0000

发送时间: 2015年4月29日 20:32

[Qin]: Thanks for clarification. let’s hear what authors of service model draft think about this proposal.

[Qin]: The internal process can be triggered when orchestrator layer receives the service model instead of receiving a parameter or indication flag bit carried in the service model.

>>> “[Qin]: Customer can know the current state returned by the service orchestrator using Restconf, why bother service model?”

[Qin]: Okay.

[Qin]: Thanks for raising discussion, much appreciate your input and contribution to the service model draft.

Best Regards,
Max

Hi Qin,

Best Regards,
Maxim Klyus

Hi, Max:

-Qin

Hello L3SM and SUPA,

rw - read/write
ro – read only

Best Regards,
Maxim Klyus