Subject: Re: [L3sm] draft-zaalouk-supa-vpn-service-management-model

From: Vikram Choudhary <[email-masked]>
Date: Wed, 8 Apr 2015 05:53:02 +0000

Hi Ying,

Thanks for the update.

Thanks
Vikram

From: Ying Cheng [mailto:[email-masked]]
Sent: 19 March 2015 15:19
To: Vikram Choudhary; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: Dongfeng (C); Jixiaofeng (Steven); Kalyankumar Asangi
Subject: Re: RE: [L3sm] draft-zaalouk-supa-vpn-service-management-model

Hi Vikram,

Thanks for your commetns. We will update the model based on them. Below please see my response inline.

2015-03-19
________________________________
Ying CHENG  程莹
China Unicom Network Technology Research Institute 中国联通网络技术研究院
Tel: +86-10-68799999-7702
Mobile: +86-18601102971
________________________________
发件人： Vikram Choudhary
发送时间： 2015-03-18  13:20:22
收件人： [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Ying Cheng(联通集团联通网络技术研究院); [email-masked]<mailto:[email-masked]>
抄送： Dongfeng (C); Jixiaofeng (Steven); Kalyankumar Asangi
主题： RE: [L3sm] draft-zaalouk-supa-vpn-service-management-model
Hi All,
Can you please provide your thought on my queries.
Thanks
Vikram
-----Original Message-----
From: Vikram Choudhary
Sent: 10 March 2015 18:26
To: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]<mailto:[email-masked]>; Dongfeng (C); Jixiaofeng (Steven); Dhruv Dhody; Kalyankumar Asangi
Subject: RE: [L3sm] draft-zaalouk-supa-vpn-service-management-model
Hi All,
Request you to kindly help me to understand below points as proposed in the draft.
1. Section: 3.1.1.
>> Why do we need both "access-interface-id" and "access-interface-address + ip-address-mask-length" as mandatory parameter for identifying an access interface.
-> As per my understanding access-interface-id will be unique for each interface and hence will be sufficient for identifying access-interface.
-> Moreover, 2 interfaces can't have same ip address so only "access-interface-address + ip-address-mask-length" will be enough for identifying access interface.
-> I feel these parameters are mutually exclusive and anyone of them can serve the purpose. No need of making all of them as mandatory.

[Ying]You're right. I remember a previous email from Jan also pointed this out. We will remove this mandatory lines only leave one for access-interface-id.

>> "protocol-type" can be extended to include "RIP" and "STATIC" protocol-type.

[Ying]Right, in fact, in my previous response to Jan, I also mentioned to add this.:)

>> "igp-attribute" container needs to be extended as per the "protocol-type". Currently, only the "protocol-id" field is defined which may not be sufficient for forming IGP peer
relationship between CE and PE device's.
-> Example: OSPF needs area, hello time-interval, dead time-interval and etc for establishing adjacencies.
(Assume CE devices have different hello and dead time-interval configuration)

[Ying]It's true. We should have taken this into consideration. Thank you for the example. We will address this by adding the info you mentioned into attributes.

2. Section: 3.2.1.
>> Provision for "vlanId" is only available. Since vxLan is also used in DDC now, how to handle these cases? I feel this part may be made more generic to handle any L2 technology.

[Ying]Sorry. I am not sure whether I captured your points. Could you please kindly elaborate it?

Thanks
Vikram

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: 10 March 2015 15:30
To: [email-masked]<mailto:[email-masked]>
Subject: [L3sm] draft-zaalouk-supa-vpn-service-management-model
Dear all,
FYI.
http://tools.ietf.org/id/draft-zaalouk-supa-vpn-service-management-model-02.txt
Regards, Benoit
_______________________________________________
L3sm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/l3sm

---

From: Qin Wu <[email-masked]>
Date: Thu, 9 Apr 2015 01:27:53 +0000

Authors of draft-zaalouk-supa-vpn-service-management-model,

We would like to thank you for your work on your draft and commend your enthusiasm, but we would also like to point out that the L3SM working group is tightly chartered to work on a Layer 3 VPN Service Model only, and that any broadening to a more generic VPN model is out of scope.

As Adrian said in his mail on 3/25 to the L3SM list:

> If you have your own draft in this area, the best approach would be
> to look at draft-l3vpn-service-yang and see what you would change
> or add to that draft, then send your comments to the mailing list.
> Don't forget that we are strictly limited by what is in our charter.

Thanks, and looking forward to your discussions of draft-l3vpn-service-yang,

Regards!
Qin and Adrian
发件人: L3sm [mailto:[email-masked]] 代表 Vikram Choudhary
发送时间: 2015年4月8日 13:53
收件人: Ying Cheng; [email-masked]; [email-masked]; [email-masked]; [email-masked]
抄送: Dongfeng (C); Jixiaofeng (Steven); Kalyankumar Asangi
主题: Re: [L3sm] draft-zaalouk-supa-vpn-service-management-model

Hi Ying,

Thanks for the update.

Thanks
Vikram

To: Vikram Choudhary; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Hi Vikram,

2015-03-19
-----Original Message-----
From: Vikram Choudhary
Sent: 10 March 2015 18:26
To: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]<mailto:[email-masked]>; Dongfeng (C); Jixiaofeng (Steven); Dhruv Dhody; Kalyankumar Asangi
Subject: RE: [L3sm] draft-zaalouk-supa-vpn-service-management-model
Hi All,

2. Section: 3.2.1.

Thanks
Vikram

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: 10 March 2015 15:30
To: [email-masked]<mailto:[email-masked]>
Subject: [L3sm] draft-zaalouk-supa-vpn-service-management-model
Dear all,
FYI.

---

From: Tina TSOU <[email-masked]>
Date: Thu, 9 Apr 2015 02:50:43 +0000

Dear Qin et al,

Draft-zaalouk authors and draft-l3vpn-service-yang author (Rob) met in Dallas.
They would work on the minimum common set of both drafts.

The proposed minimum common set was discussed at this Monday's supa weekly call, will be further discussed on next Monday call.
Feel free to join it.
The Webex information will be announced soon at https://www.ietf.org/mailman/listinfo/supa

Thank you,
Tina

On Apr 9, 2015, at 9:31 AM, Qin Wu <[email-masked]<mailto:[email-masked]>> wrote:

Regards!
Qin and Adrian
发件人: L3sm [mailto:[email-masked]] 代表 Vikram Choudhary
发送时间: 2015年4月8日 13:53
收件人: Ying Cheng; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
抄送: Dongfeng (C); Jixiaofeng (Steven); Kalyankumar Asangi
主题: Re: [L3sm] draft-zaalouk-supa-vpn-service-management-model

Hi Ying,

Thanks for the update.

Thanks
Vikram

Hi Vikram,

2015-03-19
-----Original Message-----
From: Vikram Choudhary
Sent: 10 March 2015 18:26
To: [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>'
Cc: [email-masked]<mailto:[email-masked]>; Dongfeng (C); Jixiaofeng (Steven); Dhruv Dhody; Kalyankumar Asangi
Subject: RE: [L3sm] draft-zaalouk-supa-vpn-service-management-model
Hi All,

2. Section: 3.2.1.

Thanks
Vikram

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: 10 March 2015 15:30
To: [email-masked]<mailto:[email-masked]>
Subject: [L3sm] draft-zaalouk-supa-vpn-service-management-model
Dear all,
FYI.

---

From: <[email-masked]>
Date: Fri, 24 Apr 2015 13:05:37 +0100

Hi Tina,

I just want to clarify here, as unfortunately I do not have the same understanding as your message below implies.

 *   We briefly met in Dallas – and discussed the datacentre-to-datacentre VPN model that you mentioned and I described what the motivation was for the L3VPN service model that we tried to pull together (at the request of the Ops ADs).
 *   The primary focus of the L3VPN model was more related to business VPN ‘services’ compared to infrastructure VPNs.
 *   There is likely to be some common attributes of both cases – which can be augmented such that it provides what I would describe as a “L3VPN primitive”.
 *   I encouraged your team to feedback on the L3VPN model, since L3SM is focused on this draft as a starting point for the efforts of the WG.
    *   I’m not currently working to align these two models as is inferred in your message below.

I look forward to your comments on the L3SM draft. My view is that the work of the (chartered) L3SM working group should be done as per usual IETF work – rather than on calls for a non-WG interest group – but I’ll leave our esteemed Area Directors and Working Group Chairs to comment on this further.

Kind regards,
r.

From: Tina TSOU <[email-masked]<mailto:[email-masked]>>
Date: Thursday, 9 April 2015 03:50
To: Qin Wu <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Ying Cheng <[email-masked]<mailto:[email-masked]>>, "Dongfeng (C)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Jixiaofeng (Steven)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Vikram Choudhary <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Kalyankumar Asangi <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [L3sm] draft-zaalouk-supa-vpn-service-management-model

Dear Qin et al,

Thank you,
Tina

Regards!
Qin and Adrian

Hi Ying,

Thanks for the update.

Thanks
Vikram

Hi Vikram,

2015-03-19
收件人：[email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Ying Cheng(联通集团联通网络技术研究院); [email-masked]<mailto:[email-masked]>
-----Original Message-----
From: Vikram Choudhary
Sent: 10 March 2015 18:26
To: [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>'
Cc: [email-masked]<mailto:[email-masked]>; Dongfeng (C); Jixiaofeng (Steven); Dhruv Dhody; Kalyankumar Asangi
Subject: RE: [L3sm] draft-zaalouk-supa-vpn-service-management-model
Hi All,

2. Section: 3.2.1.

Thanks
Vikram

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: 10 March 2015 15:30
To: [email-masked]<mailto:[email-masked]>
Subject: [L3sm] draft-zaalouk-supa-vpn-service-management-model
Dear all,
FYI.

---

From: Tina TSOU <[email-masked]>
Date: Fri, 24 Apr 2015 15:19:07 +0000

Dear Rob,

Thank you for getting back to this email thread.

Here is the minimum common set discussed, I copied it from the slides from draft-zaalouk authors and contributors.

Have a good weekend.

Thank you,
Tina

From: [email-masked] [mailto:[email-masked]]
Sent: Friday, April 24, 2015 2:06 PM
To: Tina TSOU; Qin Wu
Cc: [email-masked]; [email-masked]; Dongfeng (C); [email-masked]; Jixiaofeng (Steven); [email-masked]; Vikram Choudhary; [email-masked]; Kalyankumar Asangi; [email-masked]
Subject: Re: [L3sm] draft-zaalouk-supa-vpn-service-management-model

Hi Tina,

Kind regards,
r.

Dear Qin et al,

Thank you,
Tina

Regards!
Qin and Adrian

Hi Ying,

Thanks for the update.

Thanks
Vikram

Hi Vikram,

2015-03-19
-----Original Message-----
From: Vikram Choudhary
Sent: 10 March 2015 18:26
To: [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>'
Cc: [email-masked]<mailto:[email-masked]>; Dongfeng (C); Jixiaofeng (Steven); Dhruv Dhody; Kalyankumar Asangi
Subject: RE: [L3sm] draft-zaalouk-supa-vpn-service-management-model
Hi All,

2. Section: 3.2.1.

Thanks
Vikram

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: 10 March 2015 15:30
To: [email-masked]<mailto:[email-masked]>
Subject: [L3sm] draft-zaalouk-supa-vpn-service-management-model
Dear all,
FYI.