Subject: [L3sm] I-D Action: draft-ietf-l3sm-l3vpn-service-model-01.txt

From: [email-masked]
Date: Mon, 03 Aug 2015 04:07:32 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the L3VPN Service Model  Working Group of the IETF.

        Title           : YANG Data Model for L3VPN service delivery
        Authors         : Stephane Litkowski
                          Rob Shakir
                          Luis Tomotaki
                          Kevin D'Souza
	Filename        : draft-ietf-l3sm-l3vpn-service-model-01.txt
	Pages           : 94
	Date            : 2015-08-03

Abstract:
   This document defines a YANG data model that can be used to deliver a
   Layer 3 Provider Provisioned VPN service.  The document is limited to
   the BGP PE-based VPNs as described in RFC4110 and RFC4364.  This
   model is intended to be instantiated at management system to deliver
   the overall service.  This model is not a configuration model to be
   used directly on network elements.  This model provides an abstracted
   view of the Layer 3 IPVPN service configuration components.  It will
   be up to a management system to take this as an input and use
   specific configurations models to configure the different network
   elements to deliver the service.  How configuration of network
   elements is done is out of scope of the document.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-l3sm-l3vpn-service-model/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-l3sm-l3vpn-service-model-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-l3sm-l3vpn-service-model-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Mon, 3 Aug 2015 11:11:18 +0000

Hi WG,

Here is a new version of our draft fitting some comments received on the list or during IETF meeting.
- First level of modularization has been done , is it enough ?
- Site templates putted as a separate list
- More abstracted VPN policy and removal of native VPN
- Add MPLS leaf in vpn-svc for the CsC case
- some renaming
...

Multicast comments are not addressed yet.

Please provide your comments on this new proposal.

-----Original Message-----
From: I-D-Announce [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, August 03, 2015 13:08
To: [email-masked]
Cc: [email-masked]
Subject: I-D Action: draft-ietf-l3sm-l3vpn-service-model-01.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Qin Wu <[email-masked]>
Date: Tue, 18 Aug 2015 09:56:54 +0000

Stephane:
Thanks for update, 1st level of modularization sounds good, especially separating site template as a separate list make a lot of sense to me 
although separating site template from site introduces a lot of duplicated data nodes that occur in both site and site template list, it greatly facilitates service automation (i.e., building more new site using site template) and also the modular component enclosed in the grouping statement in the service model can be reused when other new service model can be developed.

Regarding removal of native vpn, I will raise a issue in the separate email.

-Qin
-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2015年8月3日 19:11
收件人: [email-masked]
主题: Re: [L3sm] I-D Action: draft-ietf-l3sm-l3vpn-service-model-01.txt

Hi WG,

-----Original Message-----
From: I-D-Announce [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, August 03, 2015 13:08
To: [email-masked]
Cc: [email-masked]
Subject: I-D Action: draft-ietf-l3sm-l3vpn-service-model-01.txt

Abstract:

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Wed, 19 Aug 2015 10:08:29 +0000

Hi Stephane,

I think the model is indeed a bit more elegant with separate templates.

After quickly scanning the model again, I have run into a small nit:

  leaf id {
              type uint32;
              description
              "VPN identifier. Local administration meaning.";
          }

Is there a particular reason why this id has to be of type "uint32"? Most other related identifiers in the model are strings (e.g., site-id, cloud-identifier, ...).

Thanks!

Michael

> From: L3sm [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Monday, August 03, 2015 1:11 PM
> To: [email-masked]
> Subject: Re: [L3sm] I-D Action: draft-ietf-l3sm-l3vpn-service-model-
> 01.txt
> 
> Hi WG,
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> _______________________________________________________________________
> __________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les
> messages electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: <[email-masked]>
Date: Wed, 19 Aug 2015 12:11:15 +0000

Hi,

No there's no reason, it's inconsistent. I will fix it.
And I'm also wondering if we need to keep both vpn name and vpn id (redundant?).

Thanks for pointing it

Stephane

-----Original Message-----
From: Scharf, Michael (Michael) [mailto:[email-masked]] 
Sent: Wednesday, August 19, 2015 12:08
To: LITKOWSKI Stephane SCE/IBNF; [email-masked]
Subject: RE: I-D Action: draft-ietf-l3sm-l3vpn-service-model-01.txt

Hi Stephane,

  leaf id {
              type uint32;
              description

Thanks!

Michael

> ______________________________________________________________________
> _ __________________________________________________
> 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi 
> que les pieces jointes. Les messages electroniques etant susceptibles 
> d'alteration, Orange decline toute responsabilite si ce message a ete 
> altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not 
> be distributed, used or copied without authorisation.

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Wed, 19 Aug 2015 12:48:00 +0000

Hi Stephane,

> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Wednesday, August 19, 2015 2:11 PM
> To: Scharf, Michael (Michael); [email-masked]

If name is unique, which seems to be implied in the examples in the document, the id could indeed be redundant.

Michael

> Is there a particular reason why this id has to be of type "uint32"?
> Most other related identifiers in the model are strings (e.g., site-id,
> cloud-identifier, ...).
> 
> Thanks!
> 
> Michael
> 
> 
> > From: I-D-Announce [mailto:[email-masked]] On Behalf
> Of
> > [email-masked]
> >    This document defines a YANG data model that can be used to
> deliver
> > a
> > https://www.ietf.org/rfcdiff?url2=draft-ietf-l3sm-l3vpn-service-
> model-
> > 01
> >
> >
> > If you have received this email in error, please notify the sender
> and
> > delete this message and its attachments.

---

From: <[email-masked]>
Date: Thu, 20 Aug 2015 07:41:29 +0000

The name is unique as it is the key of the list.

-----Original Message-----
From: Scharf, Michael (Michael) [mailto:[email-masked]] 
Sent: Wednesday, August 19, 2015 14:48
To: LITKOWSKI Stephane SCE/IBNF; [email-masked]
Subject: RE: I-D Action: draft-ietf-l3sm-l3vpn-service-model-01.txt

Hi Stephane,

Michael

> Most other related identifiers in the model are strings (e.g., 
> site-id, cloud-identifier, ...).
> 
> Thanks!
> 
> Michael
> 
> 
> > confidentielles ou privilegiees et ne doivent donc pas etre 
> > diffuses, exploites ou copies sans autorisation. Si vous avez recu 
> > ce message par erreur, veuillez le signaler a l'expediteur et le 
> > detruire ainsi que les pieces jointes. Les messages electroniques 
> > etant susceptibles d'alteration, Orange decline toute responsabilite 
> > si ce message a ete altere, deforme ou falsifie. Merci.
> >
> > As emails may be altered, Orange is not liable for messages that 
> > have been modified, changed or falsified.
> > Thank you.
> >

---

From: "Aijun Wang" <[email-masked]>
Date: Tue, 25 Aug 2015 09:17:52 +0800

Hi, stephane:

It seems that the current version of the Yang Model is more
structured/moduled and organized reasonable. 

Here I have some questions for the revised version:
1. What is the scenario where the leaf "customer-nat-address" will be used?
If the customer being provided one public address, why use NAT? if use NAT,
why allocate such "customer-nat-address"?
2. What is the main reason that define grouping "vpn-svc-cfg"? you have
defined grouping "site-service-mpls", "site-service-multicast" etc. Is it
possible to define for example "site-service-cloudaccess" and use them later
directly within the container "l3vpn-svc"?
3. There are some overlapping contents between grouping
"site-attachment-ip-connection" and
"site-customer-routing-specific-information", and the latter is more vague
and hard to understand. Can it be merged into the grouping
"site-attachment-ip-connection"?

Aijun Wang

China Telecom Corporation Limited Beijing Research Institute 
Intelligent Network Product Line

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Monday, August 03, 2015 7:11 PM
To: [email-masked]
Subject: Re: [L3sm] I-D Action: draft-ietf-l3sm-l3vpn-service-model-01.txt

Hi WG,

Here is a new version of our draft fitting some comments received on the
list or during IETF meeting.
- First level of modularization has been done , is it enough ?
- Site templates putted as a separate list
- More abstracted VPN policy and removal of native VPN
- Add MPLS leaf in vpn-svc for the CsC case
- some renaming
...

-----Original Message-----
From: I-D-Announce [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Monday, August 03, 2015 13:08
To: [email-masked]
Cc: [email-masked]
Subject: I-D Action: draft-ietf-l3sm-l3vpn-service-model-01.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
 This draft is a work item of the L3VPN Service Model  Working Group of the
IETF.

Abstract:

____________________________________________________________________________
_____________________________________________

Ce message et ses pieces jointes peuvent contenir des informations
confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
exploites ou copies sans autorisation. Si vous avez recu ce message par
erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les
pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou
falsifie. Merci.

This message and its attachments may contain confidential or privileged
information that may be protected by law; they should not be distributed,
used or copied without authorisation.
If you have received this email in error, please notify the sender and
delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been
modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Wed, 26 Aug 2015 00:13:01 +0000

Hi,

Pls find inline comments.

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Tuesday, August 25, 2015 03:18
To: LITKOWSKI Stephane SCE/IBNF; [email-masked]
Subject: Re: [L3sm] I-D Action: draft-ietf-l3sm-l3vpn-service-model-01.txt

Hi, stephane:

It seems that the current version of the Yang Model is more structured/moduled and organized reasonable. 

Here I have some questions for the revised version:
1. What is the scenario where the leaf "customer-nat-address" will be used?
If the customer being provided one public address, why use NAT? if use NAT, why allocate such "customer-nat-address"?
[SLI] This is necessary in case the customer owns some public IP address that he wants to use for NAT (Provider independent block).
If the SP is providing the public IP, no need to fill the NAT address, the OSS can automatically allocate one from reserved pools owned by the SP.

2. What is the main reason that define grouping "vpn-svc-cfg"? you have defined grouping "site-service-mpls", "site-service-multicast" etc. Is it possible to define for example "site-service-cloudaccess" and use them later directly within the container "l3vpn-svc"?
[SLI] Yep, we can refine the groupings for the VPN container. We may create a vpn-service-cloudaccess and vpn-service-multicast for example.

3. There are some overlapping contents between grouping "site-attachment-ip-connection" and "site-customer-routing-specific-information", and the latter is more vague and hard to understand. Can it be merged into the grouping "site-attachment-ip-connection"?
[SLI] Some merging look possible, for example, putting the ASnumber within bgp container, LAN and cascaded under static. When I created the site-customer-specific-info container I wanted to hide the complexity of bindings those parameters to specific configuration items (AS not linked to bgp config ...) but for sure merging is possible if you think that it make sense. I'm not against this merging.

Aijun Wang

China Telecom Corporation Limited Beijing Research Institute Intelligent Network Product Line

-----Original Message-----

Hi WG,

-----Original Message-----

Abstract: