Subject: [L3sm] Inventory ops state

From: <[email-masked]>
Date: Mon, 17 Aug 2015 09:55:17 +0000

Hi WG,

Discussing with some colleagues, we were wondering if we can integrate some kind of inventory as operational state within the model.
The idea would be to know easily the sites attached to a particular VPN, which is not easy with the current configuration structure but we can add it in an operational state structure.
Also for cloud services being able to know quickly what VPNs are subscribing to a particular Cloud service.

Thoughts ?

[Orange logo]<http://www.orange.com/>

Stephane Litkowski
Network Architect
Orange/SCE/EQUANT/IBNF/ENDD/NDE
Orange Expert Future Networks
phone: +33 2 23 28 49 83 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%202%2023%2028%2049%2083%20>
mobile: +33 6 37 86 97 52 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%206%2037%2086%2097%2052%20>
[email-masked]<mailto:[email-masked]>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Qin Wu <[email-masked]>
Date: Tue, 18 Aug 2015 09:57:03 +0000

Hi, Stephane:
Before considering Inventory ops state, can you tell me why native-vpn is removed from the (v-01), for better VPN policy abstraction?
Or path statement within the native-vpn is not sufficient to associate one VPN with one site?
Can native-vpn in the earlier version be used to identify the specific VPN one site is belong to? It seems native-vpn parameter can tell us
Which VPN is associated with which site?

-Qin
发件人: L3sm [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2015年8月17日 17:55
收件人: [email-masked]
主题: [L3sm] Inventory ops state

Hi WG,

Thoughts ?

Stephane Litkowski
Network Architect

Thank you.

---

From: <[email-masked]>
Date: Tue, 18 Aug 2015 10:48:28 +0000

Some people told that the notion of native VPN was not really clear, especially for the management of a site belonging to multiple VPNs.
So rather than having native VPN+vpn policy, I just kept a simplified vpn policy where we can express rules for VPN attachment.
The VPN policy is a list of entry, where a site or LAN of the site is attached to a VPN (using a ref) and adding its role within the VPN.

From: Qin Wu [mailto:[email-masked]]
Sent: Tuesday, August 18, 2015 11:57
To: LITKOWSKI Stephane SCE/IBNF; [email-masked]
Subject: RE: Inventory ops state

Hi, Stephane:

-Qin
发件人: L3sm [mailto:[email-masked]] 代表 [email-masked]<mailto:[email-masked]>
发送时间: 2015年8月17日 17:55
收件人: [email-masked]<mailto:[email-masked]>
主题: [L3sm] Inventory ops state

Hi WG,

Thoughts ?

Stephane Litkowski
Network Architect

Thank you.

---

From: Qin Wu <[email-masked]>
Date: Tue, 18 Aug 2015 10:58:03 +0000

发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2015年8月18日 18:48
收件人: Qin Wu; [email-masked]
主题: RE: Inventory ops state

[Qin]: To a VPN or To multiple VPN?, can VPN policy still be applied to multiple VPNs?

Since Section 5.2.2 of draft-ietf-l3sm-l3vpn-service-model-01 said:
“

The VPN policy defines the route exchange between multiple VPNs. A
vpn-policy configuration MUST be configured to attach a site to one
or multiple VPNs.
”

From: Qin Wu [mailto:[email-masked]]
Sent: Tuesday, August 18, 2015 11:57
To: LITKOWSKI Stephane SCE/IBNF; [email-masked]<mailto:[email-masked]>
Subject: RE: Inventory ops state

Hi, Stephane:

-Qin

Hi WG,

Thoughts ?

Stephane Litkowski
Network Architect

Thank you.

Thank you.

---

From: <[email-masked]>
Date: Tue, 18 Aug 2015 11:13:55 +0000

PVN policy is used to attach a site to one or multiple VPNs.

Example :
                Site attached to a single VPN :
<vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
               <site-role>any-to-any-role</site-role>
           </vpn>
       </entries>
   </vpn-policy>

Site attached to a multiple VPNs :

<vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
               <site-role>any-to-any-role</site-role>
           </vpn>
       </entries>
       <entries>
           <id>2</id>
           <vpn>
               <vpn>VPN2</vpn>
               <site-role>any-to-any-role</site-role>
           </vpn>
       </entries>
   </vpn-policy>

Site attached to a multiple VPNs with LAN separation :

<vpn-policy>
       <entries>
           <id>1</id>
           <filter>
               <lan-tag>LAN1</lan-tag>
           </filter>
           <vpn>
               <vpn>VPN1</vpn>
               <site-role>any-to-any-role</site-role>
           </vpn>
       </entries>
       <entries>
           <id>2</id>
           <filter>
               <lan-tag>LAN2</lan-tag>
           </filter>
           <vpn>
               <vpn>VPN2</vpn>
               <site-role>any-to-any-role</site-role>
           </vpn>
       </entries>
   </vpn-policy>

From: Qin Wu [mailto:[email-masked]]
Sent: Tuesday, August 18, 2015 12:58
To: LITKOWSKI Stephane SCE/IBNF; [email-masked]
Subject: RE: Inventory ops state

发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
发送时间: 2015年8月18日 18:48
收件人: Qin Wu; [email-masked]<mailto:[email-masked]>
主题: RE: Inventory ops state

Hi, Stephane:

-Qin

Hi WG,

Thoughts ?

Stephane Litkowski
Network Architect

Thank you.

Thank you.

---

From: Qin Wu <[email-masked]>
Date: Wed, 19 Aug 2015 02:57:13 +0000

From the example below, I tend to agree native-vpn is not needed.
It seems to me vpn policy can also be used to specify which VPNs are attached to a particular site or specify one site belonging to multiple VPN,
Do we need to add association between site and VPN also in the operational state subtree?

In addition, I feel, entries list should be entry list, when  VPN-policy as container contains multiple entries, e.g.,
<vpn-policy>
       <entry>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
               <site-role>any-to-any-role</site-role>
           </vpn>
       </entry>
       <entry>
           <id>2</id>
           <vpn>
               <vpn>VPN2</vpn>
               <site-role>any-to-any-role</site-role>
           </vpn>
       </entry>
   </vpn-policy>
The Corresponding service model structure for VPN policy should be

         |  +--rw vpn-policy
         |  |  +--rw entry* [id]

-Qin
发送时间: 2015年8月18日 19:14

Example :

<vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>

<vpn-policy>
       <entries>
           <id>1</id>
           <filter>
               <lan-tag>LAN1</lan-tag>
           </filter>
           <vpn>
               <vpn>VPN1</vpn>

Hi, Stephane:

-Qin

Hi WG,

Thoughts ?

Stephane Litkowski
Network Architect

Thank you.

Thank you.

Thank you.