Subject: Re: [L3sm] [l3sm] #6 (draft-ltsd-l3sm-l3vpn-service-model): Inventory ops state

From: "Ariel Gu" <[email-masked]>
Date: Wed, 30 Sep 2015 15:20:42 +0800

Hi, Stephane and dear all.
 
I think the information of L3VPN model now is enough even for multiple entries. I think we do not need the extra inventory.
How about others' idea?

Best regards.
Gu Rong
[email-masked]
[email-masked]

发件人: l3sm issue tracker [mailto:[email-masked]]
发送时间: 2015年9月23日 16:14
收件人: [email-masked]; Qin Wu
抄送: [email-masked]
主题: Re: [l3sm] #6 (draft-ltsd-l3sm-l3vpn-service-model): Inventory ops state

#6: Inventory ops state

Description changed by [email-masked]:

Old description:

> In v(-01), VPN policy is used to exchange route among VPNs, As a site 
> can belong to multiple VPNs, the vpn-policy may be composed of 
> multiple entries which may indicate which VPNs are associated with the 
> same particular site.
>
> To better know which the sites attached to a particular VPN,Stephane 
> proposes to integrate some kind of inventory as operational state 
> within the model to achieve this.

New description:

 In v(-01), VPN policy is used to exchange route among VPNs, As a site can  belong to multiple VPNs, the vpn-policy may be composed  of multiple entries which may indicate which VPNs are associated with the  same particular site.

 To better know which the sites attached to a particular VPN,Stephane  proposes to integrate some kind of inventory as operational state within  the model to achieve this.

 In addition, for cloud services,with Inventory ops state, we will be able  to know quickly what VPNs are subscribing to a particular Cloud service.

--

-- 
-------------------------------------+----------------------------------
-------------------------------------+---
 Reporter:  [email-masked]       |       Owner:  draft-ltsd-l3sm-l3vpn-
     Type:  enhancement              |  [email-masked]
 Priority:  minor                    |      Status:  new
Component:  draft-ltsd-l3sm-l3vpn-   |   Milestone:
  service-model                      |     Version:
 Severity:  -                        |  Resolution:
 Keywords:  oper state               |
-------------------------------------+----------------------------------
-------------------------------------+---

Ticket URL: <http://trac.tools.ietf.org/wg/l3sm/trac/ticket/6#comment:1>
l3sm <http://tools.ietf.org/l3sm/>

---

From: Qin Wu <[email-masked]>
Date: Wed, 30 Sep 2015 09:32:23 +0000

Hi, Ariel:
When you say L3VPN model has sufficient information, do you mean L3VPN has sufficient information to represent association between site-id and VPN-name or association between cloud-identity and VPN-name since in the current v(-01), the service model allows one VPN contain multiple sites, 
   module: ietf-l3vpn-svc
      +--rw l3vpn-svc
         +--rw vpn-svc* [name]
         |  +--rw name             string
         |  +--rw id?              uint32
         +--rw sites* [site-id]
         |  +--rw site-id  

or allows one VPN contain multiple cloud identity under cloud-access container
   module: ietf-l3vpn-svc
      +--rw l3vpn-svc
         +--rw vpn-svc* [name]
         |  +--rw name             string
         |  +--rw id?              uint32
         |  +--rw cloud-access* [cloud-identifier]
         |  |  +--rw cloud-identifier        string

So adding inventory oper state for this purpose is redundant, Is that what you said?

-Qin
-----邮件原件-----
发件人: Ariel Gu [mailto:[email-masked]] 
发送时间: 2015年9月30日 15:21
收件人: [email-masked]; [email-masked]
抄送: [email-masked]; Qin Wu
主题: RE: [l3sm] #6 (draft-ltsd-l3sm-l3vpn-service-model): Inventory ops state

Best regards.
Gu Rong
[email-masked]
[email-masked]

#6: Inventory ops state

New description:

--

---

From: "Ariel Gu" <[email-masked]>
Date: Wed, 30 Sep 2015 20:12:29 +0800

Yes, that's exactly what I mean. Thank you, Bill.

Gu Rong
[email-masked]
[email-masked]

-----邮件原件-----
发件人: Qin Wu [mailto:[email-masked]] 
发送时间: 2015年9月30日 17:32
收件人: Ariel Gu
抄送: [email-masked]
主题: RE: [l3sm] #6 (draft-ltsd-l3sm-l3vpn-service-model): Inventory ops state

Hi, Ariel:

-Qin
-----邮件原件-----
发件人: Ariel Gu [mailto:[email-masked]] 
发送时间: 2015年9月30日 15:21
收件人: [email-masked]; [email-masked]
抄送: [email-masked]; Qin Wu
主题: RE: [l3sm] #6 (draft-ltsd-l3sm-l3vpn-service-model): Inventory ops state

Best regards.
Gu Rong
[email-masked]
[email-masked]

#6: Inventory ops state

New description:

--