Subject: [L3sm] [l3sm] #3 (draft-ltsd-l3sm-l3vpn-service-model): M to N availability support

From: "l3sm issue tracker" <[email-masked]>
Date: Wed, 23 Sep 2015 07:38:29 -0000

#3: M to N availability support

 In v(-01),Site Availability support primary-back,loadsharing,single.
 In prague meeting, Kireeti Kompella brought up a case where there is M
 primary,N backup,loading sharing among M primary, N backups for backup, do
 we support M to N availability in service model? How do we support it?

 One relevant question is,In v(-01), can one site provide more than one
 attachment? If not, how do we know one site offering backup access is used
 for another site offering primary access?

-- 
-------------------------------------------------+-------------------------
 Reporter:  [email-masked]                   |      Owner:  Site
     Type:  enhancement                          |  Availability
 Priority:  minor                                |     Status:  new
Component:  draft-ltsd-l3sm-l3vpn-service-model  |  Milestone:
 Severity:  -                                    |    Version:
                                                 |   Keywords:
-------------------------------------------------+-------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/l3sm/trac/ticket/3>
l3sm <http://tools.ietf.org/l3sm/>

---

From: <[email-masked]>
Date: Wed, 30 Sep 2015 07:56:56 +0000

Hi,

Here is what we have :
- a site is defined as a network attachment, so if a real customer site requires dualhoming, there is a need for two sites. Do we need to change this assumption and having a single site with multi-attachment ?

-Then we have for a site the possibility to define : loadsharing or primary/backup, so we cannot manage M to N availability.
Two proposals :
1) Add a "multihomed" identity for site-availability in addition to a "preference" access-type identity. In case "preference" access-type is used, we may use a conditional leaf preference-value to give order of preferences  between sites (same preference between multiple sites = loadsharing if preferred). We keep other identities to identify easily more simple cases. The number of customers using M to N is very low compared to the one using primary/backup or simple loadsharing. So from an abstraction point of view, it may be good to keep it.
2) Use only preference (no more need of identity) and remove service-type and access-type in availability.

Thoughts ?

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of l3sm issue tracker
Sent: Wednesday, September 23, 2015 09:38
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] [l3sm] #3 (draft-ltsd-l3sm-l3vpn-service-model): M to N availability support

 In v(-01),Site Availability support primary-back,loadsharing,single.
 In prague meeting, Kireeti Kompella brought up a case where there is M  primary,N backup,loading sharing among M primary, N backups for backup, do  we support M to N availability in service model? How do we support it?

 One relevant question is,In v(-01), can one site provide more than one  attachment? If not, how do we know one site offering backup access is used  for another site offering primary access?

-- 
-------------------------------------------------+----------------------
-------------------------------------------------+---
 Reporter:  [email-masked]                   |      Owner:  Site
     Type:  enhancement                          |  Availability
 Priority:  minor                                |     Status:  new
Component:  draft-ltsd-l3sm-l3vpn-service-model  |  Milestone:
 Severity:  -                                    |    Version:
                                                 |   Keywords:
-------------------------------------------------+----------------------
-------------------------------------------------+---

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Qin Wu <[email-masked]>
Date: Wed, 30 Sep 2015 09:42:59 +0000

Hi,Stephane:
Just want to confirm, two proposals you gave below don't change "one site with one network attachment" assumption? Right?

M to N availability seems, to me, a combination of primary back type and load sharing type. It adds complexity to the basic service model.

Also in the first proposal, do you propose to add "preference" identity instead of "multi-homed" for site-availability 
in addition to existing access-type identities since in the site availability, service type can be
used to distinguish single-home from dual home, or distinguish dual home from multi-homing, what am I missing?

-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2015年9月30日 15:57
收件人: [email-masked]; Qin Wu
主题: RE: [L3sm] [l3sm] #3 (draft-ltsd-l3sm-l3vpn-service-model): M to N availability support

Hi,

Here is what we have :

Thoughts ?

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of l3sm issue tracker
Sent: Wednesday, September 23, 2015 09:38
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] [l3sm] #3 (draft-ltsd-l3sm-l3vpn-service-model): M to N availability support

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Thu, 1 Oct 2015 05:31:43 +0000

> Just want to confirm, two proposals you gave below don't change "one site with one network attachment" assumption? Right?

These are independent items.

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Wednesday, September 30, 2015 11:43
To: LITKOWSKI Stephane SCE/IBNF; [email-masked]
Subject: Re: [L3sm] [l3sm] #3 (draft-ltsd-l3sm-l3vpn-service-model): M to N availability support

Hi,Stephane:

Also in the first proposal, do you propose to add "preference" identity instead of "multi-homed" for site-availability in addition to existing access-type identities since in the site availability, service type can be used to distinguish single-home from dual home, or distinguish dual home from multi-homing, what am I missing?

-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2015年9月30日 15:57
收件人: [email-masked]; Qin Wu
主题: RE: [L3sm] [l3sm] #3 (draft-ltsd-l3sm-l3vpn-service-model): M to N availability support

Hi,

Here is what we have :

Thoughts ?