Subject: [L3sm] Issue#6 : Operational inventory

From: <[email-masked]>
Date: Tue, 8 Dec 2015 14:14:18 +0000

Hi,

Here is a modeling proposal for operational inventory.

I propose to duplicate the three top containers with the extension "-state", this would bring the operational view of each parameter while reading the no "-state" container will provide the configuration view. The "-state" containers are not configurable.
I propose to move the actual-site-start and actual-site-stop to the "sites-state" container as it's a pure operational state.

In addition propose to add the following container in vpn-svc-state :

container site-list {
                list site {
                                key site-id;

                                leaf site-id;
                                leaf site-role;
                }
}

This would provide the list of sites associated to a particular VPN.
I attached a summary tree displaying how it could look.

[Orange logo]<http://www.orange.com/>

Stephane Litkowski
Network Architect
Orange/SCE/EQUANT/OINIS/NET
Orange Expert Future Networks
phone: +33 2 23 28 49 83 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%202%2023%2028%2049%2083%20>
mobile: +33 6 37 86 97 52 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%206%2037%2086%2097%2052%20>
[email-masked]<mailto:[email-masked]>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorization.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange shall not be liable if this message was modified, changed or falsified.
Thank you.

---

From: Qin Wu <[email-masked]>
Date: Wed, 23 Dec 2015 08:30:08 +0000

Hi, folks:
The author of WG document has the following two proposals to address operational inventory issue
http://trac.tools.ietf.org/wg/l3sm/trac/ticket/6
we filed in the issue tracker.

1.       Create three subtrees(vpn-svc-state, sites-state,site-templates-state) for operation state and duplicate parameters defined in three configuration subtree for operation state subtree.

2.       Add a container in vpn-svc-state to describe which site is attached to a particular VPN.
These two proposals haven’t been incorporated into version (-02) of draft-ietf-l3sm-l3vpn-service-model.
https://tools.ietf.org/html/draft-ietf-l3sm-l3vpn-service-model-02
Please review and comment on it and let us know if you have any objection to make such change.

-Qin
发件人: L3sm [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2015年12月8日 22:14
收件人: [email-masked]
主题: [L3sm] Issue#6 : Operational inventory

Hi,

I propose to duplicate the three top containers with the extension “-state”, this would bring the operational view of each parameter while reading the no “-state” container will provide the configuration view. The “-state” containers are not configurable.
I propose to move the actual-site-start and actual-site-stop to the “sites-state” container as it’s a pure operational state.

container site-list {
                list site {
                                key site-id;

                                leaf site-id;
                                leaf site-role;
                }
}

Stephane Litkowski
Network Architect

Thank you.