Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

From: Qin Wu <[email-masked]>
Date: Thu, 3 Dec 2015 15:41:34 +0000

Hi all:

Below is the initial version of draft minutes for Thursday L3SM WG interim session.

Thanks Dan to help take minutes.
Folks, please let us know if you have any correction.

-Qin
===============================================================================
L3SM Working Group Virtual Interim Meeting
Thursday December 5th, 2015. 8am East Coast Time (New York)

BLUE SHEET

Name                    | Affiliation
------------------------+------------------------------------------------
Adrian Farrel           | Old Dog Consulting
Qin Wu                  | Huawei Technologies
Stephane Litkowski      | Orange
Luis Tomotaki           | Verizon
Daniel King             | Old Dog Consulting
Susan Hares             | Huawei Technologies
Scott Mansfield         | Ericsson
Gu Rong                 | China Mobile
Kenichi Ogaki           | KDDI
Aijun Wang              | China Telecom
Victor Santos           | Ericsson
Ignas Bagdonas          |

MINUTES

* Meting logiistics https://mailarchive.ietf.org/arch/msg/l3sm/SJub1aHVQGOQW6rWhthX0fB8Ac8
* Meeting materials https://www.ietf.org/proceedings/interim/2015/12/03/l3sm/proceedings.html
* Etherpad for minutes (this page) http://etherpad.tools.ietf.org:9000/p/l3sm-interim-2015-12-03
* Jabber using [email-masked]<mailto:[email-masked]>
* Blue sheet http://etherpad.tools.ietf.org:9000/p/l3sm-interim-2015-12-03-bluesheet

Agendaa
- Administrivia (Note Well, etc). a
- Introduction
- Open Issues for YANG Data Model for L3VPNservice delivery (draft-ietf-l3sm-l3vpn-servicemodel)
o Open Issues discussion and resolution– http://trac.tools.ietf.org/wg/l3sm/trac/report/1

For a full list of issues and resolution proposals please see: https://www.ietf.org/proceedings/interim/2015/12/03/l3sm/slides/slides-interim-2015-l3sm-1-2.pdf

Issue#1: When customer-nat-address is used
Resolution #1:  Leaf used when NAT is required to access cloud VPN and customer wants to use its ownIP address. If provider provides the public IP,no need to use the leaf
Status #1:  Closed Pending I-D text review.
Discussion on #1:

Aijun asks for more description in the YANG model itself
Stephane shows current model
Agreed OK

Issue#2 : Identify l3vpn svc using id or name or both
Resolution #2:  ID is a string, as per other properties in the model
Status #2: Closed
Discussion on #2:

Agreed OK

Issue#3: M to N availability support
Resolution #3: Modeling sites using a list with a priority, so include access list with a priority.
Status #3:
Discussion on #3:

Qin was asking that M to N availability is supported with access and priority number.
Stephane stated this is suppoted. This new proposal also supports multiple sites, as a list.
Qin also asked if Group I-D was no longer needed, which it is not. Also good solution supported by other operators.
Stephane asked if four priorities was enough, or if more were needed.

Re: Containers/Properties for Network Access Configuration - Conclusions?

o Location - Different site I-D?
o QoS Policy - Per network access link, or site information? Would QoS (cost) be different per accesslink or site? Example of Primary and Backup links given.
o Bandwidth - Moved to access link group
o Maximum Routes -
Security, routing, and services are duplicated with inheritance

Issue#4: site-service-cloud access as grouping
Resolution #4 Already resilved as a separate grouping
Status #4: Closed
Discussion on #4:

Issue#5: Multicast support as raised by Eric Rosen
Resolution #5: : New "provider managed" property, and in Site Properties "property-type"  added
Status #5: Solution proposed.
Discussion on #5:

Stephane will proviode new property proposals will be provided to Eric for review.

Issue#6: Inventory operational state
Resolution #6: Include a new container for inventory state, or an RPC call (sitting above the service orchestrator) to retrieve inventory state.
Status #6: Need to propose to the WG and agree solution.
Discussion on #6:

Luis asked would this info be collected from provision state? Stephane suggested this would not be availible.
Adrian observed that the code used to convert the model into a service request may not utilise this inventory information capability. Sue mentioned that others have mentioned by a vendor that it would be useful to have the ability to configure inventory state. This should be clarified by the operators.

Stephane to take proposals to list and ask anyone who is interested in having the feature to suggest text.

Issue#7: Generic VAS - do we need to create a generic VAS container as VAS are popular in L3VPNs?
Resolution #7: Separate from L3SM
Status #7: Closed
Discussion on #7:

Gu Rong highlighted Generic VAS model which was presented at IETF 94.

Issue#8: Who keeps site locationinformation?
Resolution #8: Text has been fixed
Status #8: Closed
Discussion on #8:

Issue#9: Do we need to model transport constraints, such as: jitter, disjoint, path diversity?
Resolution #9:   Propose a "transport-constraint" group with "constraint-type", "constraint-value" and "constraint-list" (composed of type and values)
Status #9: Authors to propose the resolution in the I-D and provide to the WG
Discussion on #9:

Luis mentioned that they have multicast transport (multiple sites) and bi-directional traffic applications (financial) that will require transport constraints

Duplicate transport constraints for unicast and multicast to give options for separate configuration.
Keep single list entries for each src/dst pair even in the multicast variant.

DO we need to support multiple constraints or just have a single composite (of multiple constraints), have the ability to specify a constraint-list?
Aijun prfers list of constraints and meeting agrees this is OK

What constraints to offer?
Latency
Path diversty
Site diversty
Jitter
Class of service was proposed but rejected

Luis highlighted they have a current implementation that uses the similar proposal. Luis also mentioned that site diversity might also be required, would this be achievable

Issue#10: VPN "merging"
Resolution #10:
Status #10:
Discussion on #10:

VPN is a per site property.
- A site can belong tomultiple VPNs
- How to handle merging of two VPNs?
- Is this an issue the service model has to deal with?

If VPN merging is required to be seamless, then this would be device specific and not service model related.

"Merging" is a confusing term. The objective is NOT to merge VPN1 and VPN2.
The objective is to provide an extranet so that some sites in VPN1 can connect to some sites in VPN2 for some traffic.
This can be solved using a per-site property.

Action: Need to update this issue to make it clear what function was being discussed, also Stephane will send options to the working group- list.
We are specifically looking for people who offer extranet connection between sites from different VPNs

== Other Issues ==

Modeling Customer Specific Info
- Create appropiate containers for Provider Edge and Customer Site routers
- The current  model contains routing parametres that refer to CE and PE relationships
- General agreement is routing info should be split and current proposal will be sent to the list for Kenichi, and working groups, review.

== Conclusions ==

- A number of resolutions have been agreed and will be updated in the I-D
- Chairs would like to see revised I-D based on the agreed points
- Plan to have another interim call at the end of January (2016)
- Chairs to add new tracker items, including security for future discussion.

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Fri, 4 Dec 2015 10:01:30 +0900

Dear All,

It was good having discussion.

As for issue#10, the objective and problem we discussed in the meeting as follows.

The objective is to provide per-VPN extranet service which connects two different VPNs (e.g. VPN1 and VPN2). It means that any sites in VPN1 can access to any sites in VPN2.
The problem is that the current model must update vpn-policy under all the sites belong to these two VPNs in order to offer this service. Especially when this model is used as a customer self-control API, it's not good idea to require customers to update the information of all the sites. (It's not abstracted way, a service model should provide what the consumer wants, not how.)
If a service or customer requires to control per-site vpn-policy, that of current model should be used without setting per-VPN vpn-polity. It depends on each operator's service.
Stephane proposed to use apply-template, but it still cannot solve the problem. When each VPN already has a large number of sites and want to connect each other for the first time, both VPNs must update these sites to apply apply-template on the current model.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

* Jabber using [email-masked]

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: "Aijun Wang" <[email-masked]>
Date: Fri, 4 Dec 2015 09:44:28 +0800

Dear all:

Can we put the list "sites" within the list "vpn-svc", and define the general vpn policy for all sites that within the corresponding vpn service instance?
If doing so, some entries within the current list "sites" can also be dragged out for general usual purposes, for example, "maximum-routes", "security" etc. These parameters are often all same for every site within one VPN service instance. 

If some sites have special requirements, we can achieve this by using some special "site-vpn-policy" within the corresponding site definition.
Is this more acceptable for customers?

Best Regards.

Aijun Wang

China Telecom Corporation Limited Beijing Research Institute 
Intelligent Network Product Line

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

The objective is to provide per-VPN extranet service which connects two different VPNs (e.g. VPN1 and VPN2). It means that any sites in VPN1 can access to any sites in VPN2.
The problem is that the current model must update vpn-policy under all the sites belong to these two VPNs in order to offer this service. Especially when this model is used as a customer self-control API, it's not good idea to require customers to update the information of all the sites. (It's not abstracted way, a service model should provide what the consumer wants, not how.) If a service or customer requires to control per-site vpn-policy, that of current model should be used without setting per-VPN vpn-polity. It depends on each operator's service.
Stephane proposed to use apply-template, but it still cannot solve the problem. When each VPN already has a large number of sites and want to connect each other for the first time, both VPNs must update these sites to apply apply-template on the current model.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

------------------------+-----------------------------------------------
------------------------+-

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Fri, 4 Dec 2015 12:39:04 +0900

Dear Aijun, All,

See inline comments, please.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 10:44 AM
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

[KO] I basically think so.

[KO] Yes, this is my proposal.

[KO] I believe so. As I wrote, when a customer want to globally apply the same policy/attribute to the whole VPN, the current model must update all the sites.

Best Regards.

Aijun Wang

China Telecom Corporation Limited Beijing Research Institute Intelligent Network Product Line

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: <[email-masked]>
Date: Fri, 4 Dec 2015 11:17:21 +0000

Hi,

I'm against this proposal, as I do not want to create any dependency between a particular VPN and a list of sites.
A site can belong to multiple VPNs with any kind of topology, if we attach the site to a single VPN, we come back to the notion of "native VPN" we had at the beginning of the model which was hard to understand and so was removed.

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorization.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange shall not be liable if this message was modified, changed or falsified.
Thank you.

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Sat, 5 Dec 2015 14:23:09 +0900

Dear Stephane and All,

I don't say that sites *must* move under vpn-svc because I understand stephane's use case.
But we already have vpn-svc and some parameters under this are globally applied to all the sites even in the current model.

It depends on operator's use case which is site-oriented or vpn-oriented service.
Our service is vpn-oriented, site has the native VPN. Then, I would just like you to allow other global options to vpn-svc.

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorization.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange shall not be liable if this message was modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Mon, 7 Dec 2015 14:44:37 +0000

Hi Kenichi,

Regarding your proposal of having a simple VPN policy in the vpn-svc container, I do see an issue. One of the key point of the VPN policy is to express the role of the site in the target VPN topology.
If we do a vpn policy at VPN level, we cannot anymore describe site roles in the target VPN which causes an issue.
In an ideal world where all VPNs are any to any, the site role is always the same and there is no issue, but let's think about someone trying to use the vpn-policy (at vpn level) to connect to a Hub & Spoke VPN, how do you deduce the roles of the sites ?

One proposal could be to not call this VPN policy, but creating a container "extranet-vpn-policy" at vpn level which will mandate an extranet VPN architecture from a configuration point of view, deducing automatically the appropriate RT rules to add (like creating a new pair of RTs). This means that the usage is really limited to "simple" extranet-vpns and it does not replace nor compete with the VPN policy at site level.

Could it be a good compromise ?

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Tue, 8 Dec 2015 10:22:12 +0900

Dear Stephane,

See comments inline, please.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

[KO] As we touched on the inheritance in the interim meeting, both vpn and site-role under the current vpn-policy/entries/vpn are option, then the vpn-policy/entries/vpn/vpn just has to inherit that of per-vpn vpn-polity if it is not explicitly indicated.

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref
|  |        +--rw site-role?   Identityref

In the case below, entry 2 just inherit VPN1 as the vpn.

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>
               <site-role>spoke-role</site-role>
           </vpn>
       </entries>
       <entries>
           <id>2</id>
           <vpn>
               <site-role>any-to-any-role</site-role>
           </vpn>
       </entries>
   </vpn-policy>
   ...
</sites>

[KO] For this specific use case, it may be a solution, but is the above proposal better for the general purpose for each operator's own use case?

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: <[email-masked]>
Date: Tue, 8 Dec 2015 08:26:17 +0000

Hi,

Site-role is a mandatory information in order to understand how the site acts in the targeted VPN.
Inheritance from global VPN does not make sense to me as it remains mandatory to configure site-role at site level to make it working, so you do not save anything in term of configuring each site.

While with my new proposal of creating extranet-vpn container, the site-role is automatically deduced from the fact that this is an extranet topology so the current VPN is a sort of client from the extranet VPN.

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Wed, 9 Dec 2015 10:29:19 +0900

Hi Stepahene,

There is two implications. Both vpn and site-role under the current vpn-policy/entries/vpn are mandatory or only the site-role is mandatory?
Which is your opinion?
1) Both are mandatory?
As I wrote, vpn-policy/entries/vpn/vpn can be omitted and inherit the vpn at the vpn level vpn-policy when it is set. Then, only the site-role is explicitly set to each site. But, it's optional usage and we can also set both vpn and site-role at each site.

2) Only the site-role is mandatory?
In the case that hub-spoke is set to vpn-svc/topology, I understand the site-role has to be set in order to identify the role. However, do we need set any-to-any-role to all the site, when any-to-any is set to vpn-svc/topology?
Isn't it verbose?

So, should we set mandatory for these?

Also, the draft should be updated if these are mandatory. Option "?" must be removed from the node in the tree diagram and "mandatory true" must be stated in the module. Nobody can discuss on the same baseline.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: <[email-masked]>
Date: Wed, 9 Dec 2015 08:09:01 +0000

Both are mandatory, this has been fixed in the next revision

Your inheritance does not make sense to me, as you will still have to configure the site role under each site, so there is no gain compare to setting both vpn and site-role at site level.

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Wednesday, December 09, 2015 02:29
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stepahene,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Wed, 9 Dec 2015 17:27:09 +0900

Hi Stephane,

I can't still understand why any-to-any-role must be set to each site role, when vpn-svc/topology is any-to-any.

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 02:29
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stepahene,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: <[email-masked]>
Date: Wed, 9 Dec 2015 09:26:28 +0000

Hi,

I do not really see why you say that site-based design is more suitable for the network (=device) yang model.
VPN technologies allow a site to be part of multiple VPNs and this is widely deployed (especially for major accounts). So to handle this you have two way of modeling :

- managing VPN and sites independently (as proposed today), and add attributes in the site for the VPN attachments.

- choose one VPN as "native" VPN for a site (in this case, you can have the site as child of the VPN), and add attributes in the site for additional VPN attachments.

Stephane

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]] 
Sent: Wednesday, December 09, 2015 09:39
To: LITKOWSKI Stephane SCE/OINIS; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi，stephane:

For customer to apply one vpn service, they often treat the sites within it in a whole. That is to say, most of the container items under the list "sites" will be same, and most of the final data tree will be duplicate if we design this model based strongly on the sites.
And IMO, the site-based design strategy is more suitable for the network Yang model, which will be deployed onto every router within that site directly. For service yang model, we should adopt the customer and service centric design philosophy, that is to say, pay more attention to the common attributes of one vpn service, not the specific requirement of every site.
So, I still recommend we put the list "sites" under the list "vpn-svc", and if some sites have special requirement, then just add the required container under this site. That is to say, for the container items that under the sites, their existences option is 0-1. And most of them will not actually emerged. The final data structure of such Yang model will be very concise when compare with that based on the present l3vpn-service model.  

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 02:29
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stepahene,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Thu, 10 Dec 2015 10:09:34 +0900

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, December 09, 2015 6:26 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

I do not really see why you say that site-based design is more suitable for the network (=device) yang model.
VPN technologies allow a site to be part of multiple VPNs and this is widely deployed (especially for major accounts).

[KO] So, the current model seems network technology centric, not service centric. A service model should focus not on what kind of usages the existing VPN technology allows, but on how our customers use VPN. If another L3VPN technology exists and doesn't allow per-site policy or an operator doesn't use per-site policy, the current site-level some mandatory parameters don't make sense.

So to handle this you have two way of modeling :

[KO] So, why do we have to choose the specific service model biased to the specific service use case?
My compromise proposal is to duplicate potential parameters under vpn-svc as option like some parameters even in the current model. Then, some mandatory parameters under site is changed to option.
Doesn't this accommodate both Aijun's and us, and your use cases?

Stephane

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 09:39
To: LITKOWSKI Stephane SCE/OINIS; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi，stephane:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 02:29
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stepahene,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Thu, 10 Dec 2015 10:11:19 +0000

Hi,

A site will always be able to be part of multiple VPNs whatever the technology is (IPSec, L2TP, L3VPN ...), so we need to do with it.
Now the question is how do we model this ?
As I said, I seen two ways ... but now I see third one :

Keeping the site list separated but remove the vpn-policy.
Create a site-list within the vpn-svc container which will only contains the list of sites attached to this VPN with their role.

vpn-svc
   <vpn-config>
   Site-list [site-id]
        Site-id   svc-id
        Site-role site-role
!
Sites [site-id]
  <site-config> with no more VPN policy

It would so be possible to attach the same site ID to multiple VPNs.
I really want to keep the site configuration outside the VPN, because most of the configuration is agnostic to the VPN attachment and it looks better to manage the multiVPN attachment.
So the idea is really for customer to create sites, and attach them to the appropriate VPNs it is managing.

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, December 10, 2015 02:10
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, December 09, 2015 6:26 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Stephane

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 09:39
To: LITKOWSKI Stephane SCE/OINIS; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi，stephane:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 02:29
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stepahene,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Fri, 11 Dec 2015 09:08:34 +0900

Hi Stephane,

If a customer has only a VPN, the list under vpn-svc is troublesome. The customer must describe both the list and the separated sites at once, though the sites themselves are the list.

As I wrote, my proposal is to just duplicate some potential parameters, which may be globally applied to all the site, under vpn-svc as option. Also, some mandatory parameters under site is changed to option.

      +--rw l3vpn-svc
         +--rw vpn-svc* [id]
         |  +--rw id                    string
         |  +--rw topology              identityref
         |  +--rw vpn-policy?
         |  |  +--rw entries* [id]
         |  |     +--rw id              uint32
         |  |     +--rw vpn
         |  |        +--rw vpn?         leafref
            ...

         +--rw sites* [site-id]
         |  +--rw site-id               string
         |  +--rw vpn-policy?
         |  |  +--rw entries* [id]
         |  |     +--rw id              uint32
         |  |     +--rw vpn
         |  |        +--rw vpn?         leafref
         |  |        +--rw site-role?   identityref

And, the following implications just have to be defined.

vpn-svc/id is also used to specify vpn-policy/vpn/vpn.
If the uniqueness of a parameter is implicitly kept in a transaction or request, each parameter needs not to be explicitly indicated. But, to keep the consistency among multiple transactions, the implicit parameter should be set to appropriate data node by the operator's management system internally.
I believe this should improve the model usability for customers.

These are exercises.

Case1: Customer A has an any-to-any VPN
Customer doesn’t want to specify the detail in each site. Then, vpn-svc/id customerA_VPN1 is implicitly set to site1's vpn-policy by the management system, when only a vpn-svc is defined in a request.

<vpn-svc>
   <id>customerA_VPN1</id>
   <topology>any-to-any</topology>
   ...
</vpn-svc>
<sites>
   <site-id>site1</site-id>
   ...
</sites>

Case2: Customer A has an hub-spoke VPN
Must indicate hub or spoke role to each site to identify the role.

<vpn-svc>
   <id>customerA_VPN1</id>
   <topology>hub-spoke</topology>
   ...
</vpn-svc>
<sites>
   <site-id>site1</site-id>
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <site-role>hub-role</site-role>
           <vpn>
       </entries>
   </vpn-policy>
   ...
</sites>

Case3: Customer A has two VPNs
Must indicate VPN to identify each site to belong to, when multiple vpn-svc are defined in a request.

<vpn-svc>
   <id>customerA_VPN1</id>
   <topology>hub-spoke</topology>
   ...
</vpn-svc>
<vpn-svc>
   <id>customerA_VPN2</id>
   <topology>any-to-any</topology>
   ...
</vpn-svc>
<sites>
   <site-id>site1</site-id>
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>customerA_VPN1</vpn>
               <site-role>hub-role</site-role>
           <vpn>
       </entries>
       <entries>
           <id>2</id>
           <vpn>
               <vpn>customerA_VPN2</vpn>
           <vpn>
       </entries>
   </vpn-policy>
   ...
</sites>

Case4: Customer A has an any-to-any VPN and an extranet to Customer B’s VPN
Each site can access Customer A’s VPN1 and Customer B’s VPN3.

<vpn-svc>
   <id>customerA_VPN1</id>
   <topology>any-to-any</topology>
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>customerB_VPN3</vpn>
           <vpn>
       </entries>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   <site-id>site1</site-id>
   ...
</sites>

Does this make sense?

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, December 10, 2015 7:11 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

vpn-svc
   <vpn-config>
   Site-list [site-id]
        Site-id   svc-id
        Site-role site-role
!
Sites [site-id]

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, December 10, 2015 02:10
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, December 09, 2015 6:26 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Stephane

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 09:39
To: LITKOWSKI Stephane SCE/OINIS; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi，stephane:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 02:29
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stepahene,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: <[email-masked]>
Date: Fri, 11 Dec 2015 08:22:45 +0000

Hi,

In your proposal how do you differentiate a misconfiguration (missing VPN parameter) from a real will to attach ?
In your case 1 and 2, I do not see in the XML provided how you can do any inheritance, as site and VPN are not linked by any way. Note sure to catch what you mean by :" vpn-svc/id is also used to specify vpn-policy/vpn/vpn. If the uniqueness of a parameter is implicitly kept in a transaction or request, each parameter needs not to be explicitly indicated. But, to keep the consistency among multiple transactions, the implicit parameter should be set to appropriate data node by the operator's management system internally."

Moreover you are providing multiple ways of configuring VPN attachments which will IMO brings more confusion and possible errors while having a single consistent one would be better.

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Friday, December 11, 2015 01:09
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane,

      +--rw l3vpn-svc
         +--rw vpn-svc* [id]
         |  +--rw id                    string

         +--rw sites* [site-id]
         |  +--rw site-id               string
         |  +--rw vpn-policy?
         |  |  +--rw entries* [id]
         |  |     +--rw id              uint32
         |  |     +--rw vpn
         |  |        +--rw vpn?         leafref

These are exercises.

<vpn-svc>
   <id>customerA_VPN1</id>

<vpn-svc>
   <id>customerA_VPN1</id>

<vpn-svc>
   <id>customerA_VPN1</id>

Case4: Customer A has an any-to-any VPN and an extranet to Customer B’s VPN Each site can access Customer A’s VPN1 and Customer B’s VPN3.

<vpn-svc>
   <id>customerA_VPN1</id>

Does this make sense?

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, December 10, 2015 7:11 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

vpn-svc
   <vpn-config>
   Site-list [site-id]
        Site-id   svc-id
        Site-role site-role
!
Sites [site-id]

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, December 10, 2015 02:10
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, December 09, 2015 6:26 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Stephane

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 09:39
To: LITKOWSKI Stephane SCE/OINIS; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi，stephane:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 02:29
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stepahene,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Mon, 14 Dec 2015 10:47:08 +0900

Hi Stephane,

>From a service model perspective, why do we have to force our customer to indicate the detail configuration, the relationship between two data? In the case 1 and 2, only one vpn-svc exists in this transaction, then the relationship between the vpn-svc and each site is obvious. Even in the current model, some parameters like cloud-access allow this implicit relationship.
Also, from an interface principle, the input of two lists, the list under vpn-svc and separated site-lists, will rather cause a misconfiguration. How do we make our customer to input these two lists keeping the consistency in these cases?

I have a different opinion. Although a single consistent way sounds good, it means *not* providing the optimal way for any use case. If our customer needs only one use case or an operator offers only one use case, this consistent way must be troublesome.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, December 11, 2015 5:23 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, December 11, 2015 01:09
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane,

      +--rw l3vpn-svc
         +--rw vpn-svc* [id]
         |  +--rw id                    string

         +--rw sites* [site-id]
         |  +--rw site-id               string
         |  +--rw vpn-policy?
         |  |  +--rw entries* [id]
         |  |     +--rw id              uint32
         |  |     +--rw vpn
         |  |        +--rw vpn?         leafref

These are exercises.

<vpn-svc>
   <id>customerA_VPN1</id>

<vpn-svc>
   <id>customerA_VPN1</id>

<vpn-svc>
   <id>customerA_VPN1</id>

<vpn-svc>
   <id>customerA_VPN1</id>

Does this make sense?

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, December 10, 2015 7:11 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

vpn-svc
   <vpn-config>
   Site-list [site-id]
        Site-id   svc-id
        Site-role site-role
!
Sites [site-id]

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, December 10, 2015 02:10
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, December 09, 2015 6:26 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Stephane

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 09:39
To: LITKOWSKI Stephane SCE/OINIS; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi，stephane:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 02:29
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stepahene,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: <[email-masked]>
Date: Mon, 14 Dec 2015 13:31:48 +0000

Hi,

The implicit relationship does work only for the first (or first set of) site.
When we deploy IPVPNs for customers, all sites are not provisioned at the same time and customer are adding/removing sites from their IPVPNs.
So when you add a new site (days, weeks or months) after the VPN creation, you need to explicitly set the VPN attachment whatever how it is done (hierarchy, pointer ...).

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Monday, December 14, 2015 02:47
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, December 11, 2015 5:23 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, December 11, 2015 01:09
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane,

      +--rw l3vpn-svc
         +--rw vpn-svc* [id]
         |  +--rw id                    string

         +--rw sites* [site-id]
         |  +--rw site-id               string
         |  +--rw vpn-policy?
         |  |  +--rw entries* [id]
         |  |     +--rw id              uint32
         |  |     +--rw vpn
         |  |        +--rw vpn?         leafref

These are exercises.

<vpn-svc>
   <id>customerA_VPN1</id>

<vpn-svc>
   <id>customerA_VPN1</id>

<vpn-svc>
   <id>customerA_VPN1</id>

<vpn-svc>
   <id>customerA_VPN1</id>

Does this make sense?

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, December 10, 2015 7:11 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

vpn-svc
   <vpn-config>
   Site-list [site-id]
        Site-id   svc-id
        Site-role site-role
!
Sites [site-id]

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, December 10, 2015 02:10
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, December 09, 2015 6:26 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Stephane

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 09:39
To: LITKOWSKI Stephane SCE/OINIS; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi，stephane:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 02:29
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stepahene,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Tue, 15 Dec 2015 09:52:21 +0900

Hi Stephane,

I basically agree with you.
The implicit relationship only works whenever both only a vpn-svc and (set of) site are defined in a transaction, not only for the first time.
If only (a set of) site or multiple vpn-svc with them exists in a transaction, we must explicitly set the VPN attachment to uniquely identify which vpn the site belongs to.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 14, 2015 10:32 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Monday, December 14, 2015 02:47
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, December 11, 2015 5:23 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, December 11, 2015 01:09
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane,

      +--rw l3vpn-svc
         +--rw vpn-svc* [id]
         |  +--rw id                    string

         +--rw sites* [site-id]
         |  +--rw site-id               string
         |  +--rw vpn-policy?
         |  |  +--rw entries* [id]
         |  |     +--rw id              uint32
         |  |     +--rw vpn
         |  |        +--rw vpn?         leafref

These are exercises.

<vpn-svc>
   <id>customerA_VPN1</id>

<vpn-svc>
   <id>customerA_VPN1</id>

<vpn-svc>
   <id>customerA_VPN1</id>

<vpn-svc>
   <id>customerA_VPN1</id>

Does this make sense?

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, December 10, 2015 7:11 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

vpn-svc
   <vpn-config>
   Site-list [site-id]
        Site-id   svc-id
        Site-role site-role
!
Sites [site-id]

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, December 10, 2015 02:10
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, December 09, 2015 6:26 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Stephane

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 09:39
To: LITKOWSKI Stephane SCE/OINIS; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi，stephane:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 02:29
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stepahene,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: Qin Wu <[email-masked]>
Date: Wed, 23 Dec 2015 08:57:18 +0000

Hi, all:
I agree site level design is not designed for network element model.
It looks what we debate a lot here is whether VPN and site should be managed separately or establish inheritance between them.
Whether some parameters for site level vpn-policy should be mandatory or optional, I think the big
Challenge we need to conquer is to how to avoid mis-configuration if we manage VPN and site separately.

The solution we proposed during interim call seems to like this: duplicate parameters (which may be globally applied to all the site) under “vpn-svc”, and also maintain state.
As follow up, Stephane has given the following two proposals below,
another proposal from Stephane was also given in the separate email
https://mailarchive.ietf.org/arch/msg/l3sm/aZ_NqIdHRA39GkZ8OFIydFmsBKg

Please review and comment these proposals? Let us know if you have a better proposal. Let us know if you are the people who operation experience to offer extranet connection between sites from different VPNs.
Also we appreciate authors of document can join together with Kenichi and Aijun Wang to find a compromised solution on this issue soon. Thanks! 
Wish you all Merry Christmas and Happy new year.

Regards!
-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2015年12月9日 17:26
收件人: Aijun Wang; 'Ogaki, Kenichi'; 'Aijun Wang'; Qin Wu; [email-masked]
抄送: [email-masked]
主题: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Stephane

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 09:39
To: LITKOWSKI Stephane SCE/OINIS; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi，stephane:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 02:29
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stepahene,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Thu, 24 Dec 2015 12:33:21 +0900

Dear All,

>The solution we proposed during interim call seems to like this: duplicate parameters (which may be globally 
>applied to all the site) under “vpn-svc”, and also maintain state.
>As follow up, Stephane has given the following two proposals below, another proposal from Stephane was also 
>given in the separate email https://mailarchive.ietf.org/arch/msg/l3sm/aZ_NqIdHRA39GkZ8OFIydFmsBKg

Alternative proposal is here:
https://mailarchive.ietf.org/arch/msg/l3sm/CKEOpNtU-fe5AbqLfTfkd_ywAA8

I appreciate comments and the feedback, especially from other operators.

Merry X'mas & Happy New Year,
Kenichi

-----Original Message-----
From: Qin Wu [mailto:[email-masked]] 
Sent: Wednesday, December 23, 2015 5:57 PM
To: [email-masked]; Aijun Wang; 'Ogaki, Kenichi'; 'Aijun Wang'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi, all:
I agree site level design is not designed for network element model.
It looks what we debate a lot here is whether VPN and site should be managed separately or establish inheritance between them.
Whether some parameters for site level vpn-policy should be mandatory or optional, I think the big Challenge we need to conquer is to how to avoid mis-configuration if we manage VPN and site separately.

The solution we proposed during interim call seems to like this: duplicate parameters (which may be globally applied to all the site) under “vpn-svc”, and also maintain state.
As follow up, Stephane has given the following two proposals below, another proposal from Stephane was also given in the separate email https://mailarchive.ietf.org/arch/msg/l3sm/aZ_NqIdHRA39GkZ8OFIydFmsBKg

Regards!
-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2015年12月9日 17:26
收件人: Aijun Wang; 'Ogaki, Kenichi'; 'Aijun Wang'; Qin Wu; [email-masked]
抄送: [email-masked]
主题: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Stephane

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 09:39
To: LITKOWSKI Stephane SCE/OINIS; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi，stephane:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 02:29
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stepahene,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Thu, 24 Dec 2015 08:17:57 +0000

Hi,

I would prefer a model design that keeps all relevant site-specific configuration inside the "sites" list entries, including the policies, as far as possible.

For instance, to me it would make sense if the model would allow adding or removing a site with a single NETCONF/RESTCONF operation. This is much simple rwith a model structure that avoisd having to manipulate different parts of the tree "in parallel". Unless I miss something, the proposed solution in

would require two different list entries to be present before a site can actually be configured. I would prefer to void such dependencies as far as possible, in order to simplify the use of the model and avoid internal inconsistencies.

One specific constraint is that RESTCONF right now has no built-in support for transactions. Therefore, it is not clear to me how to really avoid inconsistencies in even simple operations such as adding or removing sites, if RESTCONF is used. Of course, an implementation could rely on additional transaction logic to sort that out, but that logic would possibly be implementation-specific.

Thanks

Michael

________________________________________
Von: L3sm [[email-masked]]&quot; im Auftrag von &quot;Qin Wu [[email-masked]]
Gesendet: Mittwoch, 23. Dezember 2015 09:57
An: [email-masked]; Aijun Wang; 'Ogaki, Kenichi'; 'Aijun Wang'; [email-masked]
Cc: [email-masked]
Betreff: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi, all:

Regards!
-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2015年12月9日 17:26
收件人: Aijun Wang; 'Ogaki, Kenichi'; 'Aijun Wang'; Qin Wu; [email-masked]
抄送: [email-masked]
主题: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Stephane

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 09:39
To: LITKOWSKI Stephane SCE/OINIS; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi，stephane:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 02:29
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stepahene,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          |

MINUTES

Agendaa

- Introduction

Discussion on #1:

Agreed OK

Status #2: Closed

Discussion on #2:

Agreed OK

Status #3:

Discussion on #3:

o Maximum Routes -

Status #4: Closed

Discussion on #4:

Discussion on #5:

Discussion on #6:

Status #7: Closed

Discussion on #7:

Status #8: Closed

Discussion on #8:

Discussion on #9:

Latency

Path diversty

Site diversty

Jitter

Issue#10: VPN "merging"

Resolution #10:

Status #10:

Discussion on #10:

== Other Issues ==

== Conclusions ==

---

From: Qin Wu <[email-masked]>
Date: Thu, 24 Dec 2015 10:17:21 +0000

Kenichi:
Thanks for correction, I missed your proposal below.
Happy new year of Monkey and Merry Christmas.

-Qin
-----邮件原件-----
发件人: Ogaki, Kenichi [mailto:[email-masked]] 
发送时间: 2015年12月24日 11:33
收件人: Qin Wu; [email-masked]; 'Aijun Wang'; 'Aijun Wang'; [email-masked]
抄送: [email-masked]
主题: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

>The solution we proposed during interim call seems to like this: 
>duplicate parameters (which may be globally applied to all the site) under “vpn-svc”, and also maintain state.

-----Original Message-----
From: Qin Wu [mailto:[email-masked]]
Sent: Wednesday, December 23, 2015 5:57 PM
To: [email-masked]; Aijun Wang; 'Ogaki, Kenichi'; 'Aijun Wang'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi, all:

Regards!
-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2015年12月9日 17:26
收件人: Aijun Wang; 'Ogaki, Kenichi'; 'Aijun Wang'; Qin Wu; [email-masked]
抄送: [email-masked]
主题: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Stephane

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 09:39
To: LITKOWSKI Stephane SCE/OINIS; 'Ogaki, Kenichi'; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi，stephane:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 02:29
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stepahene,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 08, 2015 5:26 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 02:22
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

+--rw sites* [site-id]
|  +--rw vpn-policy
|  |  +--rw entries* [id]
|  |     +--rw id        uint32
|  |     +--rw filter
|  |     +--rw vpn
|  |        +--rw vpn?         leafref

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN1</vpn>
   </vpn-policy>
   ...
</vpn-svc>
<sites>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn>VPN2</vpn>

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Best Regards.

Aijun Wang

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

-Qin

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

Agendaa

- Introduction

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

Discussion on #6: 

 

Status #7: Closed

Discussion on #7: 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

Latency

Path diversty

Site diversty

Jitter

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

== Other Issues ==    

== Conclusions ==