Subject: Re: [L3sm] I-D Action: draft-wu-l3sm-rfc8049bis-00.txt

From: Qin Wu <[email-masked]>
Date: Thu, 22 Jun 2017 12:13:31 +0000

Hi,L3SMers:
Thank Jan for excellent YANG doctor review and valuable inputs based on Service Model deployment experience.
Thanks for L3SM design team to engage in the discussion on the list and help address all of comments.
Here is the initial version of RFC8049bis.
https://tools.ietf.org/html/draft-wu-l3sm-rfc8049bis-00
Jan, please review it and let us know if you have any additional comments.

-Qin
-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2017年6月22日 20:05
收件人: [email-masked]
主题: I-D Action: draft-wu-l3sm-rfc8049bis-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : YANG Data Model for L3VPN Service Delivery
        Authors         : Qin Wu
                          Stephane Litkowski
                          Luis Tomotaki
                          Kenichi Ogaki
	Filename        : draft-wu-l3sm-rfc8049bis-00.txt
	Pages           : 175
	Date            : 2017-06-22

Abstract:
   This document defines a YANG data model that can be used for
   communication between customers and network operators and to deliver
   a Layer 3 provider-provisioned VPN service.  This document is limited
   to BGP PE-based VPNs as described in RFCs 4026, 4110, and 4364.  This
   model is intended to be instantiated at the management system to
   deliver the overall service.  It is not a configuration model to be
   used directly on network elements.  This model provides an abstracted
   view of the Layer 3 IP VPN service configuration components.  It will
   be up to the management system to take this model as input and use
   specific configuration models to configure the different network
   elements to deliver the service.  How the configuration of network
   elements is done is out of scope for this document.

   If approved, this document obsoletes RFC 8049.  The changes are a
   series of small fixes to the YANG module, and some clarifications to
   the text.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-wu-l3sm-rfc8049bis/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-wu-l3sm-rfc8049bis-00
https://datatracker.ietf.org/doc/html/draft-wu-l3sm-rfc8049bis-00

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Jan Lindblad (jlindbla)" <[email-masked]>
Date: Fri, 30 Jun 2017 10:02:23 +0000

Qin,

Hi,L3SMers:

I had a quick scan and I think it all looks good. Tried all the examples. Pretty much all of them still have a lot of dependencies on data not provided and omit many mandatory fields. We can live with that.

I found two examples with minor mistakes in them.

Line 4597:

      <?xml version="1.0"?>
      <l3vpn-svc xmlns="urn:ietf:params:xml:ns:yang:ietf-l3vpn-svc">
        <vpn-services>
          <vpn-service>
            <vpn-id>VPNA</vpn-id>
          </vpn-service>
        </vpn-services>
        <sites>
          <site>
            <site-id>SITE1</site-id>
            <routing-protocols>
              <routing-protocol>
                <type>static</type>
                <static>
                              <cascaded-lan-prefixes>
                  <ipv4-lan-prefixes>
                  <lan>192.0.2.0/24</lan>
                  <next-hop>203.0.113.1/32</next-hop>

The next-hop address is modeled as inet:ipv4-address, so the above value is invalid. Should be: "203.0.113.1"

Line 5070:

     <?xml version="1.0"?>
     <l3vpn-svc xmlns="urn:ietf:params:xml:ns:yang:ietf-l3vpn-svc">
       <vpn-services>
         <vpn-service>
           <vpn-id>VPNA</vpn-id>
         </vpn-service>
       </vpn-services>
       <sites>
         <site>
           <site-id>SITE1</site-id>
           <service>
             <qos>
               <qos-classification-policy>
                 <rule>
                   <id>SvrA-http</id>
                   <match-flow>
                     <ipv4-src-prefix>192.0.2.0/24</ipv4-src-prefix>
                     <ipv4-dst-prefix>203.0.113.1/32</ipv4-dst-prefix>
                     <l4-dst-port>80</l4-dst-port>
                     <protocol-type>tcp</protocol-type>

The leaf I believe the example author is thinking of is called <protocol-field>. There is no leaf called protocol-type at this location, even if the type of the leaf protocol-field is called so.

The Swedish vacation season is on; I won't have time for more reviews until the beginning of August. Have a great summer! ;-)

Best Regards,
/jan

---

From: Qin Wu <[email-masked]>
Date: Fri, 30 Jun 2017 12:02:52 +0000

Thank Jan for quick feedback, We will fix mistake you raised in the next update.
Have a good vacation. :)

-Qin
发件人: Jan Lindblad (jlindbla) [mailto:[email-masked]]
发送时间: 2017年6月30日 18:02
收件人: Qin Wu
抄送: [email-masked]; Benoit Claise (bclaise); [email-masked]
主题: Re: [L3sm] I-D Action: draft-wu-l3sm-rfc8049bis-00.txt

Qin,

Hi,L3SMers:

Line 4597:

      <?xml version="1.0"?>

Line 5070:

     <?xml version="1.0"?>

Best Regards,
/jan