Subject: End to end QoS guarantee for users in VPN

From: "Li Xiangjun" <[email-masked]>
Date: Thu, 19 Feb 2004 10:08:06 +0800

hi;
    Traditionally we only manages the toal QoS of VPN. In fact,many users in the enterprise use the VPN,that means the VPN carries different kinds of services(VoIP.HTTP.VoD et ac.) of different users in the enterprise. How to assure every user's QoS, that is to say every flow's QoS ?
    Is there any suggestion about it?

---

From: Jeff Helmer <[email-masked]>
Date: Fri, 20 Feb 2004 15:49:38 -0800 (PST)

Neil,
 
I wanted to understand the phrase "traffic isolation on a per VPN basis" that you used. Do you mean per-VPN LSPs (without any merging) between the PE routers (assuming a MPLS core)? This would ensure each VPN has a guaranteed end-to-end bandwidth which may not be possible if all VPNs between a pair of PE routers used the same tunnel LSP. The DS codepoint would then signify the relative importance of different kinds of traffic in the same VPN.
 
- Jeff

Jeff Helmer <[email-masked]> wrote:
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Li Xiangjun
Sent: 19 February 2004 02:08
To: [email-masked]
Subject: End to end QoS guarantee for users in VPN

hi;
    Traditionally we only manages the toal QoS of VPN. In fact,many users in the enterprise use the VPN,that means the VPN carries different kinds of services(VoIP.HTTP.VoD et ac.) of different users in the enterprise. How to assure every user's QoS, that is to say every flow's QoS ?
    Is there any suggestion about it? 
Excellent question.  And I agree with you.  As a general observation it is not possible to differentiate 'urgency' (ie how fast?) from 'importance' (ie how critical is this pkt vs others?) from just a DS codepoint at the pkt level.  One can imagine cases in 1 VPN where a given voice call is mission critical and others where it is not....same applies to data applications.  Further, there is a difference between the treatment of public traffic and private traffic.....and in fact some public traffic that belongs to the same 'urgency' class can also have different 'importance'.  One can use the LSP as a survivavbility differentiator, ie to isolate different VPN instances......however, this requires p2p LSPs because if the traffic gets merged on lower mp2p LSPs then per VPN QoS/perf/failure-handling behaviour is not simple to provide. The usual response to such uncertainty in these quantities is to significanly overprovide.......which is not a good solution.
 
There are deeper issues here of pricing for 'fair/meaningful' services that, in addition to the urgency vs importance angle, is affected by BW borrowing between DS classes.....and these can't be easily sorted IMO if the network arch is unable to deliver traffic isolation on a per VPN basis.
 
regards, Neil

---------------------------------
Do you Yahoo!?
Yahoo! Mail SpamGuard - Read only the mail you want.

---------------------------------
Do you Yahoo!?
Yahoo! Mail SpamGuard - Read only the mail you want.

---

From: [email-masked]
Date: Sat, 21 Feb 2004 00:05:00 -0000

This needs a longish response .....so I'll get back to you off-list.
 
regards, Neil

-----Original Message-----
From: Jeff Helmer [mailto:[email-masked]]
Sent: 20 February 2004 23:50
To: Harrison,N,Neil,IKR2 R
Cc: [email-masked]
Subject: Re: FW: End to end QoS guarantee for users in VPN

Neil,

- Jeff

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Li Xiangjun
Sent: 19 February 2004 02:08
To: [email-masked]
Subject: End to end QoS guarantee for users in VPN

hi;

 
regards, Neil

  _____  

Do you Yahoo!?
Yahoo!  <http://us.rd.yahoo.com/mailtag_us/*http://antispam.yahoo.com/tools?tool=1> Mail SpamGuard - Read only the mail you want.

  _____  

Do you Yahoo!?
Yahoo!  <http://us.rd.yahoo.com/mailtag_us/*http://antispam.yahoo.com/tools?tool=1> Mail SpamGuard - Read only the mail you want.