Subject: Re: Multi-As Backbones

From: Marc Binderberger <[email-masked]>
Date: Mon, 9 Feb 2004 15:14:25 +0100

Hi Roger,

>  draft-ietf-l3vpn-rfc2547bis-01.txt specifies the multi-AS Backbone 
> scenario.
>
> 10. c) Multihop EBGP redistribution of labeled VPN-IPv4 routes between
>          source and destination ASes, with EBGP redistribution of
>          labeled IPv4 routes from AS to neighboring AS.
>
> The ASBR  maintains labeled IPv4  /32 routes to the PE routers within 
> its AS and uses EBGP to  distribute the labeled routes to other ASes.
>

> Between, two ASs, it uses BGP to distribute the labels, but in that 
> case, how is the labeled path within the AS Maintained. Is it using 
> BGP itself. Or is  LDP/RSVP used to
> distribute the labels within the same AS?

Redistributing the eBGP-learned /32 into your IGP (thus using LDP/RSVP) 
works. A colleague of mine has tested this. Obviously this has some 
limitations with scalability.

Using iBGP IPv4+label - haven't tested yet as no IOS for 7600 (our PE 
plattform) was available supporting this. As I understand the theory 
this results in a packet with 3 labels minimum: the MP-BGP VPN label at 
the bottom, then the IPv4 next hop label and topmost the LDP label to 
the ASBR.

Regards, Marc
--
Marc Binderberger    <[email-masked]>    Powered by *BSD ;-)

---

From: Roger Pottier <[email-masked]>
Date: Mon, 9 Feb 2004 08:28:28 -0800 (PST)

Hi Marc, 
 
 Thank you for the response.  

Marc Binderberger <[email-masked]> wrote:

Hi Roger,

As you said, this could have some scaling limitations. Does LDP assign a label to each route learnt by the IGP. I think, LDP does not assign labels for BGP Learnt routes. Can cisco be configured to send labels for some BGP Learnt routes?

The IPv4 Nexthop Label (Middle one) would be assigned by the ASBR?

Regards,

Roger

Regards, Marc
--
Marc Binderberger Powered by *BSD ;-)

---------------------------------
Do you Yahoo!?
Yahoo! Finance: Get your refund fast by filing online

---

From: Marc Binderberger <[email-masked]>
Date: Tue, 10 Feb 2004 00:35:22 +0100

Hi Roger,

> As you said, this could have some scaling limitations. Does LDP assign 
> a label to each route learnt by the IGP. I think, LDP does not assign 
> labels for BGP Learnt routes. Can cisco be configured to send labels 
> for some BGP Learnt routes?

 From a test setup. The box is a 7507 w/ 12.0(25)S1:

router bgp 65017
  bgp router-id 192.168.249.250
  bgp cluster-id 3239121353
  bgp log-neighbor-changes
  bgp deterministic-med
  bgp bestpath compare-routerid
  neighbor 192.168.249.17 remote-as 65018
  neighbor 192.168.249.17 password 7 070D2D4D460B151015100E1E4A6465
  !
  address-family ipv4
  redistribute isis TEST level-2 route-map ISIS-TO-BGP
  neighbor 192.168.249.17 activate
  neighbor 192.168.249.17 send-label
  no auto-summary
  no synchronization
  exit-address-family

R1-7507#show ip bgp
BGP table version is 4, local router ID is 192.168.249.250
Status codes: s suppressed, d damped, h history, * valid, > best, i - 
internal,
               S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

    Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.249.251/32
                     192.168.249.46          10         32768 ?
*> 192.168.17.206/32
                     192.168.249.17          10             0 65018 ?

R1-7507#show ip bgp 192.168.17.206/32
BGP routing table entry for 192.168.17.206/32, version 4
Paths: (1 available, best #1)
   Not advertised to any peer
   65018
     192.168.249.17 from 192.168.249.17 (192.168.249.241)
       Origin incomplete, metric 10, localpref 100, valid, external, 
best,
       mpls labels in/out 106/18

So R1 receives label "18" via eBGP, the LDP binds local label "106". 
This happens even without a redistribution into the IGP.

On router "R3" (belonging to AS65017):

R3-7204#show mpls ldp bindings 192.168.17.206 32 detail
   tib entry: 192.168.17.206/32, rev 37
         local binding:  tag: 203
           Advertised to:
           192.168.249.250:0
         remote binding: tsr: 192.168.249.250:0, tag: 106

BTW, with 12.2(18)S it did not work.

> The IPv4 Nexthop Label (Middle one) would be assigned by the ASBR?

Yes. But let me try to get 1-2 more test boxes in the setup. Seeing is 
believing :-)

Regards, Marc

---

From: Roger Pottier <[email-masked]>
Date: Tue, 10 Feb 2004 11:15:02 -0800 (PST)

Hi Marc,
 
 Between the ASBRs at the two ASes, i think you have send-label configured for ipv4 
address family. Does that result in the ASBR sending out labels for each PE, within
 its own AS. Or does it send labels only for its own router ID? 
 
 For 10(b) with no multihop MP-EBGP, how are the labels exchanged between the
 ASBRs, to each other - is it using EBGP ipv4+ Label connection.
 
Regards,
Roger

router bgp 65017

R1-7507#show ip bgp

Regards, Marc

---

From: Roger Pottier <[email-masked]>
Date: Fri, 20 Feb 2004 10:47:00 -0800 (PST)

Hi,
 
 If i have "send label" configured for a BGP peer, do the peers need to be on directly
connected interfaces? If it is not, how would the MPLS switches in between know 
about the labels? 
And if it is on directly connected interfaces, does it allocate a label from  the interface label spaceof that interface?
 
 I guess, for carrier's Carrier case, the CEs need to be on directly connected interfaces with the PE.
 
Thanks,
Roger.

router bgp 65017

R1-7507#show ip bgp

Regards, Marc

---------------------------------
Do you Yahoo!?
Yahoo! Mail SpamGuard - Read only the mail you want.

---

From: Pedro Roque Marques <[email-masked]>
Date: Fri, 20 Feb 2004 11:10:12 -0800 (PST)

Roger Pottier writes:

> Hi, If i have "send label" configured for a BGP peer, do the peers
> need to be on directly connected interfaces?

While details may differ between implementations, BGP SAFI=4, which is
what i assume you are refering to, does not require a directly
connected interface.

It can be used over a directly connected interface, in case in which
it is the top label, or over a non-directly connected session, case in
which the intra-area signaling protocol manages the top.

> If it is not, how would
> the MPLS switches in between know about the labels?

      link
[AS1]      [AS2			      ]
ASBR1 ---- ASBR2 --- P1 --- P2 --- PE1

===> direction of routing advertisements

asbr1 advertises 10.0.1.1/32	label 10000	via directly connected
						ebgp session to asbr2

asbr2 advertises 10.0.1.1/32	label 20000	via ibgp safi=4
						session to PE1

PE1 needs LDP/RSVP path to asbr2, w/ hop-by-hop labels.
assume P2 advertises label 30000 for the ASBR2 FEC.

PE1 forwarding state:
	10.1.1.1/32	push	(20000, 30000)....

>  And if it is on
> directly connected interfaces, does it allocate a label from the
> interface label spaceof that interface?

implementation dependent.

I'm not sure that this is the question that you want to ask also...

Some implementations use only a platform space but restrict allocated
labels so that they can be used only in a subset of
interfaces (where they are announced).

You can consider this to be 'interface label space' or not. The
important property is that a CoC customer interface cannot use labels
which have not been assigned to him.
 
> connected interfaces with the PE.
 
That is the most common model. However the statement "need to be" is
not acurate. One could configure it as a multihop session... i'm sure
somebody will find a good reason why one of this days. Lots of
creative people out there ;-)

  Pedro.

---

From: Marc Binderberger <[email-masked]>
Date: Fri, 20 Feb 2004 21:18:47 +0100

Hi Roger,

> connected interfaces?

No other MPLS hop(s) in between, right. That's at least the "usual" 
scenario.

>  If it is not, how would the MPLS switches in between know
> about the labels?

They don't know unless you configure them, e.g. by means of static 
labels.

> And if it is on directly connected interfaces, does it allocate a 
> label from  the interface label space of that interface?

The routers I have seen use a global label pool, not per-interface.
Well ... what (should) exist is an information that relates the label 
to the interface, maybe something similar to Carrier's Carrier where 
the label is related to the VRF the interface is part of. If this 
information doesn't exist you cannot prevent label spoofing

> connected interfaces with the PE.

Same as above, when there is a label-switch device in between how does 
it know about the labels in/out?
Again for routers (the one I know) it's a global pool together with 
information about the VRF the labels have been advertised in.

Regards, Marc