Subject: Re: About IS-IS as the PE/CE Protocol in BGP/MPLS VPNs (43834 bytes)

From: Ray Qiu <[email-masked]>
Date: Tue, 21 Sep 2004 16:29:58 -0700

Not interested.

On Tue, 21 Sep 2004 14:55:35 -0400, Ronald Bonica
<[email-masked]> wrote:
> Defeng,
> 
> Currently, the L3VPN WG charter does not include ISIS as a PE-CE routing
> protocol. However, I would like to open the mailing list to discussion.
> 
> Is there a compelling reason to deploy ISIS as a PE-CE routing protocol, as
> opposed to BGP or OSPF? Also, I would like to determine whether there is
> broad WG interest in this work.
> 
>                                               Ron
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > On Behalf Of lidefeng
> > Sent: Thursday, September 02, 2004 5:13 AM
> > To: [email-masked]; Ronald Bonica; Ross Callon
> > Cc: [email-masked]
> > Subject: About IS-IS as the PE/CE Protocol in BGP/MPLS VPNs
> > (43834 bytes)
> >
> >
> > Dear Chairmen,
> >
> > At 57th IETF meeting, I made the presentation for
> > draft-sheng-ppvpn-isis-bgp-mpls-00.txt at PPVPN wg meeting
> > and proposed the draft about "IS-IS as the PE/CE Protocol in
> > BGP/MPLS VPNs" as work group draft, now PPVPN wg is divided
> > into L3VPN and L2VPN, at the same time, draft "OSPF as the
> > PE/CE Protocol in BGP/MPLS VPNs " is progressed as L3VPN wg,
> > and IS-IS as an alternate IGP in SP's network and
> > enterprise's network has its advantages over OSPF, especially
> > in IPv6 and Traffic Engineering scenarios(OSPFv3 can't be
> > compatibility with OSPFv2，while IS-ISv6 can be updated from
> > IS-ISv4 by TLV extensiona), and IS-IS gained its wide
> > deployment gradually.
> >
> > So I hope L3VPN wg consider to progress
> > draft-sheng-ppvpn-isis-bgp-mpls-00.txt as WG draft, and it's
> > goal is to become an informational RFC.
> >
> > As to the technical problem might exist in it, comments are welcomed.
> >
> > Regards
> >
> > Defeng Li
> > Huawei Technologies
> >
> >
> >
> 
>

---

From: [email-masked]
Date: Wed, 22 Sep 2004 08:50:09 -0400 (GMT-04:00)

Ron,

Currently, the ISIS MIB is in draft form (version 16) and doesn't compile using the MIB
compilers recommended by the IETF MIB Doctor review process.   Additionally, this MIB is
has a  particularly resource intensive damping strategy (and in my opinion an overly complex
one) for supporting the notifications.   I'd prefer to see the Network management aspects worked out within 
the ISIS working group prior to this working group adopting ISIS as a PE-CE routing protocol.   

The network manage aspects of BGP and OSPF are far more 
established (and in fact are on versions 2 or 3 of protocol/MIB) whereas
ISIS is not near that level of maturity.

I would not be in favor of using ISIS as a PE-CE routing protocol at this time.

  -Joan

-----Original Message-----
From: Ronald Bonica <[email-masked]>
Sent: Sep 21, 2004 2:55 PM
To: 'lidefeng' <[email-masked]>, [email-masked], 
	'Ross Callon' <[email-masked]>, [email-masked]
Subject: RE: About IS-IS as the PE/CE Protocol in BGP/MPLS VPNs (43834 bytes)

Defeng,

                                              Ron

> compatibility with OSPFv2?while IS-ISv6 can be updated from