Subject: Please comment draft-kulmala-l3vpn-aggregation-pe-00

From: "Kulmala, Marko" <[email-masked]>
Date: Wed, 23 Feb 2005 09:55:10 +0200

Hi,
 
We have submitted http://www.ietf.org/internet-drafts/draft-kulmala-l3vpn-aggregation-pe-00.txt <http://www.ietf.org/internet-drafts/draft-kulmala-l3vpn-aggregation-pe-00.txt> .
 
This proposal defines a new way to implement inter-as MPLS VPNs. The method resembles a hybdrid of RFC2547bis ch 10 option A and B (more B than A). This proposal allows easy and secure way to partition access networks in separate AS. Partitioning access networks removes full mesh LSP requirement and allows partitioning IGP without losing capability for end-to-end TE.  Another good thing regarding security is that implicit RT filtering is provided by configured VRF.
 
One application for this is to build IP/MPLS regional networks pretty much in analogous way than with H-VPLS. In that application there are many benefits compared to option B:

	�- Hides core network structure (RTs and RDs) 
	- �Per VPN QoS handling is possible
	- Per VPN aggregation is possible 
	- Per VPN filtering is possible 
	- Per VPN PSN tunnel selection is possible (e.g. separate some VPNs to separate RSVP tunnels in access, and use LDP in core) 
	-End to end traffic engrineering is possible, even when access networks are in separate IGP areas (and reduced number of LSPs allows using RSVP-TE without unresonable overhead).

All comments are appreciated.
 
Best Regards,
Marko Kulmala

	"Abstract
	
	   This document describes operation of aggregation PE and applications
	   for it.
	
	   Aggregation PE installs VPN-IPv4 routes into VRFs and acts as BGP 
	   next hop when it readvertises VPN-IPv4 routes with MP-BGP to other 
	   PE routers. This eliminates the need to LSP connectivity (or some 
	   other type of tunnels) between packet's ingress and egress PE.  
	    
	   Aggregation PE function can be used in multi AS backbones. If routing 
	   peering between the ASes is done between aggregation PE routers then 
	   ingress PE in one AS does not need to know reachability information 
	   to egress PE in other AS. Security is enhanced because no LSP is 
	   needed between packet's ingress and egress PEs.
	
	   Another application for aggregation PE is the support of distinct 
	   IP/MPLS regional networks. It enables access network to be separate
	   area or domain which makes the network more scalable. "

============================================================
The information contained in this message may be privileged
and confidential and protected from disclosure. If the reader
of this message is not the intended recipient, or an employee
or agent responsible for delivering this message to the
intended recipient, you are hereby notified that any reproduction,
dissemination or distribution of this communication is strictly
prohibited. If you have received this communication in error,
please notify us immediately by replying to the message and
deleting it from your computer. Thank you. Tellabs
============================================================

---

From: Ronald Bonica <[email-masked]>
Date: Thu, 24 Feb 2005 11:19:42 -0500

Marko,

I am not clear on the difference between your proposal and interprovider 
   Option B. In your proposal, if I were to monitor the link between 
ASBR's what would I see on the forwarding plane? On the control plane? 
How would that be different from interprovider Option B?

                                    (as individual contributor)
                                       Ron

Kulmala, Marko wrote:
> Hi,
>  
> We have submitted 
> http://www.ietf.org/internet-drafts/draft-kulmala-l3vpn-aggregation-pe-00.txt.
>  
> This proposal defines a new way to implement inter-as MPLS VPNs. The 
> method resembles a hybdrid of RFC2547bis ch 10 option A and B (more B 
> than A). This proposal allows easy and secure way to partition access 
> networks in separate AS. Partitioning access networks removes full mesh 
> LSP requirement and allows partitioning IGP without losing capability 
> for end-to-end TE.  Another good thing regarding security is that 
> implicit RT filtering is provided by configured VRF.
>  
> One application for this is to build IP/MPLS regional networks pretty 
> much in analogous way than with H-VPLS. In that application there are 
> many benefits compared to option B:
> 
>> - Per VPN PSN tunnel selection is possible (e.g. separate some VPNs to 
>> separate RSVP tunnels in access, and use LDP in core)
>> -End to end traffic engrineering is possible, even when access 
>> networks are in separate IGP areas (and reduced number of LSPs allows 
>> using RSVP-TE without unresonable overhead).
>