Subject: Re: Multicast in BGP/MPLS VPN with pseudo wires technology

From: xuxiaohu 41208 <[email-masked]>
Date: Sun, 09 Oct 2005 22:06:35 +0800

Hi,Yakov

Right, thanks for your reminder;) 
It should be said "as packets are received over TE tunnel with PHP off by
egress LSR,  it can not be determined from which VPN
these packets are transimitted without additional configure or processing such as bidirectiaonal RSVP-TE tunnel with virtual router technology.

Best regards!

Steven Joe

Huawei Technologies Co.,Ltd

> Hi Thomas
> 
> Thanks a lot for your response
> 
> TE tunnels established between a pair of  PEs destined to each other are 
> unidirectional and disrelated. As packets are received over TE tunnel by
> egress LSR  it can not be determined from which VPN and from which PE
> these packets are transimitted. 

The above is not exactly correct. Namely, if one does not perform
PHP, then the egress PE by examining the outermost label can determine
from which PE these packets are transmitted.

> PWs are bidirectional virtual link  
> between each pair of PEs and are bound to a particular VRF2C  As packets 
> are received over PW by egress LSR  it can not be determined from which
> VPN and from 
> which ingress PE these packets are transimitted according to the VPN label
> info  Of cource bidirectional RSVP-TE tunnel  described in my previous
> email can also be used to realize the above goal.

Yakov.

---

From: Yakov Rekhter <[email-masked]>
Date: Sun, 09 Oct 2005 11:17:13 -0700

Steven,

> Right, thanks for your reminder;) 

You are welcomed :-)

> these packets are transimitted without additional configure or processing 
> such as bidirectiaonal RSVP-TE tunnel with virtual router technology.

This is not exactly correct either, as if the packets carry not
one, but two labels, then the inner label would determine from which
VPN these packets are transmitted. So, a combination of the inner
and outer label with PHP disable would tell the receiving PE from
which PE and from which VPN the packets are transmitted.

Yakov.
  
> --Boundary_(ID_f/aGhuv1Lm3q8D00BscCiw)
> Content-type: text/x-vcard; name=x41208.vcf; charset=gb2312
> Content-transfer-encoding: 7BIT
> Content-disposition: attachment; filename=x41208.vcf
> Content-description: Card for xuxiaohu 41208 <[email-masked]>
> 
> begin:vcard
> n:;xuxiaohu
> fn:xuxiaohu
> version:2.1
> email;internet:[email-masked]
> end:vcard
> 
> 
> --Boundary_(ID_f/aGhuv1Lm3q8D00BscCiw)--