Subject: Re: Multicast in BGP/MPLS VPN with pseudo wires technology

From: xuxiaohu 41208 <[email-masked]>
Date: Thu, 06 Oct 2005 21:31:51 +0800

Hi, Thomas

Thanks a lot for your response.

TE tunnels established between a pair of  PEs destined to each other are unidirectional and disrelated. As packets are received over TE tunnel by egress LSR,  it can not be determined from which VPN and from which PE these packets are transimitted. PWs are bidirectional virtual link  between each pair of PEs and are bound to a particular VRF,  As packets are received over PW by egress LSR,  it can not be determined from which VPN and from w
hich ingress PE these packets are transimitted according to the VPN label info.  Of cource, bidirectional RSVP-TE tunnel  described in my previous email can also be used to realize the above goal.

----- Original Message ----- 
From: "Thomas D. Nadeau" <[email-masked]>
To: "xuxiaohu 41208" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Thursday, October 06, 2005 8:32 PM
Subject: Re: Multicast in BGP/MPLS VPN with pseudo wires technology

> Dear members of the l3vpn distribution list:
>
> I want to introduce a new method of implementing MVPN in 2547bis  
> VPN with pseudo wires technology, any comment from you will be  
> expected.
>
> The basic procedures are as follows: first, discover all the PEs  
> which is attached to a particular MVPN via BGP;

     Can you explain why this is different from the already
deployed approach where TE tunnels are established between
PEs?

> second, Full-meshed pseudo wires (PW) are established among the  
> above PEs, and these PWs are bound to a particular MVRF related to  
> the above MVPN;

     I am interested to hear from operators whether they think
of this approach in the context of operational issues.

     --Tom

> lastly, multicast control messages and multicast data traffices can  
> be transmitted through those PWs.
>
> The main advantages of this method is as follows:
> First,it is independant with multicast routing protocols and any  
> kind of current multicast routing protocols, including PIM-SM, PIM- 
> SSM and PIM-DM can run over such MVPN.
> Second, multicast is not required in P devices. It's easy to  
> maintain such MVPN and it is good for protecting original investment.
> Third, replication on PE can share the burden on P router which is  
> a hub in hub-spoke network topology.
>
>
> The main differnece with draft-ietf-l3vpn-2547bis-mcast-00.txt (May  
> 2005) lies in the demultiplexor.
>
> The description about demultiplexor in draft-ietf-l3vpn-2547bis- 
> mcast-00.txt is as follows:
>
> ##################################
>
> If multicast control information is to be unicast, rather
>
> than sent on an MI-PMSI, then a demultiplexor value must
>
> be carried by the control messages in order to identify
>
> the particular MVPN to which the control message belongs.
>
> The form of this demultiplexor is not yet agreed upon,
>
> but one possibility is a downstream-assigned MPLS label.
>
> If this procedure is adopted, this label would be carried
>
> in the BGP update message. The PE originating the BGP
>
> update message would specify the label which it expects
>
> to see on received control packets for the specified MVPN.
>
> ##################################
>
>
> In the above description, a demultiplexor is used to distinguish  
> different MVPN streams of traffic carried over a tunnel. But in my  
> implemention of MVPN, the demultiplexor not only says to which  
> specific MVPN a packet belongs, but also identifies the ingress PE.  
> For this reason, there is no need to carry ingress PE’s address in  
> multicast traffic with a special encapsulation such as GRE for the  
> purpose of RPF checking and other uses. The det
> ails about encapsulation are speciafied in section 11 of the draft  
> mentioned above.
>
> That is to say,in my implemention of MVPN, each PE will assign a  
> unique label to every one of the other PEs within the above MVPN,  
> and those unique labels are associated to a particular MVRF related  
> to the above MVPN. These PWs can be looked as virtual interfaces  
> between each pair of the above PEs, which are bound to a particular  
> MVRF.
>
> These PWs mentioned above could be established via BGP or targeted  
> LDP .
>
> Of course, BGP is still can be used to carry PIM C-instance control  
> message after the PWs are eatablished between each pair of PEs  
> within the same MVPN. That is to say, PIM C-instance control  
> messages can be carried in BGP updates and multicast traffics can  
> travel over PWs.
>
>
> Sincerely
>
> Steven Joe
>
> Huawei Technologies Co.,Ltd.
>
> Email: [email-masked]
>
>
>
>

---

From: Yakov Rekhter <[email-masked]>
Date: Sat, 08 Oct 2005 17:12:51 -0700

Hi,

> Hi Thomas
> 
> Thanks a lot for your response
> 
> TE tunnels established between a pair of  PEs destined to each other are 
> unidirectional and disrelated. As packets are received over TE tunnel by
> egress LSR  it can not be determined from which VPN and from which PE
> these packets are transimitted. 

The above is not exactly correct. Namely, if one does not perform
PHP, then the egress PE by examining the outermost label can determine
from which PE these packets are transmitted.

> PWs are bidirectional virtual link  
> between each pair of PEs and are bound to a particular VRF2C  As packets 
> are received over PW by egress LSR  it can not be determined from which
> VPN and from 
> which ingress PE these packets are transimitted according to the VPN label
> info  Of cource bidirectional RSVP-TE tunnel  described in my previous
> email can also be used to realize the above goal.

Yakov.
  
>     
> 
> ----- Original Message ----- =
> 
> From=3A =22Thomas D=2E Nadeau=22 =3Ctnadeau=40cisco=2Ecom=3E
> To=3A =22xuxiaohu 41208=22 =3Cxuxh=40huawei=2Ecom=3E
> Cc=3A =3Cl3vpn=40ietf=2Eorg=3E=3B =3Ccli=40futurewei=2Ecom=3E=3B =3Csdawk=
> ins=40futurewei=2Ecom=3E
> Sent=3A Thursday=2C October 06=2C 2005 8=3A32 PM
> Subject=3A Re=3A Multicast in BGP/MPLS VPN with pseudo wires technology
> 
> 
> 
> 
> =3E Dear members of the l3vpn distribution list=3A
> =3E
> =3E I want to introduce a new method of implementing MVPN in 2547bis  =
> 
> =3E VPN with pseudo wires technology=2C any comment from you will be  =
> 
> =3E expected=2E
> =3E
> =3E The basic procedures are as follows=3A first=2C discover all the PEs =
>  =
> 
> =3E which is attached to a particular MVPN via BGP=3B
> 
> PEs=3F
> =3E second=2C Full-meshed pseudo wires (PW) are established among the  =
> 
> =3E above PEs=2C and these PWs are bound to a particular MVRF related to =
>  =
> 
> =3E the above MVPN=3B
> 
> of this approach in the context of operational issues=2E
> 
>      --Tom
> 
> =3E lastly=2C multicast control messages and multicast data traffices can=
>   =
> 
> =3E be transmitted through those PWs=2E
> =3E
> =3E The main advantages of this method is as follows=3A
> =3E First=2Cit is independant with multicast routing protocols and any  =
> 
> =3E kind of current multicast routing protocols=2C including PIM-SM=2C PI=
> M- =
> 
> =3E SSM and PIM-DM can run over such MVPN=2E
> =3E Second=2C multicast is not required in P devices=2E It=27s easy to  =
> 
> =3E maintain such MVPN and it is good for protecting original investment=2E=
> 
> =3E Third=2C replication on PE can share the burden on P router which is =
>  =
> 
> =3E a hub in hub-spoke network topology=2E
> =3E
> =3E
> =3E The main differnece with draft-ietf-l3vpn-2547bis-mcast-00=2Etxt (May=
>   =
> 
> =3E 2005) lies in the demultiplexor=2E
> =3E
> =3E The description about demultiplexor in draft-ietf-l3vpn-2547bis- =
> 
> =3E mcast-00=2Etxt is as follows=3A
> =3E
> =3E =23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=
> =23=23=23=23=23=23=23=23=23=23=23
> =3E
> =3E If multicast control information is to be unicast=2C rather
> =3E
> =3E than sent on an MI-PMSI=2C then a demultiplexor value must
> =3E
> =3E be carried by the control messages in order to identify
> =3E
> =3E the particular MVPN to which the control message belongs=2E
> =3E
> =3E The form of this demultiplexor is not yet agreed upon=2C
> =3E
> =3E but one possibility is a downstream-assigned MPLS label=2E
> =3E
> =3E If this procedure is adopted=2C this label would be carried
> =3E
> =3E in the BGP update message=2E The PE originating the BGP
> =3E
> =3E update message would specify the label which it expects
> =3E
> =3E to see on received control packets for the specified MVPN=2E
> =3E
> =3E =23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=23=
> =23=23=23=23=23=23=23=23=23=23=23
> =3E
> =3E
> =3E In the above description=2C a demultiplexor is used to distinguish  =
> 
> =3E different MVPN streams of traffic carried over a tunnel=2E But in my =
>  =
> 
> =3E implemention of MVPN=2C the demultiplexor not only says to which  =
> 
> =3E specific MVPN a packet belongs=2C but also identifies the ingress PE=2E=
>   =
> 
> =3E For this reason=2C there is no need to carry ingress PE=A1=AFs addres=
> s in  =
> 
> =3E multicast traffic with a special encapsulation such as GRE for the  =
> 
> =3E purpose of RPF checking and other uses=2E The det
> =3E ails about encapsulation are speciafied in section 11 of the draft  =
> 
> =3E mentioned above=2E
> =3E
> =3E That is to say=2Cin my implemention of MVPN=2C each PE will assign a =
>  =
> 
> =3E unique label to every one of the other PEs within the above MVPN=2C  =
> 
> =3E and those unique labels are associated to a particular MVRF related  =
> 
> =3E to the above MVPN=2E These PWs can be looked as virtual interfaces  =
> 
> =3E between each pair of the above PEs=2C which are bound to a particular=
>   =
> 
> =3E MVRF=2E
> =3E
> =3E These PWs mentioned above could be established via BGP or targeted  =
> 
> =3E LDP =2E
> =3E
> =3E Of course=2C BGP is still can be used to carry PIM C-instance control=
>   =
> 
> =3E message after the PWs are eatablished between each pair of PEs  =
> 
> =3E within the same MVPN=2E That is to say=2C PIM C-instance control  =
> 
> =3E messages can be carried in BGP updates and multicast traffics can  =
> 
> =3E travel over PWs=2E
> =3E
> =3E
> =3E Sincerely
> =3E
> =3E Steven Joe
> =3E
> =3E Huawei Technologies Co=2E=2CLtd=2E
> =3E
> =3E Email=3A xuxh=40huawei=2Ecom
> =3E
> =3E
> =3E
> =3E
> 
> --Boundary_(ID_Z9XT0MSx/EcK/HXBmYd5Og)
> Content-type: text/x-vcard; name=x41208.vcf; charset=gb2312
> Content-disposition: attachment; filename=x41208.vcf
> Content-description: Card for xuxiaohu 41208 <[email-masked]>
> Content-Transfer-Encoding: 7BIT
> 
> begin:vcard
> n:;xuxiaohu
> fn:xuxiaohu
> version:2.1
> email;internet:[email-masked]
> end:vcard
> 
> 
> --Boundary_(ID_Z9XT0MSx/EcK/HXBmYd5Og)--