Subject: re: draft-wu-l3vpn-ipsec-gre-00

From: "qiminpeng" <[email-masked]>
Date: Thu, 22 Nov 2007 15:49:30 +0800

Hi
I'm interested in this draft. But I'm confused with a question below.
It is said that "the source GRE half key and destination GRE half key can be used in IKEv2 Traffic Selector negotiation".  In my humble opinion, it is just discribed how the GRE half key works in IKE protocol. I wonder how does it work in IPSec module. Is there any statement of this question? 
Thank you,
Regards
Minpeng Qi

>Hello, all
>
>
>
>Below is our new draft which posted recently,
>
>http://www.ietf.org/internet-drafts/draft-wu-l3vpn-ipsec-gre-00.txt

---

From: "Hui Deng" <[email-masked]>
Date: Mon, 26 Nov 2007 09:00:51 +0800

Hi, Minpeng,

Thanks for your comments, 

As you said here, we do need extend IPsec to support gre key parse.

This is what we are proposing here, and is quite similar to MH type which is
defined in MIP6.

Many thanks

-Hui

  _____  

From: qiminpeng [mailto:[email-masked]] 
Sent: Thursday, November 22, 2007 3:50 PM
To: l3vpn
Subject: re: draft-wu-l3vpn-ipsec-gre-00

Hi

It is said that "the source GRE half key and destination GRE half key can be
used in IKEv2 Traffic Selector negotiation".  In my humble opinion, it is
just discribed how the GRE half key works in IKE protocol. I wonder how does
it work in IPSec module. Is there any statement of this question? 

Thank you,
Regards

Minpeng Qi