Subject: Advancing the Multicast L3VPN protocol drafts

From: Marshall Eubanks <[email-masked]>
Date: Wed, 6 Aug 2008 08:37:28 -0400

While there was rough consensus in Dublin to decouple the
protocol drafts from the choice of how to describe the use of those  
protocols
to create interoperable Multicast VPNs, and to progress the protocol  
drafts immediately,
such decisions must be confirmed by this list.

The essence of the "decoupling" proposal is that the protocol  
documents will progress
(which will clearly take some time) while the Working Group decides  
what profile drafts,
requirement drafts, etc., will accompany them.

Therefore :

Should the L3VPN WG submit both

draft-ietf-l3vpn-2547bis-mcast  AND
draft-ietf-l3vpn-2547bis-mcast-bgp to the IESG

as multicast VPN solutions and as proposed standards ?

If you support this proposal  please
reply with a "yes", if you're opposed, reply with a "no".

While comments and suggestions are welcomed, please make your
position clear in your response. Note that this is not a WG Last Call on
these documents, but a request for a WG decision.

Please provide any feedback no later than August 21, 2008.

Regards
Marshall Eubanks

---

From: <[email-masked]>
Date: Wed, 6 Aug 2008 17:34:57 +0200

> requirement drafts, etc., will accompany them.

IINM, in essence the question seems: should the WG submit to the IESG a
document as a proposed standard that does not allow for interoperable
equipments? And without a clear & agreed path toward defining
interoperability.

Before collecting answers, I wonder if we shouldn't first discuss and
agree on the question(s) to be asked to the L3 VPN WG.

For example Thomas Morin proposed the following questions:

> Summary
> - question 1 with two choices :
>    (a) adopt draft-morin-l3vpn-mvpn-considerations-03
>    (b) adopt a profile-based approach
> - question 2 (yes/no) : should the working group progress
draft-ietf-2547bis-mcast-vpn and draft-..-mcast-vpn-bgp to the IESG
without the WG having adopted a document describing how interoperability
can happen ? (yes or no)

Shouldn't the WG be proposed and polled on at least an alternative to
the profile option?

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Thu, 14 Aug 2008 12:08:39 +0100

Marshall, WG,

I have no problem in principle with decoupling the protocol documents from
the "implementation" draft(s) (so I guess that's a yes).  However I do feel
it is just sidestepping the real issue.

The current protocol drafts as they stand are no good to me as an operator
that requires multi-vendor interoperable solutions.  In combination with the
"implementation" draft(s) they could be of use to me.

Therefore unless there is commitment from the WG to address and resolve the
"implementation" draft(s) issue (which is the real issue that's need
resolving IMO) then sending the protocol drafts to the IESG still places us
in the same position we have been in for some time albeit with two more RFC
numbers allocated.

Ben

---

From: Thomas Morin <[email-masked]>
Date: Thu, 14 Aug 2008 15:23:19 +0200

Hi Marshall, folks,

I find the formulation of the question surprising, suggesting at the
same time that we don't have anything providing interoperable Multicast
VPNs and that we can still consider progressing current WG drafts to the
IESG. 

Marshall Eubanks :
> While there was rough consensus in Dublin to decouple the protocol
> drafts from the choice of how to describe the use of those  
> protocols to create interoperable Multicast VPNs, and to progress the
> protocol drafts immediately, such decisions must be confirmed by this
> list.

( I don't recall that there was a consensus on this. What I recall is
the proposal made by Dave Ward, and some comments at the mike, but
certainly not that all were in favor of this approach. )

> documents will progress (which will clearly take some time) while the
> Working Group decides what profile drafts, requirement drafts, etc.,
> will accompany them.

This seem to be an approach focused on a path that will take a long
time.

Yet, having the working group decide now, how we will provide
interoperability for multicast VPN (mandatory procedures with options OR
multiple profiles), seems to me as a better way to quickly solve the
situation.  

Asking the working group on adopting
draft-morin-l3vpn-mvpn-considerations, which you said you would do
during the meeting after a favorable raise of hands, will precisely
start to answer that question.

Once this is clearer, the WG will be in a clearer situation to decide to
opt for a pragmatic approach consisting in progressing current solution
draft to the IESG.

Thank you,

-Thomas

---

From: "Drake, John E" <[email-masked]>
Date: Thu, 14 Aug 2008 06:35:39 -0700

Good point. 

>-----Original Message-----
>From: Ben Niven-Jenkins [mailto:[email-masked]] 
>Sent: Thursday, August 14, 2008 4:09 AM
>To: Marshall Eubanks; [email-masked]
>Subject: Re: Advancing the Multicast L3VPN protocol drafts
>
>Marshall, WG,
>
>I have no problem in principle with decoupling the protocol 
>documents from the "implementation" draft(s) (so I guess 
>that's a yes).  However I do feel it is just sidestepping the 
>real issue.
>
>The current protocol drafts as they stand are no good to me as 
>an operator that requires multi-vendor interoperable 
>solutions.  In combination with the "implementation" draft(s) 
>they could be of use to me.
>
>Therefore unless there is commitment from the WG to address 
>and resolve the "implementation" draft(s) issue (which is the 
>real issue that's need resolving IMO) then sending the 
>protocol drafts to the IESG still places us in the same 
>position we have been in for some time albeit with two more 
>RFC numbers allocated.
>
>
>Ben
>
>
>
>> drafts from the choice of how to describe the use of those protocols 
>> drafts immediately, such decisions must be confirmed by this list.
>> 
>> While comments and suggestions are welcomed, please make 
>your position 
>> clear in your response. Note that this is not a WG Last Call 
>on these 
>> documents, but a request for a WG decision.
>>

---

From: "Drake, John E" <[email-masked]>
Date: Thu, 14 Aug 2008 07:08:02 -0700

No.  As many people ahave pointed out, this does nothing to solve the
real problem which is deciding what is mandatory and what is optional.

>From: Marshall Eubanks [mailto:[email-masked]] 
>Sent: Wednesday, August 06, 2008 5:37 AM
>To: [email-masked]
>Subject: Advancing the Multicast L3VPN protocol drafts
>
>protocol drafts from the choice of how to describe the use of 
>those protocols to create interoperable Multicast VPNs, and to 
>progress the protocol drafts immediately, such decisions must 
>be confirmed by this list.
>
>documents will progress (which will clearly take some time) 
>while the Working Group decides what profile drafts, 
>position clear in your response. Note that this is not a WG 
>Last Call on these documents, but a request for a WG decision.
>

---

From: "Drake, John E" <[email-masked]>
Date: Thu, 14 Aug 2008 07:11:47 -0700

>From: Thomas Morin [mailto:[email-masked]] 
>Sent: Thursday, August 14, 2008 6:23 AM
>To: Marshall Eubanks
>Cc: [email-masked]
>I find the formulation of the question surprising, suggesting 
>at the same time that we don't have anything providing 
>interoperable Multicast VPNs and that we can still consider 
>progressing current WG drafts to the IESG. 
>
>Marshall Eubanks :
>( I don't recall that there was a consensus on this. What I 
>recall is the proposal made by Dave Ward, and some comments at 
>the mike, but certainly not that all were in favor of this approach. )
>

JD:  Your recollection is the same as mine.

>while the 
>This seem to be an approach focused on a path that will take a 
>long time.
>
>interoperability for multicast VPN (mandatory procedures with 
>options OR multiple profiles), seems to me as a better way to 
>quickly solve the situation.

JD:  First things first.
  
>draft-morin-l3vpn-mvpn-considerations, which you said you 
>would do during the meeting after a favorable raise of hands, 
>will precisely start to answer that question.

JD:  I am surprised that the chairs have yet to ask the mailing list
this question.
 
>
>Once this is clearer, the WG will be in a clearer situation to 
>decide to opt for a pragmatic approach consisting in 
>progressing current solution draft to the IESG.
>
>Thank you,
>
>-Thomas
>
>

---

From: "Newton, Jonathan" <[email-masked]>
Date: Thu, 14 Aug 2008 17:41:10 +0100

Well put Ben.

What we need is a truly interoperable solution for both multi-vendor and
inter-AS multicast vpn services.   
IMO, decoupling would suggest that the protocol documents will serve a
useful function in isolation from requirements and implementation
documents, which I do not believe to be the case. For this reason, I
vote no.

Cheers,
~Jon.

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Ben Niven-Jenkins
> Sent: 14 August 2008 12:09
> The current protocol drafts as they stand are no good to me 
> as an operator that requires multi-vendor interoperable 
> > clear in your response. Note that this is not a WG Last 
> Call on these 

This e-mail has been scanned for viruses by the Cable & Wireless e-mail security system - powered by MessageLabs. For more information on a proactive managed e-mail security service, visit http://www.cw.com/uk/emailprotection/ 

The information contained in this e-mail is confidential and may also be subject to legal privilege. It is intended only for the recipient(s) named above. If you are not named above as a recipient, you must not read, copy, disclose, forward or otherwise use the information contained in this email. If you have received this e-mail in error, please notify the sender (whose contact details are above) immediately by reply e-mail and delete the message and any attachments without retaining any copies.
 
Cable and Wireless plc 
Registered in England and Wales.Company Number 238525 
Registered office: 3rd Floor, 26 Red Lion Square, London WC1R 4HQ

---

From: "Joorde, Uwe" <[email-masked]>
Date: Fri, 15 Aug 2008 08:03:47 +0200

Underlined what Ben say.

Operaters like DT need a interoperable solution for multi-vendor multicast vpn services. IMO, decoupling would split our effords towards this goal.

Cheers, Uwe

Deutsche Telekom AG
T-Com, Zentrum Technik Einführung
Uwe Joorde
Technik Internet Backbone, TE142-12
Hammer Str. 216 - 226, 48153 Münster
+49 251 7985 406 (Tel.)  
+49 251 7985 109 (Fax)
E-Mail: [email-masked]
http://www.t-com.de

Registerrechtliche Unternehmensangaben:
Deutsche Telekom AG
Aufsichtsrat: . Dr. Ulrich Lehner (Vorsitzender)
Vorstand: René Obermann (Vorsitzender), 
Dr. Karl-Gerhard Eick (stellvertretender Vorsitzender),
Hamid Akhavan, Timotheus Höttges, Thomas Sattelberger
Handelsregister: Amtsgericht Bonn HRB 6794,
Sitz der Gesellschaft: Bonn
WEEE-Reg.-Nr.: DE50478376

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] 
> Im Auftrag von Ben Niven-Jenkins
> Gesendet: Donnerstag, 14. August 2008 13:09
> An: Marshall Eubanks; [email-masked]
> Betreff: Re: Advancing the Multicast L3VPN protocol drafts
> 
> Marshall, WG,
> 
> documents from
> as an operator
> and resolve the
> Last Call on