Subject: Re: Query related to Auto Discovery as in draft-ietf-l3vpn-2547bis-mcast-07.txt

From: Subinoy Das <[email-masked]>
Date: Tue, 2 Dec 2008 13:38:47 +0530 (IST)

Thanks for answer. I still have confision about the exact process..

If local policy states to discard route if RT does not match Import then what happen if new VPN support is added to a PE? How does it comes to know all routes for that VPN? Should all other PEs send I-PMSI A-D Route, S-PMSI A-D Route, Source Active A-D Route, C-Multicast Route to that PE?

Thanks,
Subinoy

________________________________
From: Yakov Rekhter <[email-masked]>
To: Subinoy Das <[email-masked]>
Cc: L3VPN MAIL <[email-masked]>
Sent: Wednesday, 26 November, 2008 7:29:21 PM
Subject: Re: Query related to Auto Discovery as in draft-ietf-l3vpn-2547bis-mcast-07.txt

Subinoy,

> Hi,
> 
> I have one query about Auto Discovery using BGP to exchange multicast
> route in provider network.
> 
> When a PE receives Intra-AS I-PMSI A-D route it matches Import RT
> of all VRF it supports with all RTs in the packet. If no match found
> then what does PE do? Is it stores the information in database or
> just discard the packet?

It is a matter of local policy on the PE. Not that much different
from the scenario where a PE receives a (unicast) VPN-IPv4 route
whose RT does not match Import RT of any of the VRFs on the PE.

Yakov.

      Add more friends to your messenger and enjoy! Go to http://messenger.yahoo.com/invite/

---

From: Yakov Rekhter <[email-masked]>
Date: Tue, 2 Dec 2008 08:13:12 -0800

Subinoy,

> Thanks for answer. I still have confision about the exact process.
> 
> If local policy states to discard route if RT does not match Import
> then what happen if new VPN support is added to a PE? How does it
> comes to know all routes for that VPN? 

>From Section 4.3.2 of rfc4364:

   A PE router, UNLESS it is a route reflector (see Section 4.3.3) or an
   Autonomous System Border Router (ASBR) for an inter-provider VPN (see
   Section 10), should not install a VPN-IPv4 route unless it has at
   least one VRF with an Import Target identical to one of the route's
   Route Target attributes.  Inbound filtering should be used to cause
   such routes to be discarded.  If a new Import Target is later added
   to one of the PE's VRFs (a "VPN Join" operation), it must then
   acquire the routes it may previously have discarded.  This can be
   done using the refresh mechanism described in [BGP-RFSH].  The
   outbound route filtering mechanism of [BGP-ORF] can also be used to
   advantage to make the filtering more dynamic.

To which I may add that one may use RT Constrain (rfc4684) instead
of [BGP-ORF], as RT Constrain is more useful that [BGP-ORF].

> Should all other PEs send
> I-PMSI A-D Route, S-PMSI A-D Route, Source Active A-D Route,
> C-Multicast Route to that PE?

See the above.

Yakov.