Subject: FW: draft-ietf-l3vpn-2547bis-mcast-bgp section 13

From: "NAPIERALA, MARIA H, ATTLABS" <[email-masked]>
Date: Wed, 4 Mar 2009 10:46:41 -0500

Is there an answer to the question below?

Maria

From: [email-masked] [mailto:[email-masked]] On Behalf
Of HEMIGE Venu
Sent: Friday, December 12, 2008 10:54 AM
To: [email-masked]
Subject: draft-ietf-l3vpn-2547bis-mcast-bgp section 13

[...]

3. Section 13.2: I think it is insufficient to say that the egress PE
creates just the forwarding state for (C-S,C-G). I think the egress PE
MUST send a Source Join Route to explicitly join the (C-S, C-G) tree. 

 [...]

Thanks,

-Venu

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 4 Mar 2009 12:32:38 -0800

Maria,

> Is there an answer to the question below?

Yes. The answer is in the (soon to be released) updated version
of draft-ietf-l3vpn-2547bis-mcast-bgp.

Yakov.
  
> =20
> =20
> MUST send a Source Join Route to explicitly join the (C-S, C-G) tree.=20
> 
>  [...]
> 
> =20
> 
> Thanks,
> 
> -Venu
> 
> 
> ------_=_NextPart_001_01C99CE0.6A9D011B
> Content-Type: text/html;
> 	charset="us-ascii"
> Content-Transfer-Encoding: quoted-printable
> 
> <html xmlns:v=3D"urn:schemas-microsoft-com:vml" =
> xmlns:o=3D"urn:schemas-microsoft-com:office:office" =
> xmlns:w=3D"urn:schemas-microsoft-com:office:word" =
> xmlns:m=3D"http://schemas.microsoft.com/office/2004/12/omml" =
> xmlns=3D"http://www.w3.org/TR/REC-html40">
> 
> <head>
> <meta http-equiv=3DContent-Type content=3D"text/html; =
> charset=3Dus-ascii">
> <meta name=3DGenerator content=3D"Microsoft Word 12 (filtered medium)">
> <style>
> <!--
>  /* Font Definitions */
>  @font-face
> 	{font-family:Calibri;
> 	panose-1:2 15 5 2 2 2 4 3 2 4;}
> @font-face
> 	{font-family:Tahoma;
> 	panose-1:2 11 6 4 3 5 4 4 2 4;}
>  /* Style Definitions */
>  p.MsoNormal, li.MsoNormal, div.MsoNormal
> 	{margin:0in;
> 	margin-bottom:.0001pt;
> 	font-size:12.0pt;
> 	font-family:"Times New Roman","serif";}
> a:link, span.MsoHyperlink
> 	{mso-style-priority:99;
> 	color:blue;
> 	text-decoration:underline;}
> a:visited, span.MsoHyperlinkFollowed
> 	{mso-style-priority:99;
> 	color:purple;
> 	text-decoration:underline;}
> span.EmailStyle17
> 	{mso-style-type:personal;
> 	font-family:"Calibri","sans-serif";
> 	color:#1F497D;}
> span.EmailStyle18
> 	{mso-style-type:personal-reply;
> 	font-family:"Calibri","sans-serif";
> 	color:#1F497D;}
> .MsoChpDefault
> 	{mso-style-type:export-only;
> 	font-size:10.0pt;}
> @page Section1
> 	{size:8.5in 11.0in;
> 	margin:1.0in 1.0in 1.0in 1.0in;}
> div.Section1
> 	{page:Section1;}
> -->
> </style>
> <!--[if gte mso 9]><xml>
>  <o:shapedefaults v:ext=3D"edit" spidmax=3D"1026" />
> </xml><![endif]--><!--[if gte mso 9]><xml>
>  <o:shapelayout v:ext=3D"edit">
>   <o:idmap v:ext=3D"edit" data=3D"1" />
>  </o:shapelayout></xml><![endif]-->
> </head>
> 
> <body lang=3DEN-US link=3Dblue vlink=3Dpurple>
> 
> <div class=3DSection1>
> 
> <p class=3DMsoNormal><span =
> style=3D'font-size:11.0pt;font-family:"Calibri","sans-serif";
> color:#1F497D'>Is there an answer to the question =
> below?<o:p></o:p></span></p>
> 
> <p class=3DMsoNormal><span =
> style=3D'font-size:11.0pt;font-family:"Calibri","sans-serif";
> color:#1F497D'><o:p>&nbsp;</o:p></span></p>
> 
> <p class=3DMsoNormal><span =
> style=3D'font-size:11.0pt;font-family:"Calibri","sans-serif";
> color:#1F497D'>Maria<o:p></o:p></span></p>
> 
> <p class=3DMsoNormal><span =
> style=3D'font-size:11.0pt;font-family:"Calibri","sans-serif";
> color:#1F497D'><o:p>&nbsp;</o:p></span></p>
> 
> <div style=3D'border:none;border-left:solid blue 1.5pt;padding:0in 0in =
> 0in 4.0pt'>
> 
> <div>
> 
> <div style=3D'border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt =
> 0in 0in 0in'>
> 
> <p class=3DMsoNormal><b><span =
> style=3D'font-size:10.0pt;font-family:"Tahoma","sans-serif"'>From:</span>=
> </b><span
> style=3D'font-size:10.0pt;font-family:"Tahoma","sans-serif"'>
> [email-masked] [mailto:[email-masked]] <b>On Behalf Of =
> </b>HEMIGE
> Venu<br>
> <b>Sent:</b> Friday, December 12, 2008 10:54 AM<br>
> <b>To:</b> [email-masked]<br>
> <b>Subject:</b> draft-ietf-l3vpn-2547bis-mcast-bgp section =
> 13<o:p></o:p></span></p>
> 
> </div>
> 
> </div>
> 
> <p class=3DMsoNormal><span =
> style=3D'color:#1F497D'><o:p>&nbsp;</o:p></span></p>
> 
> <p class=3DMsoNormal><span =
> style=3D'color:#1F497D'>[&#8230;]<o:p></o:p></span></p>
> 
> <div>
> 
> <div>
> 
> <p class=3DMsoNormal style=3D'margin-left:4.8pt'><span =
> style=3D'font-size:10.0pt;
> font-family:"Arial","sans-serif"'>3. Section 13.2: I think it is =
> insufficient
> to say that the egress PE creates just the forwarding state for =
> (C-S,C-G). I
> think the egress PE MUST send a Source Join Route to explicitly join the =
> (C-S,
> C-G) tree. </span><o:p></o:p></p>
> 
> </div>
> 
> <div>
> 
> <p class=3DMsoNormal>&nbsp;<span =
> style=3D'color:#1F497D'>[&#8230;]</span><o:p></o:p></p>
> 
> <p class=3DMsoNormal><span =
> style=3D'font-size:11.0pt;font-family:"Calibri","sans-serif";
> color:#1F497D'><o:p>&nbsp;</o:p></span></p>
> 
> </div>
> 
> <div>
> 
> <p class=3DMsoNormal><span =
> style=3D'font-size:10.0pt;font-family:"Arial","sans-serif"'>Thanks,</span=
> ><o:p></o:p></p>
> 
> </div>
> 
> <div>
> 
> <p class=3DMsoNormal><span =
> style=3D'font-size:10.0pt;font-family:"Arial","sans-serif"'>-Venu</span><=
> o:p></o:p></p>
> 
> </div>
> 
> </div>
> 
> </div>
> 
> </div>
> 
> </body>
> 
> </html>
> 
> ------_=_NextPart_001_01C99CE0.6A9D011B--

---

From: "NAPIERALA, MARIA H, ATTLABS" <[email-masked]>
Date: Wed, 4 Mar 2009 15:37:27 -0500

Yakov,
Thanks.
Can you share the answer now or should we wait for the updated version?

Maria

> -----Original Message-----
> From: Yakov Rekhter [mailto:[email-masked]]
> Sent: Wednesday, March 04, 2009 3:33 PM
> To: NAPIERALA, MARIA H, ATTLABS
> Cc: [email-masked]; HEMIGE Venu
> Subject: Re: FW: draft-ietf-l3vpn-2547bis-mcast-bgp section 13
> 
> Maria,
>

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 4 Mar 2009 12:40:30 -0800

Maria,

> Thanks.

Welcome.

> Can you share the answer now or should we wait for the updated version?

The latter.

Yakov.

---

From: Rahul Aggarwal <[email-masked]>
Date: Wed, 4 Mar 2009 16:02:04 -0800

Hi Maria,

Please look at the revised section 13 of
draft-ietf-l3vpn-2547bis-mcast-bgp-06.txt, that has now been posted, for
an answer. Also please look at comment 5 from the list of
comments/resolutions on the revised draft that was sent to the list.

rahul

---

From: "NAPIERALA, MARIA H, ATTLABS" <[email-masked]>
Date: Thu, 5 Mar 2009 13:31:17 -0500

There is a following issue when PEs with (*,G) state receive Source
Active Route for (S,G). 
This is the scenario:

                         RP------------------------|
                          |                        |
                         PE1----PE2---PE3---PE4----S
                                 |     |
                                 |     |
                                R1     R2

-R1 sends Join (*,G) to PE2 and R2 sends Join (*,G) to PE3 
-PE1 and PE3 originate C-(*,G) routes with PE1 as upstream PE
-RP joins "S" via a backdoor
-R2 stays on shared tree
-R1 switches to SPT, i.e., sends Join (S,G) to PE2 
-PE2 originates C-(S,G) route with PE4 as upstream PE (SPT is PE2-PE4-S)
-PE2 joins a P-tunnel (Tunnel-2) rooted at PE4 to receive "S" traffic
-PE4 announces Source Active route for (S,G)
-PE1, when it receives Source Active route for (S,G), sends (S,G,rpt)
Prune to RP
-PE3, when it receives Source Active route for (S,G), creates the
forwarding state for (C-S,C-G) (but does not originate C-(S,G) route)
-R1 sends Prune (*,G) to PE2
-PE2 withdraws C-(*,G) and C-(S,G) routes
-PE4 sends Prune (S,G) to "S", cutting off "S" traffic (R2 stops
receiving "S" traffic)
-PE4 withdraws Source Active Route for (S,G)
-PE1 sends Join (*,G) to RP 
-PE3 starts receiving "S" traffic from PE1

There will be "S" traffic loss from when PE4 Prunes (S,G) to when PE1
Joins (*,G) to RP and PE3 reverts back to accepting "S" traffic from
PE1. 
I think this is a problem because the traffic loss will not be
negligible. 

Maria

> From: Rahul Aggarwal [mailto:[email-masked]]
> Sent: Wednesday, March 04, 2009 7:02 PM

---

From: Rahul Aggarwal <[email-masked]>
Date: Wed, 11 Mar 2009 13:54:16 -0700

Hi Maria,

Please see below:

> I think this is a problem because the traffic loss will not be

1. It is to be noted that the above scenario arises only when the
receiver behind PE3 does not switch to SPT while the receiver behind PE2
does. That is, the SPT threshold for the DR connected to the receiver
behind PE2 is different from the SPT threshold for the DR connected to
the receiver behind PE3. How realistic is this scenario?

2. Irrespective of how realistic this scenario, to address the above
we will add to the spec the ability for PE4 to delay pruning itself
off the C-S tree, once PE4 receives the withdraw of the C-Multicast
source tree route for (C-S, C-G) that has been previousely advertised
by PE2 (i.e. when the last source tree C-Multicast route goes away).
The delay is controlled by a timer. The value of the timer must be
configurable.

The purpose of this timer is to ensure that PE1 does not prune (C-S,
C-G) off the source tree (and therefore does not stop forwarding
(C-S, C-G) onto the PMSI) until all PEs have had time to receive the
withdraw of the Source Active A-D route for (C-S, C-G), and PE1
starts forwarding of (C-S, C-G) on the RPT.

Note that before PE4 prunes C-S, there is a possibility to have
(C-S, C-G) packets being sent at the same time on the PMSI by both
PE1 and PE4. This would result in a transient unnecessary traffic
on the provider backbone.  However, no duplicates will reach customer
hosts subscribed to C-G as long as the downstream PEs apply procedures
described in section 9.1 of [MVPN].

3. Can you please explain how this traffic loss which "will not be
negligible" can be avoided when one uses the full per-MVPN PIM peering
across a MI-PMSI procedures (ala draft-rosen).

rahul