Subject: RE: Query regarding rfc4684 Constrained Route Distribution

From: Santanu Paul <[email-masked]>
Date: Tue, 23 Apr 2013 05:07:03 +0000

2nd Try

From: Santanu Paul
Sent: 17 April 2013 17:50
To: [email-masked]
Subject: Query regarding rfc4684 Constrained Route Distribution

Hi,

                This spec says "This mechanism is applicable to any BGP NLRI that controls the distribution of routing information by using Route Targets, such as VPLS [9<http://tools.ietf.org/html/rfc4684#ref-9>]." I have a question regarding this. If same RT is used for some L3VPN routes (AFI/SAFI= /128) and some L2VPN routes (AFI/SAFI=25/65) and a PE is providing both IP VPN and VPLS service, how it will distinguish which VPN service these RTs are meant for? Should not there be a AFI/SAFI element for the RTs in "Route Target Membership NLRI"?

Regards,
Santanu.

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 23 Apr 2013 07:10:31 +0200

2nd reply ..

Hi Paul,

We think of RT as characteristic of a VPN not a service within VPN. So
why would you want to break a VPN services apart for a given customer
site/vrf ?

Said this there was proposal
http://tools.ietf.org/html/draft-dong-idr-vpn-route-constrain-02 which
did not got much traction and sort of expired on it's own.

Besides if you really want to have separated services you can always
allocate new RT per service and not per VPN/vrf.

Best regards,
R.

On Tue, Apr 23, 2013 at 7:07 AM, Santanu Paul <[email-masked]> wrote:
>                 This spec says “This mechanism is applicable to any BGP NLRI
> that controls the distribution of routing information by using Route
> Targets, such as VPLS [9].” I have a question regarding this. If same RT is
> used for some L3VPN routes (AFI/SAFI= /128) and some L2VPN routes
> (AFI/SAFI=25/65) and a PE is providing both IP VPN and VPLS service, how it
> will distinguish which VPN service these RTs are meant for? Should not there
> be a AFI/SAFI element for the RTs in “Route Target Membership NLRI”?
>
>
>
> Regards,
>
> Santanu.

---

From: Kireeti Kompella <[email-masked]>
Date: Tue, 23 Apr 2013 05:53:23 -0700

Hi Santanu,

On Apr 22, 2013, at 22:07, Santanu Paul <[email-masked]> wrote:

> If same RT is used for some L3VPN routes (AFI/SAFI= /128) and some L2VPN routes (AFI/SAFI=25/65) and a PE is providing both IP VPN and VPLS service, how it will distinguish which VPN service these RTs are meant for?

The answer should be obvious, using the "if it hurts, don't do it" principle: don't use the same RT for two different VPN services.

Kireeti

---

From: Santanu Paul <[email-masked]>
Date: Wed, 24 Apr 2013 05:00:27 +0000

Hi,

	Thanks for your reply. So does this mean, to support this spec, different VPNs even if service type is different (e.g. L2/L3) have to have different RT though from L2VPN and L3VPN specs two VPNs one providing L2 service other L3 service can share same RT without any problem and if such configured, the configuration need to be changed in all PEs/RRs. I am trying to understand VPN technologies, and don't know if there are general practise/guidelines to use them unless it is spelled out in spec.

Santanu.

-----Original Message-----
From: Robert Raszuk [mailto:[email-masked]] 
Sent: 23 April 2013 10:41
To: Santanu Paul
Cc: [email-masked]; [email-masked]
Subject: Re: Query regarding rfc4684 Constrained Route Distribution

2nd reply ..

Hi Paul,

We think of RT as characteristic of a VPN not a service within VPN. So why would you want to break a VPN services apart for a given customer site/vrf ?

Said this there was proposal
http://tools.ietf.org/html/draft-dong-idr-vpn-route-constrain-02 which did not got much traction and sort of expired on it's own.

Besides if you really want to have separated services you can always allocate new RT per service and not per VPN/vrf.

Best regards,
R.

On Tue, Apr 23, 2013 at 7:07 AM, Santanu Paul <[email-masked]> wrote:
>                 This spec says "This mechanism is applicable to any 
> BGP NLRI that controls the distribution of routing information by 
> using Route Targets, such as VPLS [9]." I have a question regarding 
> this. If same RT is used for some L3VPN routes (AFI/SAFI= /128) and 
> some L2VPN routes
> (AFI/SAFI=25/65) and a PE is providing both IP VPN and VPLS service, 
> how it will distinguish which VPN service these RTs are meant for? 
> Should not there be a AFI/SAFI element for the RTs in "Route Target Membership NLRI"?
>
>
>
> Regards,
>
> Santanu.

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 24 Apr 2013 07:16:42 +0200

Hi,

It is ok to use same RT. And usually for a given VPN which requires L2
and L3 same RT makes sense. Likewise you need both L2 and L3 VPN
routes so RTC will request routes for both of those services in the
same time.

Best regards,
R.