Subject: Query regarding rfc4684 Constrained Route Distribution

From: Santanu Paul <[email-masked]>
Date: Wed, 17 Apr 2013 12:19:30 +0000

Hi,

                This spec says "This mechanism is applicable to any BGP NLRI that controls the distribution of routing information by using Route Targets, such as VPLS [9<http://tools.ietf.org/html/rfc4684#ref-9>]." I have a question regarding this. If same RT is used for some L3VPN routes (AFI/SAFI= /128) and some L2VPN routes (AFI/SAFI=25/65) and a PE is providing both IP VPN and VPLS service, how it will distinguish which VPN service these RTs are meant for? Should not there be a AFI/SAFI element for the RTs in "Route Target Membership NLRI"?

Regards,
Santanu.

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 17 Apr 2013 16:32:00 +0200

Hi Paul,

We think of RT as characteristic of a VPN not a service within VPN. So
why would you want to break a VPN services apart for a given customer
site/vrf ?

Said this there was proposal
http://tools.ietf.org/html/draft-dong-idr-vpn-route-constrain-02 which
did not got much traction and sort of expired on it's own.

Besides if you really want to have separated services you can always
allocate new RT per service and not per VPN/vrf.

Best regards,
R.

On Wed, Apr 17, 2013 at 2:19 PM, Santanu Paul <[email-masked]> wrote:
> Hi,
>
>
>
>                 This spec says “This mechanism is applicable to any BGP NLRI
> that controls the distribution of routing information by using Route
> Targets, such as VPLS [9].” I have a question regarding this. If same RT is
> used for some L3VPN routes (AFI/SAFI= /128) and some L2VPN routes
> (AFI/SAFI=25/65) and a PE is providing both IP VPN and VPLS service, how it
> will distinguish which VPN service these RTs are meant for? Should not there
> be a AFI/SAFI element for the RTs in “Route Target Membership NLRI”?
>
>
>
> Regards,
>
> Santanu.