Subject: The meaning of "global"

From: "Pat Thaler" <[email-masked]>
Date: Thu, 25 Jul 2013 12:59:28 +0000

"Global" seems to be used in this discussion and the data plane requirements to mean "unique in the administrative domain" as contrasted to a "local" identifier that is mapped to another value at some points in the domain.

On the other hand, when discussing VN Name in the hyperviser - NVE control plane, global is used in the sense that I understand global - i.e. unique in the world - e.g. a UUID. 24-bit identifiers aren't large enough to be global in that sense.

It would be better to use another term when we mean unique in the administrative domain.

Pat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Richard Li
Sent: Tuesday, July 23, 2013 5:12 PM
To: Kireeti Kompella; Lucy yong
Cc: L3VPN; Yakov Rekhter; [email-masked]; Aldrin Isaac; [email-masked]; UTTARO, JAMES
Subject: Re: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn

We may be able to get some wisdom from VLAN where both local and global ids are used.

The global vlan id is used to build a whole "subnet" across different and multi-hop Ethernet segments. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kireeti Kompella
Sent: Wednesday, July 24, 2013 12:46 AM
To: Lucy yong
Cc: [email-masked]; L3VPN; Yakov Rekhter; [email-masked]; Aldrin Isaac; UTTARO, JAMES
Subject: Re: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn

On Jul 23, 2013, at 19:28, Lucy yong <[email-masked]> wrote:

> Like to hear more the people opinions about: in SDN approach, will global ID and local ID are equally good (just mater choice) or one is better than other?

The SDN (centralized) approach makes allocation of global IDs easier. However, Xiaohu asked a data plane question. Local IDs are much easier for the data plane.

BTW, I am not in favor of centralizing everything. 

Kireeti
_______________________________________________
nvo3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nvo3

---

From: "Fedyk, Donald (Don)" <[email-masked]>
Date: Thu, 25 Jul 2013 13:28:40 +0000

Pat

Good Point.  We should refrain from global.  Addresses (MAC and IP) that are allocated and registered with a Number Authority are typically unique but labels, and identifiers and even addresses with local scope can have varying degrees of uniqueness. I think some form of mapping or translation cannot be ruled out if the packets/frames need to cross boundaries of the domains. 

While this discussion has been focused on the data plane the scope of ids has impact on how the ids are distributed in the control and management planes too.

Another point is in Ethernet VLAN is end to end consistent but the VID may be local in scope. 

Don 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Pat Thaler
Sent: Thursday, July 25, 2013 8:59 AM
To: Richard Li; Kireeti Kompella; Lucy yong
Cc: L3VPN; Yakov Rekhter; [email-masked]; Aldrin Isaac; [email-masked]; UTTARO, JAMES
Subject: [nvo3] The meaning of "global"

Pat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kireeti Kompella
Sent: Wednesday, July 24, 2013 12:46 AM
To: Lucy yong
Cc: [email-masked]; L3VPN; Yakov Rekhter; [email-masked]; Aldrin Isaac; UTTARO, JAMES
Subject: Re: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn

Kireeti

---

From: Lucy yong <[email-masked]>
Date: Fri, 26 Jul 2013 18:26:08 +0000

(change back to the original subject title)

For this context, the global VN ID means that the label is used as the VN identifier in the data plane and is allocated per VN basis (maybe by NVA); the local (VN) ID means that the label is allocated by individual NVEs and only has the significance for the NVE that creates it. Thus, each NVE has to distribute the local (VN) ID to all the other NVEs that are the members of the same VN, which requires some distributed control plane capability. The NVE may create one local ID for a VN or several local IDs associated to a VN.

Local ID mechanism provides some flexibility to NVE in egress forwarding process. However, if the major application of NVO3 is for the case that NVE resides on server, i.e. NVE and end-points resides on a same device, is this flexibility necessary? Sometimes "flexibility" also means "complexity". When using separated NVE forwarder and NVE controller, and having SDN based NVE controller, will local ID distribution make this solution more complex than using global VN ID?

NVO3 requires supporting both NVE local and NVE remote. Can one solution fit both applications well? or we need more than one solution and let providers to choose? 

Lucy

> Sent: Thursday, July 25, 2013 7:59 AM
> "Global" seems to be used in this discussion and the data plane
> requirements to mean "unique in the administrative domain" as
> contrasted to a "local" identifier that is mapped to another value at
> some points in the domain.
> 
> On the other hand, when discussing VN Name in the hyperviser - NVE
> control plane, global is used in the sense that I understand global -
> i.e. unique in the world - e.g. a UUID. 24-bit identifiers aren't large
> enough to be global in that sense.
> 
> > Like to hear more the people opinions about: in SDN approach, will
> global ID and local ID are equally good (just mater choice) or one is
> better than other?
> 
> The SDN (centralized) approach makes allocation of global IDs easier.
> However, Xiaohu asked a data plane question. Local IDs are much easier
> for the data plane.
>