Subject: [Lake] draft minutes of lake BoF

From: Stephen Farrell <[email-masked]>
Date: Mon, 29 Jul 2019 16:25:56 +0100

Hiya,

I've posted draft minutes at [1]. Please send needed
corrections to the list. OLD/NEW form preferred.

I believe the security ADs and IESG more broadly have
discussed how to proceed and will get back to us when
they've had a chance to get home and unpacked.

Cheers,
S.

[1] https://datatracker.ietf.org/meeting/105/materials/minutes-105-lake-00

---

From: Michael Richardson <[email-masked]>
Date: Tue, 30 Jul 2019 13:49:54 -0400

I am quoting as saying:

      currentlibrary. [...] What we try to do is key OSCORE. Don't want to run CoAP
      over DTLS, want to key OSCORE and let CoAP run. That's where transport agility
      comes from, across layers[?]. For X, given cTLS, let's do that -- but for
      things that go across several devices, please let's have EDHOC.

To explain the ?:
   It's across different transport mechanisms (not layers).
   CoAP/OSCORE can be transported across many things other than UDP, and if
   we do the AKE at the CoAP layer (rather than outside/around as DTLS does),
   then it is easier to get the properties we want.
   
   [This is the premise of the ATLAS work too]

the next sentence probably should be redacted. I remember saying it, but I
can't remember what message I was trying to express about "X".

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 30 Jul 2019 20:42:18 +0100

Hiya,

Tried to fix that at [1]. (Aside: there's  a codesprint
thing for someone: diffing minutes & agenda versions.)

Thanks,
S.

[1] https://datatracker.ietf.org/doc/minutes-105-lake/