Subject: [Lake] lake is now official, so...

From: Stephen Farrell <[email-masked]>
Date: Fri, 18 Oct 2019 17:57:45 +0100

Hiya,

So the lake WG is now official and we have a 1.5
hour session requested for IETF106.

I'd like to get a draft agenda for that sorted
in the next week, so please send any requests
for presentation slots or other agenda items.
Please say what you'd like to discuss and how
long you think that discussion may need.

Unicast or sending to the list are both fine,
whatever you prefer,

Cheers,
S.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 23 Oct 2019 13:39:43 -0400

> long you think that discussion may need.

Hi.

My requirements in draft-ietf-anima-constrained-voucher and
draft-ietf-6tisch-dtsecurity-zerotouch-join are for an AKE
that does:

1) RPK from server(network)->client(pledge)
2) certificate (IDevID) from client(pledge)->server(network)
3) identity protection of client's identity (IDevID)

This is hinted at in draft-selander-lake-reqs-02 section 2.4.2,
but the specifics above are not mentioned.  While some deployments might
prefer an entire certificate chain for (1), that chain can actually be
transfered after onboarding using a straight CORE block transfer.
That chain could also be transfered from an adjacent node in the mesh rather
than across the entire LLN.

I would welcome a mechanism that allowed the certificate to be sent by
reference rather than by value.  I would also like to be able to support
draft-birkholz-core-coid (both in-band and by reference) should it come to
fruition.

It appears that draft-hallambaker-mesh-udf-07 section 1.2.2
may facilitate this use, at 52 characters (in ascii) it is shorter. We can
probably do better by not base32 encoding, and making "udf://" implicit.

I don't know what we are going to with draft-selander-lake-reqs-02.
It would seem to fit into milestone 1, but it also seems like it is has
served that purpose already.

Stephen, if appropriate, I would be happy to further explain in a couple of
slides the requirements that come from 6tisch.  I would not put that very
high on the requirements for the WG, as this email is pretty much it.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 31 Oct 2019 10:04:40 +0000

Hi all,

Not sure if the announcement went to the list but
our wise ADs have added Mališa Vučinić (cc'd) as a
co-chair, which is great.

So a) please thank him for volunteering when you
see him and b) he and I will chat in the next day
or two and then get a draft agenda out over the
weekend or early next week.

Cheers,
S.