Subject: [Lake] lake draft agenda for ietf106

From: Stephen Farrell <[email-masked]>
Date: Mon, 4 Nov 2019 06:23:31 +0000

Hi all,

Mališa and I chatted about the agenda for IETF106 and
came up with [1] as a draft. Please feel free to suggest changes.

Cheers,
S.

[1] https://datatracker.ietf.org/doc/agenda-106-lake/

---

From: John Mattsson <[email-masked]>
Date: Thu, 7 Nov 2019 11:50:04 +0000

Hi Stephen, Mališa,
    
The agenda looks fine to us. 20 minutes is fine for outlining the update of the requirements draft in preparation for the adoption call.
    
We think it is good that you bring up one of the points from Karthik's mail - the use of static DH, which is in the context of the credential requirements. As you have noted, we have updated EDHOC on this point and it could be good to illustrate static DH with this update, as Karthik did in his email.
    
The other point from Karthik - identity protection of PSK and tradeoffs - should also be discussed. I'm happy to present that issue and lead the discussion unless Karthik wants to take that too.
    
Thanks
John

-----Original Message-----
From: Lake <[email-masked]> on behalf of Stephen Farrell <[email-masked]>
Date: Monday, 4 November 2019 at 07:24
To: "[email-masked]" <[email-masked]>
Subject: [Lake] lake draft agenda for ietf106

    Hi all,

    Cheers,
    S.

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 7 Nov 2019 12:12:42 +0000

Hi John,

On 07/11/2019 11:50, John Mattsson wrote:
> Hi Stephen, Mališa,
> 
> The agenda looks fine to us. 20 minutes is fine for outlining the
> update of the requirements draft in preparation for the adoption
> call.

Great.

> 
> We think it is good that you bring up one of the points from
> Karthik's mail - the use of static DH, which is in the context of the
> credential requirements. As you have noted, we have updated EDHOC on
> this point and it could be good to illustrate static DH with this
> update, as Karthik did in his email.
> 
> The other point from Karthik - identity protection of PSK and
> tradeoffs - should also be discussed. I'm happy to present that issue
> and lead the discussion unless Karthik wants to take that too.

As preparation for the meeting, it'd be great if people
(authors and others) were able to identify work items for
the reqs draft [1] that need resolving and that would
benefit from list and especially f2f discussion.

Maybe start a thread for each on the list so we can
get a feel for which might make best use of our f2f
time.

(While doing that, please keep in mind that the goal
is not to make a requirements RFC, so we don't need
to over-polish the text.)

Thanks,
S.

[1] https://tools.ietf.org/html/draft-selander-lake-reqs-03

> 
> Thanks John
> 
> -----Original Message----- From: Lake <[email-masked]> on
> behalf of Stephen Farrell <[email-masked]> Date: Monday, 4
> November 2019 at 07:24 To: "[email-masked]" <[email-masked]> Subject:
> [Lake] lake draft agenda for ietf106
> 
> 
> Hi all,
> 
> Mališa and I chatted about the agenda for IETF106 and came up with
> [1] as a draft. Please feel free to suggest changes.
> 
> Cheers, S.
>

---

From: Mališa Vučinić <[email-masked]>
Date: Wed, 13 Nov 2019 15:22:04 +0100

Hi all,

We uploaded a revised agenda for the Singapore meeting based on the feedback we received on and off the mailing list. The agenda is available at:

https://datatracker.ietf.org/doc/agenda-106-lake/

See you next week!

Mališa

> On 7 Nov 2019, at 13:12, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hi John,
> 
> <0x5AB2FAF17B172BEA.asc>-- 
> Lake mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lake

---

From: John Mattsson <[email-masked]>
Date: Fri, 15 Nov 2019 12:33:26 +0000

Hi Mališa, Stephen,

Another topic that has been brought up is the expected security properties of the application data (section 2.7 of the requirements draft). Basically, the expected properties are those which can be assumed in the particular message where the application data is sent, see:
https://mailarchive.ietf.org/arch/msg/lake/zcS8QMHZ5jxuH3z2MrelKcXjPjo
We could add a short slot in the agenda about that.

Cheers,
John

-----Original Message-----
From: Lake <[email-masked]> on behalf of Mališa Vučinić <[email-masked]>
Date: Wednesday, 13 November 2019 at 15:22
To: "[email-masked]" <[email-masked]>
Subject: Re: [Lake] lake draft agenda for ietf106

    Hi all,

    
    See you next week!
    
    Mališa

    -- 
    Lake mailing list
    [email-masked]

---

From: Mališa Vučinić <[email-masked]>
Date: Mon, 18 Nov 2019 02:52:05 +0100

Hi John,

Sounds good, we will add a 5-min slot for this.

Mališa

> On 15 Nov 2019, at 13:33, John Mattsson <[email-masked]> wrote:
> 
> Hi Mališa, Stephen,
>