Subject: [Lake] Randomness improvements

From: John Mattsson <[email-masked]>
Date: Fri, 22 Nov 2019 19:28:44 +0000

Hi,

During the LAKE session it was suggested that LAKE should make use of draft-irtf-cfrg-randomness-improvements-08. However that draft requires a signature key and that the device calculates signatures. This makes it unsuitable for many constrained IoT devices. Many IoT devices do not have a private signature key and adding code for signatures take up storage (which may be limited).

LAKE should perhaps recommend something similar as draft-irtf-cfrg-randomness-improvements-08, but that should likely be based on symmetric cryptography.

Cheers,
John

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 23 Nov 2019 22:09:22 +0000

Hiya,

I can see an argument for use of the same underlying
primitives in the AKE and randomness-improvements,
though I'm not sure that's really convincing (if you
can do some sort of FS, in practice, you can probably
do some kind of sig) but regardless...

On 22/11/2019 19:28, John Mattsson wrote:
> LAKE should perhaps recommend something similar as
> draft-irtf-cfrg-randomness-improvements-08, but that should likely be
> based on symmetric cryptography.
I'd be much happier with any such recommendations
coming via CFRG, i.e. aim to modify the CFRG draft
rather than provide alternative text from the LAKE
wg. (That'd also avoid us having to quibble about
non-requirements work being done here and now so
process-wise handling proposals to modify that CFRG
draft in CFRG are also maybe better right now.)

Cheers,
S.