Subject: Re: [Lake] WG process beyond requirements

From: Benjamin Kaduk <[email-masked]>
Date: Sat, 1 Feb 2020 22:26:06 -0800

On Tue, Jan 28, 2020 at 04:08:53PM +0000, Göran Selander wrote:
> Hi,
> 
> On 2020-01-28, 16:03, "Stephen Farrell" <[email-masked]> wrote:
>     Just as an alternative to consider (i.e., I'm not saying I
>     think this is best, just that it's a possibility), the lake
>     wg could also adopt a draft e.g. if only one (like edhoc)
>     were on offer, but remain open to e.g. ctls turning up later,
>     whenever work on that is completed by the tls wg, which is
>     likely some time ahead I'd say.
>     
>     IOW, adopting a draft soonish (when the requirements are done
>     WGLC), doesn't mean that we need all possible designs that'll
>     ever meet the lake requirements to be at the same stage of
>     development in the very near term.
>     
> 
> GS: I'm all in favor of adopting a candidate fulfilling the requirements as a start and decide on other candidates later. But this is a new turn. One year ago in Secdispatch we were requested to define relevant benchmarks and then to formulate requirements, both of these activities were intended for making comparisons between different protocols. Perhaps that is water under the bridge now.

I don't think the sole (or even primary) reason for desiring
benchmarks/requirements was to have a comparison between protocols, but
rather to ensure that we (collectively) understand the problems we are
trying to solve and that any/all proposed solutions are fit for purpose.

-Ben

---

From: "Blomqvist, Peter" <[email-masked]>
Date: Mon, 3 Feb 2020 08:06:53 +0000

We are are also interested in the continuation of OSCORE as mentioned 
earlier by RISE and therefore we support the view to prioritize 
finalizing requirements to be able to move forward in LAKE WG.

Best
Peter

---

From: Göran Selander <[email-masked]>
Date: Mon, 3 Feb 2020 15:22:59 +0000

On 2020-02-02, 07:26, "Benjamin Kaduk" <[email-masked]> wrote:

    On Tue, Jan 28, 2020 at 04:08:53PM +0000, Göran Selander wrote:
    > [GS] I'm all in favor of adopting a candidate fulfilling the requirements as a start and decide on other candidates later. But this is a new turn. One year ago in Secdispatch we were requested to define relevant benchmarks and then to formulate requirements, both of these activities were intended for making comparisons between different protocols. Perhaps that is water under the bridge now.

[GS] Thanks for clarification. Returning to the question from the chairs:

> We'd like to ask the WG how people would like to proceed
> after that point, not to decide that right now, but
> mostly to get input and ideas and so we (as chairs) don't
> surprise anyone after we hopefully declare victory on the
> requirements in the not-too-distant future.

With the AD's clarification in mind I take back my proposal to compare candidates, and instead propose to work on ensuring that candidates are fit for purpose in terms of complying with requirements. In order to not lose momentum for the second milestone we can start this as soon as the requirements draft is in WGLC, and discuss available results at IETF 107.

Thanks
Göran