Subject: [Lake] 1 week 2nd WGLC on requirements and scoping text

From: Stephen Farrell <[email-masked]>
Date: Sun, 24 May 2020 22:07:52 +0100

Hi all,

First: my apologies for taking so long on this. (I got
sidetracked by an unexpected project.)

ISTM we have pretty good, if rough, consensus on enough of
the text to proceed, but with one important part that needs
checking. (See below.)

I'd like to start a 1 week 2nd WGLC with the main focus
being to establish whether we have rough consensus on the
scoping text below. (Which can be see in context at [2].)
That text was the main outcome of our virtual meeting last
month.

So, please send mail to the list saying if you are happy
enough to proceed on this basis. If you are not, then I'd
appreciate if you could suggest alternate text with as
few changes as possible.

This 2nd WGLC closes on June 1st. If I see rough
consensus to proceed at that point, I'll plan to start a
call for adoption for the edhoc draft. If not, we'll have
to discuss how to proceed with our AD, as I think that
would mean that the WG is very badly stuck.

The scoping text added was:

   As illustrated above, the setting is much more diverse
   in terms of credentials and trust anchors than that of
   the unconstrained web.  In order to deliver a timely
   result, there is a need to initially focus on what is
   considered most important at the time of writing: RPK
   (by reference and value) and certificate by reference.
   Information about validity of a certificate may be
   omitted from the AKE if available over unconstrained
   links.  The case of transporting certificate validation
   information over the AKE may be specified in the initial
   phase if there is a lightweight solution that matches
   existing standards and tools.

   A subsequent extension beyond the initial focus may be
   inevitable to maintain a homogenous deployment without
   having to implement a mix of AKE protocols, for example,
   to support the migration path described above.  The AKE
   needs to make clear the scope of cases analysed in the
   initial phase, and that a new analysis is required for
   additional cases.

Thanks,
Stephen.

[1] https://tools.ietf.org/html/draft-ietf-lake-reqs-03
[2] https://tools.ietf.org/html/draft-ietf-lake-reqs-03#section-2.2.1

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 29 May 2020 15:04:24 +0000

Hi Stephen,

> This 2nd WGLC closes on June 1st. If I see rough consensus to proceed at that point, I'll plan to start a call for adoption for the edhoc draft. If not, we'll have to discuss how to proceed with our AD, as I think that would mean that the WG is very badly stuck.

This is a bit surprising to me. It is great that you do the rough consensus on the requirements draft but does this imply that this should lead to a call for adoption of the EDHOC draft? You know my answer.

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 29 May 2020 17:00:55 +0100

Hiya,

On 29/05/2020 16:04, Hannes Tschofenig wrote:
> This is a bit surprising to me. It is great that you do the rough
> consensus on the requirements draft but does this imply that this
> should lead to a call for adoption of the EDHOC draft? You know my
> answer.
I also got asked about that offlist. My logic here is
that cTLS is being processed in the TLS WG so will
proceed anyway. There's a set of people who clearly do
want edhoc and want to do that here. I don't see any
other potential protocols to meet these requirements.
Therefore if we have rough consensus on the requirements,
and thing-A is happening elsewhere ISTM the next thing
is to ask if we have rough consensus to do thing-B
here or not. That's basically an adoption call for the
edhoc draft I think.

Cheers,
S.

PS: Hannes' was the only on-list response so far. That
is not enough for me to declare consensus.

---

From: Francesca Palombini <[email-masked]>
Date: Sun, 31 May 2020 20:51:09 +0000

Hi Stephen,

I am happy with this text, and support the working group moving forward.

Thanks,
Francesca 

On 24/05/2020, 23:08, "Lake on behalf of Stephen Farrell" <[email-masked] on behalf of [email-masked]> wrote:

    Hi all,

    Thanks,
    Stephen.

---

From: Christian Amsüss <[email-masked]>
Date: Sun, 31 May 2020 23:10:18 +0200

Hello Stephen, hello LAKE WG,

> appreciate if you could suggest alternate text with as

The current requirements document (even with the initial focus -- the
two projects I'll need a CoAP-transportable LAKE for would need RPKs in
one and certificates-don't-care-whether-by-reference-or-not in the
other) fit my use cases. Any document that satisfies the requirements
set out in here will work for me.

Kind regards
Christian

-- 
We are dreamers, shapers, singers, and makers.
  -- Elric

---

From: "Blomqvist, Peter" <[email-masked]>
Date: Sun, 31 May 2020 21:41:09 +0000

Stephen and all,
I support the WG moving forward.

Best
Peter
________________________________
From: Lake <[email-masked]> on behalf of Francesca Palombini <francesca.palombini=[email-masked]>
Sent: Sunday, May 31, 2020 10:51:09 PM
To: Stephen Farrell <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Lake] 1 week 2nd WGLC on requirements and scoping text

Hi Stephen,

Thanks,
Francesca

    Hi all,

    Thanks,
    Stephen.

    [1] https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dlake-2Dreqs-2D03&d=DwIGaQ&c=fP4tf--1dS0biCFlB0saz0I0kjO5v7-GLPtvShAo4cc&r=ReOhyTHbHxF59rwa6NKLJmWnWtc32YE99Fj4rlHBZBM&m=RNMrW6e3Urc3aK2SEA4mNr-ZlZVhUsVlI-2ltDGEsQs&s=cXLr4bI_XbgTxTj7LDmLUX-zgIcRsc8mWMr349Qdz2Q&e=
    [2] https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dlake-2Dreqs-2D03-23section-2D2.2.1&d=DwIGaQ&c=fP4tf--1dS0biCFlB0saz0I0kjO5v7-GLPtvShAo4cc&r=ReOhyTHbHxF59rwa6NKLJmWnWtc32YE99Fj4rlHBZBM&m=RNMrW6e3Urc3aK2SEA4mNr-ZlZVhUsVlI-2ltDGEsQs&s=AtQorPmHMsXYqgn1bZWqkXQECu9D2NR54PrTAlX9vYs&e=

--
Lake mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_lake&d=DwIGaQ&c=fP4tf--1dS0biCFlB0saz0I0kjO5v7-GLPtvShAo4cc&r=ReOhyTHbHxF59rwa6NKLJmWnWtc32YE99Fj4rlHBZBM&m=RNMrW6e3Urc3aK2SEA4mNr-ZlZVhUsVlI-2ltDGEsQs&s=u44OmRHXc6Q2-vHJY5QrYE2ZMgOPmfpjHG8l7zbeI8M&e=