Subject: Re: [Lake] Call for adoption for draft-selander-lake-edhoc - respond by June 22

From: Robert Cragie <[email-masked]>
Date: Mon, 22 Jun 2020 13:58:55 +0000

I oppose the adoption of EDHOC as I believe EDHOC and OSCORE are reinventing the wheel.

There seems to be this view that TLS and DTLS are unsuitable for IoT and technologies such as LPWAN and low power wireless PANs (e.g. 802.15.4). However, I would like to point out that we were successfully deploying:

1. Network admission using PANA, EAP and EC certificate-based TLS with Zigbee IP [1]
2. Application layer security using EC certificate-based TLS with SEP 2.0 [2]

This was ten years ago on microcontrollers with considerably less capability than those available now. Zigbee IP never gained much traction, however the successor to Zigbee IP, Thread, also deploys:

1. Network admission using EC JPAKE and EC certificate-based DTLS and CoAP-based relay mechanism [3]

The reason for using TLS in both cases as a basis was entirely due to not wanting to reinvent the wheel and come up with a new approach, as we acknowledged the hard work and effort put in by the TLS working group in not only coming up with the protocols and ciphersuites but also the significant amount of scrutiny and testing that implementations had gone through, hardening both the implementations and the standards themselves.

There is no doubt that the key exchange transactions we used could be made more efficient but, in my view, the correct approach is to build upon the solid foundation of TLS through efforts such as cTLS and not to try and start again.

Robert

[1] https://datatracker.ietf.org/meeting/83/materials/slides-83-lwig-5
[2] https://www.ei.se/Documents/Projekt/Funktionskrav%20elm%C3%A4tare/2017/SEP%202pkt0.pdf
[3] https://www.threadgroup.org/Portals/0/documents/support/CommissioningWhitePaper_658_2.pdf

From: Lake <[email-masked]> On Behalf Of Mališa Vucinic
Sent: Monday, June 8, 2020 3:55 PM
To: [email-masked]
Subject: [Lake] Call for adoption for draft-selander-lake-edhoc - respond by June 22

Hi all,

Since we now have a rough consensus on the requirements document, we are proceeding with the selection of the LAKE for OSCORE our working group is chartered to work on. Given:

- the LAKE working group charter,
- a wide community support over an extensive period of time for draft-selander-lake-edhoc,
- adoption of the cTLS draft by the TLS working group where it will be further developed,
- that no other drafts have been submitted for consideration of the LAKE working group,

we are now launching a call for adoption for https://tools.ietf.org/html/draft-selander-lake-edhoc-01.

Please reply to this thread whether you support the adoption, and indicate if you are ready to review if this draft becomes a working group document.

The call for adoption ends on June 22nd, 2020.

Your LAKE chairs.

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Robert Cragie <[email-masked]>
Date: Tue, 23 Jun 2020 10:40:53 +0000

Prompted by some of the recent e-mails, I should also add that another primary reason for choosing TLS as the basis for network admission was reuse, i.e. a single TLS code base could be used for both network admission and application layer security. In addition to being more efficient, this will likely become more important with the advent of trusted environments (e.g. Arm TrustZone-M [1]), where the less code that has to reside in the TEE, the better.

Robert

[1] https://www.arm.com/why-arm/technologies/trustzone-for-cortex-m

From: Lake <[email-masked]> On Behalf Of Robert Cragie
Sent: 22 June 2020 14:59
To: [email-masked]
Subject: Re: [Lake] Call for adoption for draft-selander-lake-edhoc - respond by June 22

Robert

From: Lake <[email-masked]<mailto:[email-masked]>> On Behalf Of Mališa Vucinic
Sent: Monday, June 8, 2020 3:55 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Lake] Call for adoption for draft-selander-lake-edhoc - respond by June 22

Hi all,

Your LAKE chairs.