Subject: Re: [Lake] Call for adoption for draft-selander-lake-edhoc - respond by June 22

From: Timothy Claeys <[email-masked]>
Date: Wed, 17 Jun 2020 11:10:18 +0200

Dear all,

I also support the adoption of the document.

We will soon start the implementation of EDHOC in the OpenWSN networking 
stack, a reference implementation of the 6TiSCH protocol suite. It will 
complement the OSCORE implementation, and allow us to do performance 
tests in constrained environments.

Timothy Claeys

---

From: Karl Norrman <[email-masked]>
Date: Wed, 17 Jun 2020 10:07:40 +0000

Hi!

For your information, and without taking any stand on the question of adoption, a team of people from KTH, ITU Copenhagen and Ericsson are working on formal verification of EDHOC using  the Tamarin tool. We have proven some fundamental properties for all five methods so far and are currently writing up the analysis.

We work with a version of the draft from 2020-03-01. After a quick scan, there appear to be no differences compared to draft-selander-lake-edhoc-01.txt which affect our model.

Some of the properties we have verified:
 - PFS for session key material
 - Session key material independence (between sessions)
 - Injective agreement on session key material
 - Mutual entity authentication (based on the assumption that party identities are properly tied to the credentials, in line with Section 3.2 of the draft)

The details can be read in the paper when it becomes available.

BR Karl