Subject: Re: [Lake] EDHOC Interop

From: Francesca Palombini <[email-masked]>
Date: Fri, 11 Dec 2020 13:19:09 +0000

Hi all,

Stefan and Timothy, our first two volunteer implementers, successfully run a first interop based on the test vector data (Appendix B.1) in one direction (Stefan as client, Timothy as server), with resulting TH4 and PRK_4x3m coinciding with each other and with our calculated test vector. The other direction proved more complicated, and we did not manage to complete the exchange (most likely because of a problem with running Stefan's server on an AWS).

This interop gave us authors great feedback on improving the test vectors in the draft, and possible additional output to include in the current github repository.

A detailed report of the interop and resulting TODO list is collected in the notes: https://docs.google.com/document/d/15iNr_-rYL87c6NZtZybqBvZza10xcA1eC5YyA_tXVB0/edit?usp=sharing 

Thanks again to all joining, and looking forward to resume our interop efforts after the holidays.
Francesca

On 08/12/2020, 15:28, "Lake on behalf of Francesca Palombini" <[email-masked] on behalf of francesca.palombini=[email-masked]> wrote:

    Hi all,

    Just a heads up: we have set up a first interop to test EDHOC authenticated with Signature Keys using x5t for this coming Friday 11th of December, 10-12 CET. We are still defining the details, but most likely the exchange will happen over CoAP, and the cipher suite used will be 0. If anybody is interested in participating, either with an implementation or just as a spectator, please reach out to me.
    We hope to report the results at our interim next week.

    Thanks,
    Francesca

    -- 
    Lake mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/lake

---

From: Mališa Vučinić <[email-masked]>
Date: Fri, 11 Dec 2020 14:40:08 +0100

Thanks Francesca for this report! Exciting news, indeed.

Mališa

On 11/12/2020 14:19, "Lake on behalf of Francesca Palombini" <[email-masked] on behalf of francesca.palombini=[email-masked]> wrote:

    Hi all,

    

    
        Hi all,

        Thanks,
        Francesca

---

From: Francesca Palombini <[email-masked]>
Date: Wed, 16 Dec 2020 16:55:00 +0000

Thanks Malisa!

In order to prepare for the next interim, please enter your preference in the following doodle: https://doodle.com/poll/mrhqqewzinegnmtq 
The goal is to have a second interop during the 3rd week of January.

Thanks,
Francesca

On 11/12/2020, 14:41, "Mališa Vučinić" <[email-masked]> wrote:

    Mališa

        Hi all,

        A detailed report of the interop and resulting TODO list is collected in the notes: https://protect2.fireeye.com/v1/url?k=67e781d1-387cb8d7-67e7c14a-86ee86bd5107-ad518f2c7f9b3c98&q=1&e=1423ec4a-92ea-4519-a8b7-9e8d0095fe69&u=https%3A%2F%2Fdocs.google.com%2Fdocument%2Fd%2F15iNr_-rYL87c6NZtZybqBvZza10xcA1eC5YyA_tXVB0%2Fedit%3Fusp%3Dsharing 

            Hi all,

            Thanks,
            Francesca