Subject: Re: [Lake] EDHOC implementation available as open source

From: Mališa Vučinić <[email-masked]>
Date: Tue, 30 Mar 2021 12:45:51 +0200

Hi Stefan,

This is very interesting, thanks for sharing. I gather that your EDHOC implementation takes roughly 10k of flash memory, not including the crypto, and up to 4k of RAM. I understand that you did not use the crypto hardware acceleration in the evaluation? Could you share with the working group which (public-key) algorithms are accelerated on these platforms? Any hints on what would the results in Figure 14 look like when using the accelerators?

Note to all: Stefan will give an overview of these results and his implementation during our upcoming interim meeting.

Mališa

From: Lake <[email-masked]> on behalf of "Hristozov, Stefan" <[email-masked]>
Date: Tuesday 30 March 2021 at 11:44
To: "[email-masked]" <[email-masked]>
Subject: [Lake] EDHOC implementation available as open source

Dear all,

I would like to inform you that we open sourced our EDHOC and OSCORE implementations (Apache 2 or MIT License ) [1]. Additionally, we provide evaluation of our implementations in [2].

Feedback and collaboration are highly appreciated. 

Best regards 

Stefan 

[1]: https://github.com/Fraunhofer-AISEC/uoscore-uedhoc

[2]: https://arxiv.org/pdf/2103.13832.pdf

-- 
Stefan Hristozov

Department Hardware Security

Fraunhofer Institute for Applied and Integrated Security AISEC

Lichtenbergstraße 11, 85748 Garching near Munich, Germany

Tel. +49 89 32299 86 157

[email-masked]

https://www.aisec.fraunhofer.de/

-- Lake mailing list [email-masked] https://www.ietf.org/mailman/listinfo/lake

---

From: "Hristozov, Stefan" <[email-masked]>
Date: Tue, 30 Mar 2021 16:35:21 +0000

Hi all,

@ Malisa:
* yes ~10KB flash and ~4KB RAM are required.

* The following accelerators are available on the platforms which we used for the evaluation:

* nRF51422: AES only
* ESP32: AES, SHA, RSA, ECC, big Integer Multiplication and Big Integer Modular Multiplication
* nRF52832: AES only
* nRF9160: RSA, secp160r1, secp192r1, secp224r1, secp256r1, secp384r1, secp521r1, secp160k1, secp192k1, secp224k1, secp256k1, Ed25519, Curve25519, SHA-1/2, AES, ChaCha20/Poly1305
* How fast will be EDHOC when using an accelerator? This is matter of evaluation for every individual accelerator. E.g. some unofficial numbers are available for the NRF9160 in [1]. From [1] we have:
* ECDH secp256r1 35.9947ms
* ECDSA Verify secp256r1 38.5376ms.
Therefore, I think it is save to assume that EDHOC will not take more than few hundred ms in any of the different modes on the NRF91 when the accelerator is used.

Br,
Stefan

[1]:https://devzone.nordicsemi.com/f/nordic-q-a/18578/arm-cryptocell-310-performance/184100#184100

On Tue, 2021-03-30 at 12:45 +0200, Mališa Vučinić wrote:
Hi Stefan,

Mališa

Dear all,

Best regards
Stefan

[email-masked]<mailto:[email-masked]>

--

Stefan Hristozov
[email-masked]<mailto:[email-masked]>