Subject: [Lake] Error message "Success" (relates to #74)

From: Göran Selander <[email-masked]>
Date: Fri, 23 Apr 2021 13:34:12 +0000

Another issue we didn't have time to discuss was regarding values of error codes, see
https://github.com/lake-wg/edhoc/issues/74

Two questions with regards to Error code "Success"

* In -06 we have assigned error code -1 for Success. This does not align with values used for success codes in other settings, any view on that?

* What should be the type of the payload (if any) of a Success message? Text string? Containing what?

Any input is welcome.

Thanks
Göran

74 <— Align with two Sucess 0, success 2. TBD for success.

---

From: John Mattsson <[email-masked]>
Date: Tue, 27 Apr 2021 14:37:32 +0000

Many OSs, shells, and programming languages (e.g. C) use 0 for success and everything non-zero (negative or positive) is considered an error. This seems like a good approach for EDHOC as well.

John

-----Original Message-----
From: Lake <[email-masked]> on behalf of Göran Selander <goran.selander=[email-masked]>
Date: Friday, 23 April 2021 at 15:34
To: "[email-masked]" <[email-masked]>
Subject: [Lake] Error message "Success" (relates to #74)

Another issue we didn't have time to discuss was regarding values of error codes, see
https://protect2.fireeye.com/v1/url?k=d144fa19-8edfc000-d144ba82-8682aaa22bc0-6c57ad5434ca2797&q=1&e=e991de8b-9403-4dc8-8173-4cc9ce577129&u=https%3A%2F%2Fgithub.com%2Flake-wg%2Fedhoc%2Fissues%2F74

Any input is welcome.

Thanks
Göran

-- 
Lake mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lake