Subject: [Lake] FW: New Version Notification for draft-ietf-lake-edhoc-09.txt

From: Göran Selander <[email-masked]>
Date: Mon, 23 Aug 2021 13:39:44 +0000

Hello LAKE,

Following the plan from IETF 111, we have now submitted -09 addressing the major issues recorded to date. We think this is a good version for continued testing and security analysis.

The main changes compared to -08 are listed in the change log, details in the diff, here are the highlights:

* MAC_2 and MAC_3 are now generated with EDHOC-KDF instead of COSE_Encrypt0.  This change was straightforward with an update to the KDF now supporting an optional general “context” field. 

* A new parameter "EDHOC MAC length" is added to the cipher suite.

* G_Y and CIPHERTEXT_2 of message_2 are now combined into one CBOR bstr. 

* The key identifier ‘kid’ is extended to also support CBOR ints, making ‘kid2’ introduced in -08 redundant. This change was based on feedback from the COSE WG [1]. One potential next step is to move all COSE-related IANA registrations from this draft to a separate COSE draft and make an informative reference.

* The prepended byte used to distinguish message_1 in a CoAP setting is now of CBOR simple type “true” (0xf5), avoiding potential confusion with "null".

* More details on the use of different credentials, in particular CWT and UCCS.

* External authorization data is now defined as a sequence of “(type, content)”. (An IANA register for different types was already in -08.)

* Updated message size examples.

This version also has some updated security considerations + a few of restructured sections, a number of clarifications and editorials.

One thing we know has been of good use to implementers is appendix D with its test vectors and detailed transcript printouts. We have not had time to update those yet but plan to do so soon. Meanwhile we removed all content from appendix D which reduced the number of pages by 25, addressing one of the open issues (#142). We propose to put the updated transcript printouts in a separate draft in the same github repo, and replace appendix D with an informative reference.

Next steps also include closing github issues, many of which have been resolved in -09.

Any comments are welcome!

Göran

[1] https://mailarchive.ietf.org/arch/msg/cose/qGngdte4s3SEZEKM-xBEoXYUgKc/

On 2021-08-23, 14:44, "[email-masked]" <[email-masked]> wrote:

    A new version of I-D, draft-ietf-lake-edhoc-09.txt
    has been successfully submitted by Göran Selander and posted to the
    IETF repository.

    Name:		draft-ietf-lake-edhoc
    Revision:	09
    Title:		Ephemeral Diffie-Hellman Over COSE (EDHOC)
    Document date:	2021-08-23
    Group:		lake
    Pages:		75
    URL:            https://www.ietf.org/archive/id/draft-ietf-lake-edhoc-09.txt
    Status:         https://datatracker.ietf.org/doc/draft-ietf-lake-edhoc/
    Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-lake-edhoc
    Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-lake-edhoc-09

    Abstract:
       This document specifies Ephemeral Diffie-Hellman Over COSE (EDHOC), a
       very compact and lightweight authenticated Diffie-Hellman key
       exchange with ephemeral keys.  EDHOC provides mutual authentication,
       forward secrecy, and identity protection.  EDHOC is intended for
       usage in constrained scenarios and a main use case is to establish an
       OSCORE security context.  By reusing COSE for cryptography, CBOR for
       encoding, and CoAP for transport, the additional code size can be
       kept very low.

    The IETF Secretariat

---

From: Michael Richardson <[email-masked]>
Date: Mon, 23 Aug 2021 13:17:08 -0400

Göran Selander wrote:
    > * The key identifier ‘kid’ is extended to also support CBOR ints,
    > making ‘kid2’ introduced in -08 redundant. This change was based on
    > feedback from the COSE WG [1]. One potential next step is to move all
    > COSE-related IANA registrations from this draft to a separate COSE
    > draft and make an informative reference.

I understanding splitting the document so that it is easier to update,
but I think that the reference should be normative.

I think we want to publish the documents together.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 23 Aug 2021 21:42:33 +0200

> One potential next step is to move all COSE-related IANA registrations from this draft to a separate COSE draft and make an informative reference.

Why?

Grüße, Carsten