Subject: [Lake] I-D Action: draft-ietf-lake-edhoc-11.txt

From: [email-masked]
Date: Fri, 24 Sep 2021 01:36:29 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Lightweight Authenticated Key Exchange WG of the IETF.

        Title           : Ephemeral Diffie-Hellman Over COSE (EDHOC)
        Authors         : Göran Selander
                          John Preuß Mattsson
                          Francesca Palombini
	Filename        : draft-ietf-lake-edhoc-11.txt
	Pages           : 79
	Date            : 2021-09-24

Abstract:
   This document specifies Ephemeral Diffie-Hellman Over COSE (EDHOC), a
   very compact and lightweight authenticated Diffie-Hellman key
   exchange with ephemeral keys.  EDHOC provides mutual authentication,
   forward secrecy, and identity protection.  EDHOC is intended for
   usage in constrained scenarios and a main use case is to establish an
   OSCORE security context.  By reusing COSE for cryptography, CBOR for
   encoding, and CoAP for transport, the additional code size can be
   kept very low.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lake-edhoc/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-lake-edhoc-11.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lake-edhoc-11

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Göran Selander <[email-masked]>
Date: Fri, 24 Sep 2021 09:02:40 +0000

All,

As announced we have uploaded -11 which addresses all protocol impacting issues known to date. We 

Restructured section on authentication parameters
Changed UCCS to CCS
Changed names and description of COSE header parameters for CWT/CCS
Changed several of the KDF and Exporter labels
Removed edhoc_aead_id from info (already in transcript_hash)
Added MTI section
EAD: changed CDDL names and added value type to registry
Updated Figures 1, 2, and 3
Some correction and clarifications
Added core.edhoc to CoRE Resource Type registry

On 2021-09-24, 10:36, "Lake on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    Abstract:

    -- 
    Lake mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/lake

---

From: Göran Selander <[email-masked]>
Date: Fri, 24 Sep 2021 09:27:17 +0000

Let me try again. 

A new version of EDHOC is just posted. We think this is ready for interop testing and reviewing.

This is the third version in a short period of time following early implementation feedback on the major revision -09, and a design team meeting discussing some aspects of -10.

The main changes are listed in the mail below. To highlight some, there are a number of changes to labels, syntax, etc. These changes have no significance on the overall protocol but impacts the test vectors. Another change with similar impact is the change of the info structure used in key derivation, where edhoc_aead_id is removed since we realized it is already included in the selected cipher suite and thus redundant. There are also more details and clarifications about authentication parameters. 

This draft is complemented with a new version of the test vector draft, updated to edhoc-11:
https://www.ietf.org/archive/id/draft-selander-lake-traces-01.html
A more extensive test vector suite in JSON and related code that was used to generate them can be found at: https://github.com/lake-wg/edhoc/tree/master/test-vectors-11

We are looking forward to feedback, at the upcoming LAKE interim or whenever, in particular what people think if this is ready to progress. 

Göran

On 2021-09-24, 11:03, "Lake on behalf of Göran Selander" <[email-masked] on behalf of goran.selander=[email-masked]> wrote:

    All,

        Abstract: