Subject: [Lake] I-D Action: draft-ietf-lake-edhoc-10.txt

From: [email-masked]
Date: Sat, 04 Sep 2021 09:55:58 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Lightweight Authenticated Key Exchange WG of the IETF.

        Title           : Ephemeral Diffie-Hellman Over COSE (EDHOC)
        Authors         : Göran Selander
                          John Preuß Mattsson
                          Francesca Palombini
	Filename        : draft-ietf-lake-edhoc-10.txt
	Pages           : 76
	Date            : 2021-09-04

Abstract:
   This document specifies Ephemeral Diffie-Hellman Over COSE (EDHOC), a
   very compact and lightweight authenticated Diffie-Hellman key
   exchange with ephemeral keys.  EDHOC provides mutual authentication,
   forward secrecy, and identity protection.  EDHOC is intended for
   usage in constrained scenarios and a main use case is to establish an
   OSCORE security context.  By reusing COSE for cryptography, CBOR for
   encoding, and CoAP for transport, the additional code size can be
   kept very low.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lake-edhoc/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-lake-edhoc-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lake-edhoc-10

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: John Mattsson <[email-masked]>
Date: Sat, 4 Sep 2021 17:34:18 +0000

Hi,

During implementation of test vectors for -09 we noticed some minor problems that required updating the specification. We
felt it was important to quickly publish test vectors along with a matching specification. We have therefore published -10 with the following changes:

- That the application was able to input a CBOR sequence in the exporter could lead to info not being well-formed CBOR
unless context was validated by the EDHOC application. Context has therefore been changed to an ordinary byte string
(wrapping the CBOR sequence in case of MAC_2 and MAC_3).

- The flexible truncation of SUITES_I led to a lot of questions from implementors a year ago and the test vectors had
previously been simplified. We now updated the specification to always use the maximum truncation of SUITES_I following the
previous test vectors. This also means that the selected suite int is no longer needed which saves 1 byte in some cases.

- The UCCS example was missing a 'kid' parameter which is needed to use it by reference.

Updates to the COSE IANA registrations:

- CWT and UCCS now has two separate header parameters 'cwt' and 'uccs'. They have quite different security properties.

- We noticed that that there is a third 'kid' parameter. The draft now extends the CWT Confirmation Method kid
parameter to bstr / int

I have implemented test vectors that aligns with the -10 version. Source code and a text file with a several test
vectors can be found here

https://github.com/lake-wg/edhoc/tree/master/test-vectors-10

The new test vectors also include message_4, as well as examples of uccs, ead, and messages. The new test vectors will
be used to create something like the test vector appendix in -08 (either as an appendix or a separate draft).

Cheers,
John

From: Lake <[email-masked]> on behalf of [email-masked] <[email-masked]>
Date: Saturday, 4 September 2021 at 18:57
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [Lake] I-D Action: draft-ietf-lake-edhoc-10.txt

Abstract:

--
Lake mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lake

---

From: John Mattsson <[email-masked]>
Date: Mon, 6 Sep 2021 13:44:51 +0000

Hi,

I very quickly transformed my -10 test vectors to JSON (or almost JSON as JSON forbids a trailing comma and I was too lazy to do that).
https://github.com/lake-wg/edhoc/tree/master/test-vectors-10-json

I just quickly tried to convert my test vecors to JSON. I tried to somewhat align with Timothy, but there are some differences.
https://github.com/lake-wg/edhoc/issues/78

In my test vectors, names ending with _raw is not CBOR and everything not ending with _raw are CBOR sequences.

Happy to change my JSON test vectors to any format implementors would want for interop testing.

Cheers,
John

From: Lake <[email-masked]> on behalf of John Mattsson <john.mattsson=[email-masked]>
Date: Saturday, 4 September 2021 at 19:35
To: [email-masked] <[email-masked]>
Subject: Re: [Lake] I-D Action: draft-ietf-lake-edhoc-10.txt
Hi,

https://github.com/lake-wg/edhoc/tree/master/test-vectors-10<https://protect2.fireeye.com/v1/url?k=70766edd-2fed57f6-70762e46-866038973a15-d46f3b783c4a1890&q=1&e=6131de5c-08be-4ab0-9e32-780c6d9888ed&u=https%3A%2F%2Fgithub.com%2Flake-wg%2Fedhoc%2Ftree%2Fmaster%2Ftest-vectors-10>

Cheers,
John

Abstract: