Subject: [Lake] Call for adoption of draft-selander-lake-traces

From: Mališa Vučinić <[email-masked]>
Date: Mon, 18 Oct 2021 12:52:34 +0200

Dear all,

As discussed during the IETF-111 meeting and the last interim, this email triggers a 2-week call for adoption of draft-selander-lake-traces-01. The draft contains the EDHOC test vectors, previously part of draft-ietf-lake-edhoc. 

We are seeking the working group input on the following points:
- Whether draft-selander-lake-traces should be adopted as a working group item, and if yes:
- Whether this draft should be published as an RFC
- What should be the scope of the document? The current version of the draft covers authentication methods 0 (signature - signature) and 3 (static DH - static DH). Should the draft cover additional methods and / or additional intermediary values? Anything else deemed useful from the implementers point of view?

Please provide your comments by November 1st, 2021.

Mališa and Stephen

---

From: Marco Tiloca <[email-masked]>
Date: Thu, 21 Oct 2021 15:37:42 +0200

Hi all,

I support adoption of this document, that I have personally found useful 
through the implementation/testing process.

I believe that publication as RFC is appropriate too. This would be 
analogous to RFC8448.

The current level of details in the traces looks actually good to me. I 
think additional traces should include cipher suite 2 (both with 
authentication method 0 and 3). This would make the document useful also 
for implementations supporting only cipher suite 2, which is admitted 
for constrained endpoints.

Best,
/Marco

-- 
Marco Tiloca
Ph.D., Senior Researcher

Division: Digital System
Department: Computer Science
Unit: Cybersecurity

RISE Research Institutes of Sweden
https://www.ri.se

Phone: +46 (0)70 60 46 501
Isafjordsgatan 22 / Kistagången 16
SE-164 40 Kista (Sweden)

---

From: "Hristozov, Stefan" <[email-masked]>
Date: Mon, 25 Oct 2021 18:31:19 +0000

Hi,

I support the adoption of the document as well, since I found it useful for updating our implementation.

I will suggest adding traces for suites 2 and/or 3, which are of interest for us as well.

Br,
Stefan

On Thu, 2021-10-21 at 15:37 +0200, Marco Tiloca wrote:

Hi all,

analogous to RFC8448.

Best,

/Marco

Dear all,

Mališa and Stephen

--

Stefan Hristozov
Department Hardware Security
Fraunhofer Institute for Applied and Integrated Security AISEC
Lichtenbergstraße 11, 85748 Garching near Munich, Germany
Tel. +49 89 32299 86 157
[email-masked]<mailto:[email-masked]>
https://www.aisec.fraunhofer.de/

---

From: John Mattsson <[email-masked]>
Date: Mon, 25 Oct 2021 19:04:31 +0000

Hi,

- I support adoption.

- I think it should be published as an RFC

- Regarding the scope. I think the scope should be narrow. My view is that the goal with the traces document is to increase understanding compared to the undocumented test vectors in https://github.com/lake-wg/edhoc/tree/master/test-vectors-11
Any additional test vectors can be provided in an undocumented JSON format. I agree with earlier comments that an ECDSA cipher suite should definitly be included. I think the ECDSA cipher suite should replace one of the current EdDSA traces. I don't really see that a third trace increases understanding very much, but I do not have a strong opinion. My suggestion would be two traces
     1. method 3 (static DH - static DH) with cipher suite 0
     2. method 0 (signature - signature) with cipher suite 2 or 3

Cheers,
John

From: Lake <[email-masked]> on behalf of Marco Tiloca <marco.tiloca=[email-masked]>
Date: Thursday, 21 October 2021 at 15:38
To: Mališa Vučinić <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [Lake] Call for adoption of draft-selander-lake-traces
Hi all,

Best,
/Marco

--
Marco Tiloca
Ph.D., Senior Researcher

Division: Digital System

RISE Research Institutes of Sweden
https://protect2.fireeye.com/v1/url?k=3da572a9-623e4b95-3da53232-86b1886cfa64-0ab0da9f4cdc4e12&q=1&e=bb32162f-d970-495a-8ea5-4133e01804dc&u=https%3A%2F%2Fwww.ri.se%2F

---

From: Sean Turner <[email-masked]>
Date: Fri, 29 Oct 2021 21:44:57 -0400

Hi! I definitely support adoption.

As far as RFC sure, really on two conditions: 1) multiple implementations very that the example are “right”, and 2) it is informational; see S/MIME Examples (https://datatracker.ietf.org/doc/rfc4134/).

I will defer on scope, but whatever examples you pick make sure they will stand up to the test of time because examples often end up haunting you 10 years down the road ;)

spt

> On Oct 18, 2021, at 06:52, Mališa Vučinić <[email-masked]> wrote:
> 
> Dear all,
> 
> Lake mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lake