Subject: [Last-Call] Yangdoctors last call review of draft-ietf-netmod-factory-default-07

From: Carl Moberg via Datatracker <[email-masked]>
Date: Wed, 27 Nov 2019 06:35:24 -0800

Reviewer: Carl Moberg
Review result: Ready with Nits

This is my YANG doctors review of the ietf-factory-default.yang module as
part of draft-ietf-netmod-factory-default-07.

The module cleanly passes validation using the YANG validator site and
I have successfully loaded it into one NETCONF server implementation.

This module is ready with a cosmetic nit and a suggestion.

I suggest fixing the following textual nit:

OLD
       configuration datastores (i.e.,<running> , <startup><candidate>) to
       their factory default content.";

NEW:
       configuration datastores (i.e. <running>, <startup>, and
       <candidate>) to their factory default content.";

I suggest adding a revision-date to the filename in the <CODE BEGINS> block.

OLD:
 <CODE BEGINS> file "ietf-factory-default.yang"

 NEW:
 <CODE BEGINS> file "[email-masked]"

 (Obviously replacing the date with the release date of the module)

---

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 28 Nov 2019 13:06:01 -0800

>        <candidate>) to their factory default content.";

FWIW, the RFC style guide wants both comma and space after "i.e." (and
comma before it, as well, when not enclosed in a parenthetical).

-Ben