Subject: Re: [Last-Call] Tsvart last call review of draft-ietf-ospf-ospfv2-hbit-10

From: Kyle Rose <[email-masked]>
Date: Mon, 9 Dec 2019 11:27:43 -0500

Draft 11 satisfies all points I made in my review. Thanks.

Kyle

On Thu, Oct 31, 2019 at 6:50 PM Padma Pillay-Esnault <[email-masked]>
wrote:

> Hi Kyle
>
> Thank you for your review
>
> Please see below PPE
>
> On Thu, Oct 31, 2019 at 2:47 PM Kyle Rose via Datatracker <
> [email-masked]> wrote:
>
>> Reviewer: Kyle Rose
>> Review result: Ready with Nits
>>
>> This document has been reviewed as part of the transport area review
>> team's
>> ongoing effort to review key IETF documents. These comments were written
>> primarily for the transport area directors, but are copied to the
>> document's
>> authors and WG to allow them to address any issues raised and also to the
>> IETF
>> discussion list for information.
>>
>> When done at the time of IETF Last Call, the authors should consider this
>> review as part of the last-call comments they receive. Please always CC
>> [email-masked] if you reply to or forward this review.
>>
>> This document is basically ready. I have the following comments:
>>
>> * LSA should be defined where it is first used.
>>
>
> PPE - Fixed for next version of draft
>
> * I'm curious what happens if a router sets the H-bit when it is on the
>> only
>> feasible transit path.
>>
>
> PPE - The router with the H-bit set will not be "on the only feasible
> transit path" to other destinations.  The H-bit functionality will exclude
> the host router from the path calculation in the SPF.
>
>
>> * In the security considerations, the document states:
>>
>> q( The feature, however does introduce the flooding of a capability
>>    information that allows discovery and verification that all routers
>>    in an area are capable before turning on the feature )
>>
>> I'm not sure "flooding" is the right term here, as the communication
>> comprising the OSPF control plane is not new: only a single bit has a
>> new meaning. This statement is also worded awkwardly, but without
>> a clearer understanding of what is meant, I don't know that I can
>> suggest alternative wording.
>>
>>
> PPE: OSPF will flood the LSA containing the capability... Perhaps
> "advertising" instead of flooding.
> See below:
>
> OLD:
> The feature, however does introduce the flooding of a capability
>    information that allows discovery and verification that all routers
>    in an area are capable before turning on the feature.
>
> SUGGESTED NEW:
> The feature introduces the advertising of a host router capability
> information to all OSPFv2 routers
>    in an area. This information can be leveraged for discovery and
> verification that all routers in the
> area support the capability before the feature is turned on.
>
> Please let me know if this addresses your comment.
>
> Thanks
> Padma
>

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Mon, 9 Dec 2019 11:35:10 -0800

Thanks Kyle for your review.

Padma

Sent from my iPhone

> On Dec 9, 2019, at 08:27, Kyle Rose <[email-masked]> wrote:
> 
> 
>> On Thu, Oct 31, 2019 at 6:50 PM Padma Pillay-Esnault <[email-masked]> wrote:
>> Hi Kyle
>> 
>>> On Thu, Oct 31, 2019 at 2:47 PM Kyle Rose via Datatracker <[email-masked]> wrote:
>>> Reviewer: Kyle Rose
>>> This document has been reviewed as part of the transport area review team's
>>> primarily for the transport area directors, but are copied to the document's
>>> authors and WG to allow them to address any issues raised and also to the IETF
>>> * I'm curious what happens if a router sets the H-bit when it is on the only
>>> feasible transit path.
>> 
>> PPE - The router with the H-bit set will not be "on the only feasible transit path" to other destinations.  The H-bit functionality will exclude the host router from the path calculation in the SPF.
>>  
>> PPE: OSPF will flood the LSA containing the capability... Perhaps "advertising" instead of flooding. 
>> See below:
>> 
>> OLD: 
>> The feature introduces the advertising of a host router capability information to all OSPFv2 routers
>>    in an area. This information can be leveraged for discovery and verification that all routers in the