Subject: Re: [Last-Call] Tsvart last call review of draft-ietf-dprive-rfc7626-bis-03

From: Sara Dickinson <[email-masked]>
Date: Wed, 18 Dec 2019 13:43:14 +0000

> On 28 Nov 2019, at 20:33, Brian Trammell via Datatracker <[email-masked]> wrote:
> 
> Reviewer: Brian Trammell
> Review result: Ready with Nits

Brian, 

Thanks for the review!

> 
> This document has been reviewed as part of the transport area review team's
> ongoing effort to review key IETF documents. These comments were written
> primarily for the transport area directors, but are copied to the document's
> authors and WG to allow them to address any issues raised and also to the IETF
> discussion list for information.
> 
> When done at the time of IETF Last Call, the authors should consider this
> review as part of the last-call comments they receive. Please always CC
> [email-masked] if you reply to or forward this review.
> 
> This draft is ready for publication from a transport point of view. I have
> minor nits / suggestions:
> 
> (1) References to QUIC imply that work is underway to build DNS over QUIC;
> while this has been suggested, there is to my knowledge no ongoing
> specification or implementation of such an application. There should be some
> additional text pointing out this context where QUIC is first mentioned.

A specification for DNS-over-QUIC was actually started in April 2017 and is still active:
https://datatracker.ietf.org/doc/draft-huitema-quic-dnsoquic/
but is, of course, somewhat held up because version 1.0 of QUIC will only support HTTP. I thought there was a reference to this but you are correct - it isn’t in there! I will add it in the introduction immediately after the referance to I-D.ietf-quic-transport.

FYI - I am aware of work on a prototype implementation on and off since then and there was experimental work to implement it in a DNS benchmarking tool at the IETF 105 hackathon: https://github.com/DNS-OARC/flamethrower/tree/dns-over-quic

> 
> (2) The references have some typos (e.g. [pitfalls-of-dns-encrption]) and are
> occasionally oddly named (e.g. [firefox] for a Mozilla announcement about DoH);
> suggest reviewing these.

Suggest (if these references remain):

[chrome] -> [chrome-doh-experiment] (article is titled “"Experimenting with same-provider DNS-over-HTTPS upgrade”)
[firefox] -> [mozilla-doh-as-default]  (article is titled “What's next in making Encrypted DNS-over- HTTPS the Default”
[pitfalls-of-dns-encrption] -> [pitfalls-of-dns-encryption]

The rest look OK (I think) or have the same names as in the original RFC....

Sara.

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Wed, 18 Dec 2019 17:57:17 +0100

hi Sara, all,

> On 18 Dec 2019, at 14:43, Sara Dickinson <[email-masked]> wrote:
> 
>> 

Great.

> [pitfalls-of-dns-encrption] -> [pitfalls-of-dns-encryption]

These are all good, thanks!

Cheers,

Brian

> _______________________________________________
> Tsv-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tsv-art