Subject: Re: [Last-Call] [MBONED] Genart last call review of draft-ietf-mboned-deprecate-interdomain-asm-05

From: Tim Chown <[email-masked]>
Date: Fri, 3 Jan 2020 16:32:11 +0000

On 29 Dec 2019, at 20:23, Manfredi (US), Albert E <[email-masked]<mailto:[email-masked]>> wrote:

From: MBONED <[email-masked]<mailto:[email-masked]>> On Behalf Of James A. (Jim) Stevens

Some background to Tim Chown's comment about "pushback in earlier discussions"
Section 4.4 is on Developing application guidance: SSM, ASM, service discovery
Section 4.5 is on Preferring SSM applications intradomain

We have intradomain applications with up to hundreds of nodes doing many to many multicast IP packet exchanges where the nodes can dynamically come and go.  (Although most networks only contain 20 to 100 nodes, I believe the largest such network had >250 nodes doing many to many multicast.

SSM is not feasible (and neither is ASM with PIM-SM due to the high overhead and dynamics as nodes come and go).  So our applications use ASM with BIDIR-PIM.

We want to ensure that operating system and router developers continue to support ASM and BIDIR-PIM over the long term for our intradomain applications. I.e., we do NOT want to deprecate intradomain use of ASM.

Thus, we pushed back against the recommendation in 4.4 to develop new applications using SSM and in 4.5 to prefer SSM for future intradomain applications.  In response, the draft-ietf-mboned-deprecate-interdomain-asm document was updated to put in the phrase "if feasible" in sections 4.4. and 4.5 so that SSM is not recommended if not feasible.

Note that we do not object to deprecating interdomain use of ASM.

I would like to emphatically post a +1 here. On all points, except perhaps the use of PIM (for security reasons primarily).

As long as we're talking interdomain, no objections. But intradomain, the fact that the source of a given multicast might vary, without mandating that each destination join all possible source-specific multicasts individually, is a "feature" that we exploit.

The model is much the same as telephone conference calls. You send out the conference call number to all possible participants, but then you want to avoid the extra complication of requiring each one dialing in having to dial the number of each participant. That would be quite laborious and unnecessary.

Just to confirm this is indeed the thrust of the draft, as per the Abstract:

"This document recommends deprecation of the use of Any-Source

   Multicast (ASM) for interdomain multicast.  It recommends the use of
   Source-Specific Multicast (SSM) for interdomain multicast
   applications and that hosts and routers in these deployments fully
   support SSM.  The recommendations in this document do not preclude
   the continued use of ASM within a single organisation or domain and
   are especially easy to adopt in existing intradomain ASM/PIM-SM
   deployments.“

And in 4.5:

"4.5<https://tools.ietf.org/html/draft-ietf-mboned-deprecate-interdomain-asm-05#section-4.5>.  Preferring SSM applications intradomain

   If feasible, it is recommended for applications to use SSM even if
   they are initially only meant to be used in intradomain environments
   supporting ASM.  Because PIM-SSM is a subset of PIM-SM, existing
   intradomain PIM-SM networks are automatically compatible with SSM
   applications.  Thus, SSM applications can operate alongside existing
   ASM applications.  SSM's benefits of simplified address management
   and significantly reduced operational complexity apply equally to
   intradomain use.

   However, for some applications it may be prohibitively difficult to
   add support for source discovery, so intradomain ASM may still be
   appropriate."

This wording was the result of comments received from those using ASM within their own networks.

Tim

---

From: "Manfredi (US), Albert E" <[email-masked]>
Date: Fri, 3 Jan 2020 19:48:36 +0000

From: Tim Chown <[email-masked]> 

"https://tools.ietf.org/html/draft-ietf-mboned-deprecate-interdomain-asm-05#section-4.5.  Preferring SSM applications intradomain

> This wording was the result of comments received from those using ASM within their own networks.

Indeed.

Just to be clear about why some of us might be sensitive to the wording. RFCs get in the hands of many people involved with network development, including those in a purely management role. So, even if, in principle, intradomain, network designers can twist and stretch RFCs to suit their needs, as long as they break nothing, in practice, network designers are not always able to benefit from this unwritten rule. "It says right here that SSM is preferred," the manager will complain, not necessarily getting all the fallout.

Happy New Year mboned!

Bert