Subject: Re: [Last-Call] Opsdir last call review of draft-ietf-6lo-ap-nd-12

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 6 Jan 2020 10:39:28 +0000

Hello Al

Many  thanks for your review!

Please see below:

> This is the OPS-DIR review of -12
> 1)  "This specification introduces a new token called a cryptographic
>    identifier (Crypto-ID) that is used to prove indirectly the ownership
>    of an address that is being registered by means of [RFC8505]."
> during Neighbor Discovery in
>   "...a 6LoWPAN Low Power Lossy
>    Network (LLN), typically a stub network connected to a larger IP
>    network via a Border Router called a 6LBR per [RFC6775]."

Unsure what you expectation is here?
I removed the redefinition of LLN in the latter piece.

> 2) This seems like a worthwhile update to RFC8505.
>      The section describing the Update aspect is helpful, but ...
>      Nit: there should also a sentence in the Abstract indicating the Update
> status.
>      The scope of operation is very limited, hence no operational issues detected.

The first sentence of the abstract says "
This document specifies an extension to 6LoWPAN Neighbor Discovery (ND) protocol defined in RFC6775 and updated in RFC8505.
"
Should we reword ? Maybe "
This document updates the 6LoWPAN Neighbor Discovery (ND) protocol defined in RFC 6775 and RFC 8505.
"
?

> 3) The SEC-DIR review will likely be more interesting: this reviewer's experience
>     doesn't foster review of LLN in any depth.

It is happening right now  : )

> 4) The Doc Shepherd's form indicates that the last 4 versions benefited from
> review by
>     knowledgeable persons in the Security Area.

Yes, that helped a lot make the SEC DIR review smoother.

Many thanks again

Pascal

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Mon, 6 Jan 2020 13:44:50 +0000

Hi Pascal,

Brief responses below, [acm] tag,

thanks for your reply,
Al

> -----Original Message-----
> From: Pascal Thubert (pthubert) [mailto:[email-masked]]
> Sent: Monday, January 6, 2020 5:39 AM
> To: MORTON, ALFRED C (AL) <[email-masked]>; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: Opsdir last call review of draft-ietf-6lo-ap-nd-12
> 
> Hello Al
> 
[acm] 
No real expectation, I was adding background to the review...
> This document specifies an extension to 6LoWPAN Neighbor Discovery (ND)
> protocol defined in RFC6775 and updated in RFC8505.
> "
[acm] 
Yes, I think that works, it must be clear that you are Updating 8505 
in this memo. There's a requirement to do this when "Updating" (somewhere).

> Yes, that helped a lot make the SEC DIR review smoother.
[acm] 
You're very welcome

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 6 Jan 2020 15:19:43 +0000

All good then!

Again, many thanks.

Pascal

> From: MORTON, ALFRED C (AL) <[email-masked]>
> Sent: lundi 6 janvier 2020 14:45
> To: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
> > >      Nit: there should also a sentence in the Abstract indicating
> > > the
> > Update
> > > status.
> > >      The scope of operation is very limited, hence no operational
> > > issues
> > detected.
> >
> > This document specifies an extension to 6LoWPAN Neighbor Discovery
> > (ND) protocol defined in RFC6775 and updated in RFC8505.
> > "
> Yes, I think that works, it must be clear that you are Updating 8505 in this
> memo. There's a requirement to do this when "Updating" (somewhere).
> 
> >
> >
> > > 3) The SEC-DIR review will likely be more interesting: this
> > > reviewer's
> > experience
> > > 4) The Doc Shepherd's form indicates that the last 4 versions
> > > benefited
> > from
> > > review by