Subject: Re: [Last-Call] [secdir] Secdir last call review of draft-ietf-pim-msdp-yang-12

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 2 Feb 2020 08:08:16 -0800

Hi Vincent,

Thanks for doing the review!

On Wed, Jan 29, 2020 at 12:18:11AM -0800, Vincent Roca via Datatracker wrote:
> Reviewer: Vincent Roca
> Review result: Has Nits
> 
> Hello,
> 
> I have reviewed this document as part of the security directorate’s ongoing
> effort to review all IETF documents being processed by the IESG. These
> comments were written primarily for the benefit of the security area
> directors.  Document editors and WG chairs should treat these comments just
> like any other last call comments.
> 
> Summary: Ready with nits
> 
> The security considerations section is globally well writen and addresses
> important topics. I don't have major comments.
> 
> Details:
> - it is said that "(i.e., config true, which is the default)".
>   I've searched in the YANG model and only found "config false" entries which
>   seems to contradict what is said in section 5.

I think the idea is that you never actually say "config true", and rather
just omit any 'config' statement to get the default (writeable) behavior.
So I think there are still writeable leaves in this module.

-Ben

> - Section 2.1 says: "This model can be used to configure and manage MSDP
> protocols." (with a final "s") which suggests there could be several MSDP
> protocols. I think it's a mistake.
> 
> Cheers,    Vincent
> 
> _______________________________________________
> secdir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secdir
> wiki: http://tools.ietf.org/area/sec/trac/wiki/SecDirReview

---

From: <[email-masked]>
Date: Mon, 3 Feb 2020 08:33:55 +0800 (CST)

Hi Ben, Vincent,

Thank you very much for your review!

Yes. This sentence means that all the configurable leaves in the model.

Should I delete this sentence to avoid misunderstanding?

Best regards,

Sandy

原始邮件

发件人：BenjaminKaduk <[email-masked]>
收件人：Vincent Roca <[email-masked]>;
抄送人：[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2020年02月03日 00:08
主 题 ：Re: [pim] [secdir] Secdir last call review ofdraft-ietf-pim-msdp-yang-12

Hi Vincent,

-Ben

_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim

---

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 2 Feb 2020 20:24:22 -0800

Hi Sandy,

No, you should not delete the sentence. We should keep the standard
template as-is.

-Ben