Subject: Re: [Last-Call] Last Call: <draft-kuehlewind-system-ports-04.txt> (Reassignment of System Ports to the IESG) to Proposed Standard

From: S Moonesamy <[email-masked]>
Date: Thu, 27 Feb 2020 13:15:28 -0800

Hello,
At 07:44 AM 10-02-2020, The IESG wrote:
>The IESG has received a request from an individual submitter to consider the
>following document: - 'Reassignment of System Ports to the IESG'
>   <draft-kuehlewind-system-ports-04.txt> as Proposed Standard
>
>The IESG plans to make a decision in the next few weeks, and solicits final
>comments on this action. Please send substantive comments to the
>[email-masked] mailing lists by 2020-03-09. Exceptionally, comments may

Is there an explanation why this document is an (intended) Proposed Standard?

The procedures for managing the port number registry are defined in 
RFC 6335.  Are the procedures defined in RFC 6335 for 
reassignments/revocations incorrect or unworkable?  What is the 
relationship between this document and RFC 6335?

Why is the IETF Chair being proposed as the point of contact?

Regards,
S. Moonesamy

---

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 28 Feb 2020 15:41:26 +0100

Thanks for you feedback/questions! Please see below.

> On 27. Feb 2020, at 22:15, S Moonesamy <[email-masked]> wrote:
> 
> Hello,

Actually this is a good point. For this document the state is not obvious I think. RFC6335 is BCP which didn’t seem appropriate for this doc but informational seemed to lax as it requests actions on a registry. However, I definitely could be convinced that informational is more appropriate as all actions are covered by RFC6335 procedures and this document is really only meant to provide most transparency to the community about any actions taken and as historical documentation for later times.

> 
> The procedures for managing the port number registry are defined in RFC 6335.  Are the procedures defined in RFC 6335 for reassignments/revocations incorrect or unworkable?  What is the relationship between this document and RFC 6335?

As I said above the draft intends to initiate actions within the procedures defined in RFC6335 and it meant for documentation and transparency purposes only.
> Why is the IETF Chair being proposed as the point of contact?

This is inline with what required in RFC6335 for ports that are assigned by IETF Review, so we adopted the same here.

Mirja

---

From: Joseph Touch <[email-masked]>
Date: Fri, 28 Feb 2020 18:54:50 -0800

> On Feb 28, 2020, at 6:41 AM, Mirja Kuehlewind <[email-masked]> wrote:
> 

This is incorrect as follows:

The process in RFC6335 for assignee ports to the IESG only for IETF document stream assignments, and only as of the date of that RFC.
	- This draft does not limit IESG request for reassignment to only ports associated with those documents.

The process for transfer is outlined in Sec 8.5.
	- There is - to be clear, speaking as an IESG-appointed Expert Reviewer - no operational, technical, or administrative reason provided for transferring ALL the system ports to the IESG.
	- There is such a reason to transfer IETF standards-track assignments - both system and user, but the doc doesn’t limit the requests to those items only (which should be enumerated before proceeding)

Thus RFC 6335 is not being followed by this draft.

Joe