Subject: [Last-Call] Iotdir telechat review of draft-ietf-ecrit-data-only-ea-21

From: Gonzalo Salgueiro via Datatracker <[email-masked]>
Date: Mon, 02 Mar 2020 11:48:51 -0800

Reviewer: Gonzalo Salgueiro
Review result: Ready with Nits

Document: draft-ietf-ecrit-data-only-ea-21
Review result: Ready with Nits
Review type: iotdir - Last Call review
Requested version for review: Current
Review Date: 2020-03-02
Reviewer: Gonzalo Salgueiro

I am the assigned IoT directorate reviewer for <draft-ietf-ecrit-data-only-ea>.
These comments were written primarily for the benefit of the Internet Area
Directors. Document editors and shepherd(s) should treat these comments just
like they would treat comments from any other IETF contributors and resolve
them along with any other Last Call comments that have been received. For more
details on the IoT Directorate, see
https://datatracker.ietf.org/group/iotdir/about/

This document describes (1) how method of including a CAP message in a SIP
transaction by defining it as a block of "additional data" as well as (2)
describes how a SIP MESSAGE transaction can be used to send a non-interactive
call. I have reviewed this document from the IoT perspective and the document
appears to be informative, clear and without obvious technical gaps. There are
just a few the authors might consider addressing.

Nits:
====

S: Abstract

"type of interactions" -> "types of interactions"

S:1

"alert specific" -> "alert-specific"

S:9

"Location specific" -> "Location-specific"

S:9

"Note that none of the security mechanism in this document" -> "Note that none
of the security mechanisms in this document"

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 2 Mar 2020 20:01:27 +0000

Thank you very much Gonzalo,

I will use your review when entering my IESG ballot later today. Having a directorate review really helps the AD job ;-)

Regards

-éric

-----Original Message-----
From: last-call <[email-masked]> on behalf of Gonzalo Salgueiro via Datatracker <[email-masked]>
Reply-To: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Monday, 2 March 2020 at 20:49
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [Last-Call] Iotdir telechat review of draft-ietf-ecrit-data-only-ea-21

    

    Nits:
    ====
    
    S: Abstract

    S:1

    S:9

    S:9

    
    -- 
    last-call mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/last-call

---

From: Brian Rosen <[email-masked]>
Date: Mon, 2 Mar 2020 16:18:59 -0500

Thanks for the review.  I will fix the nits.

You did understand that this is the mechanism by which an IoT device makes an emergency call when the device doesn’t have two way interactive media, right?

Brian

> On Mar 2, 2020, at 2:48 PM, Gonzalo Salgueiro via Datatracker <[email-masked]> wrote:
>

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Mon, 2 Mar 2020 21:51:36 +0000

Hi Brian -

Yes, the scope seemed clear to me. One thing I would qualify is that I interpreted the scope to be slightly broader than a "mechanism by which an IoT device makes an emergency call”. While you explicitly call out sensors (read: constrained devices) I don’t believe you explicitly restrict the mechanism  to those devices. I inferred that would be the typical use case but I more generally took it as *any* device that needs to initiate a request for emergency services where no interactive media channel will be established would use the mechanisms described in this document. I assumed this scope to be appropriate but if you think you need to narrow it further to exclusively constrained devices then perhaps you can add a blurb about that. Hope this helps.

Cheers,

Gonzalo

On Mar 2, 2020, at 4:18 PM, Brian Rosen <[email-masked]<mailto:[email-masked]>> wrote:

Brian

On Mar 2, 2020, at 2:48 PM, Gonzalo Salgueiro via Datatracker <[email-masked]<mailto:[email-masked]>> wrote:

Nits:
====

S: Abstract

S:1

S:9

S:9

--
last-call mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/last-call

---

From: Brian Rosen <[email-masked]>
Date: Mon, 2 Mar 2020 16:52:49 -0500

You interpreted it correctly: any device that doesn’t have two way interactive media.

Brian

> On Mar 2, 2020, at 4:51 PM, Gonzalo Salgueiro (gsalguei) <[email-masked]> wrote:
> 
> Hi Brian - 
> 
>> On Mar 2, 2020, at 4:18 PM, Brian Rosen <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>>> On Mar 2, 2020, at 2:48 PM, Gonzalo Salgueiro via Datatracker <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> https://datatracker.ietf.org/group/iotdir/about/ <https://datatracker.ietf.org/group/iotdir/about/>
>>> 
>> [email-masked] <mailto:[email-masked]>