Subject: Re: [Last-Call] Six months in: evaluation of the last-call mailing list experiment

From: Barry Leiba <[email-masked]>
Date: Thu, 30 Apr 2020 11:15:28 -0400

(I'm replying to this and adding the last-call list, which I forgot to
do when I sent it.  Please reply to *this* message, to keep both lists
included.)

On Thu, Apr 30, 2020 at 11:00 AM Barry Leiba <[email-masked]> wrote:
>
> It's been around six months since we started the <[email-masked]>
> list, and we said that we would evaluate the results after six months.
> To that end, the IESG would like to see comments about how it's been
> working.
>
> Please respond to this thread to comment.  It would be helpful if the
> first line of your comment gave a succinct view of your opinion on the
> following 5-to-1 scale:
>
> 5: Perfect!  Don't even think about going back!
> 4: I really like it and want to keep it.
> 3: Neutral: I don't care either way.
> 2: I don't like it, but I can live with it if we decide to keep it.
> 1: It's terrible!  Please, please go back to the old way!
>
> And, of course, if you have further comments beyond those numbers,
> include those as well.  We want to know what you think.  Comments,
> please, in the next couple of weeks, by 15 May.  Thanks!
>
> Barry, for the IESG

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 30 Apr 2020 15:21:32 +0000

I like it but since I'm not on the last-call list (I prefer the raw unmitigated "stuff" of [email-masked]), not sure my opinion matters much.
Are discussions bifurcated much? I guess also I don't care, the current scheme works okay for me, and isn't that all that matters?

---

From: "Scott O. Bradner" <[email-masked]>
Date: Thu, 30 Apr 2020 11:22:16 -0400

4 (nothing in the IETF can be perfect)

> On Apr 30, 2020, at 11:15 AM, Barry Leiba <[email-masked]> wrote:
>

---

From: Ben Campbell <[email-masked]>
Date: Thu, 30 Apr 2020 10:23:30 -0500

I give it a 4.5.

I see last call comments on a much more timely basis than I did with all the background noise the IETF list. (Note that I saw _this_ message on the Last-Call list first.) I think it makes a lot of sense to separate the effort of getting the day-to-day work of the IETF done from the broad range of discussions _about_ the IETF.

Ben.

> On Apr 30, 2020, at 10:15 AM, Barry Leiba <[email-masked]> wrote:
> 
> -- 
> last-call mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/last-call

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 30 Apr 2020 16:25:23 +0100

(In fact, I unsubscribed from [email-masked])

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 30 Apr 2020 08:33:01 -0700

4, Please keep it. However, I think it could be improved if you also sent
LC *announcements* there.

-Ekr

On Thu, Apr 30, 2020 at 8:30 AM Ben Campbell <[email-masked]> wrote:

> I give it a 4.5.
>
> I see last call comments on a much more timely basis than I did with all
> the background noise the IETF list. (Note that I saw _this_ message on the
> Last-Call list first.) I think it makes a lot of sense to separate the
> effort of getting the day-to-day work of the IETF done from the broad range
> of discussions _about_ the IETF.
>
> Ben.
>

---

From: Barry Leiba <[email-masked]>
Date: Thu, 30 Apr 2020 11:38:18 -0400

> 4, Please keep it. However, I think it could be improved if you also sent LC *announcements* there.

We have talked about CCing the last call announcements to the
last-call list.  I agree: I think we should.

Barry

---

From: Joseph Touch <[email-masked]>
Date: Thu, 30 Apr 2020 08:44:09 -0700

1, for the reasons Barry just showed below. (Thanks, BTW).

A person with one watch always knows what time it is. A person with two is never sure.

Joe

> On Apr 30, 2020, at 8:15 AM, Barry Leiba <[email-masked]> wrote:
>

---

From: "Pete Resnick" <[email-masked]>
Date: Thu, 30 Apr 2020 10:43:56 -0500

4 is about right, and +1 to EKR's idea.

pr

On 30 Apr 2020, at 10:33, Eric Rescorla wrote:

>>> On Thu, Apr 30, 2020 at 11:00 AM Barry Leiba 
>>> <[email-masked]>
>> wrote:
>>>>

-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

---

From: John C Klensin <[email-masked]>
Date: Thu, 30 Apr 2020 11:52:30 -0400

2.   Strongly agree with Scott Kitterman's comments about
looking at subscription (and posting) breakdowns and statistics
as being more useful than polling and about the risk of making
it more difficult for newcomers to figure out what is going on.
I'd add that anyone who does significant automated local
filtering or classification could do a 90% job by looking at
"[Last Call]" in subject lines (as I have done for years) -- no
separate list needed.

Possibly the effort to create separate lists could be better
spent pushing back on interminable discussions on the IETF list
about, e.g., subjects that are not IETF problems.

I expect I'm in  the rough here, but still...

best,
   john

--On Thursday, April 30, 2020 11:15 -0400 Barry Leiba
<[email-masked]> wrote:

> (I'm replying to this and adding the last-call list, which I
> forgot to do when I sent it.  Please reply to *this* message,
> to keep both lists included.)
> 
> <[email-masked]> wrote:
>> 
>> It's been around six months since we started the
>> <[email-masked]> list, and we said that we would evaluate
>> the results after six months. To that end, the IESG would
>> like to see comments about how it's been working.
>> 
>> Please respond to this thread to comment.  It would be
>> helpful if the first line of your comment gave a succinct
>> view of your opinion on the following 5-to-1 scale:
>> 
>> 2: I don't like it, but I can live with it if we decide to
>> keep it. 1: It's terrible!  Please, please go back to the old
>> way!

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 30 Apr 2020 17:56:59 +0200

5: Perfect, I Don't even think about going back.

More easy to work, trace and follow. However, it is good to have both as
well, so one highly formal Last-Call-List, and the other IETF-list can mix.

Best Regards
AB

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 30 Apr 2020 12:15:38 -0400

+1 (both for the rating and the CCing).

---

From: "tom petch" <[email-masked]>
Date: Thu, 30 Apr 2020 18:29:25 +0100

2

It would be higher if the Last Call announcements appeared on it (as I proposed ages ago:-)

There is also a problem with timing that some reviews take place before a formal Last Call and those reviews get posted to Last Call - there should be a gate stopping those reviews if no Last Call has been issued. I am unclear if the various directorate etc reviews belong here or not.

---
New Outlook Express and Windows Live Mail replacement - get it here:
https://www.oeclassic.com/

Tom Petch

----- Original Message -----
From: Barry Leiba [email-masked]
Sent: 30/04/2020 16:38:18
______________________________________________________________________________

> , Please keep it. However, I think it could be improved if you also sent LC *announcements* there.

Barry

---

From: Ned Freed <[email-masked]>
Date: Thu, 30 Apr 2020 09:29:31 -0700 (PDT)

4, and +1 to cc'ing last calls.

Having to deal with Slack has not enamoured me to other people deciding how to
separate things by topic, but there's real utility in this separation - more
than I expected.

				Ned

---

From: Patrick McManus <[email-masked]>
Date: Thu, 30 Apr 2020 12:47:58 -0400

5.

I utilize last-call and am no longer subscribed to ietf@ - the signal is
much better. Indeed its so obviously better I wouldn't go back if that were
the only choice.

---

From: Ben Campbell <[email-masked]>
Date: Thu, 30 Apr 2020 12:33:54 -0500

+1 to Eric’s point about the announcements.

> On Apr 30, 2020, at 10:33 AM, Eric Rescorla <[email-masked]> wrote:
> 
> On Thu, Apr 30, 2020 at 8:30 AM Ben Campbell <[email-masked] <mailto:[email-masked]>> wrote:
> I give it a 4.5.
> 
> > On Apr 30, 2020, at 10:15 AM, Barry Leiba <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > On Thu, Apr 30, 2020 at 11:00 AM Barry Leiba <[email-masked] <mailto:[email-masked]>> wrote:
> >> 
> >> It's been around six months since we started the <[email-masked] <mailto:[email-masked]>>
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/last-call <https://www.ietf.org/mailman/listinfo/last-call>
>

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 30 Apr 2020 13:39:56 -0400

3

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

---

From: "Job Snijders" <[email-masked]>
Date: Thu, 30 Apr 2020 20:00:51 +0200

Dear all,

> > please, in the next couple of weeks, by 15 May.  Thanks!

4

It feels like another layer of the [email-masked] onion has been peeled off. As our understanding of what the IETF is evolves, it seems we've now recognised there are conversations on different planes, and it also seems there is no apparent downside to  separating some off to last-call@. I suspect adoption of last-call@ will continue to grow a bit if the change is made permanent.

It is likely at times discussions still will froth over from one list to another, but if this new list-setup helps us *most of the time*, I'd say that is a win. :-)

Kind regards,

Job

---

From: Dave Lawrence <[email-masked]>
Date: Thu, 30 Apr 2020 14:43:38 -0400

4, but only because I'm ridiculously pedantic about "perfect".  

I also usually decline to participate in those business surveys that
say, "Anything less than 10 is failure!", with 10 meaning, "Greatly
exceeded expectations."  I asked you to change my oil.  You changed my
oil.  You have exactly met my expectations and I'm satisfied.  Can't
we please just leave it at that?

Anyway, right, please don't take last-call away from us.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 1 May 2020 08:48:44 +1200

> 4, Please keep it. However, I think it could be improved if you also sent LC *announcements* there.

I hope you mean to Cc: them there. The main announcement should definitely be sent to ietf-announce, the one list that every IETF participant needs to be subscribed to. This is a specific requirement in RFC2026 (https://tools.ietf.org/html/rfc2026#page-19).

   Brian

---

From: Richard Barnes <[email-masked]>
Date: Thu, 30 Apr 2020 17:17:33 -0400

My thoughts exactly.

On Thu, Apr 30, 2020 at 11:39 AM Eric Rescorla <[email-masked]> wrote:

>> > last-call@ietf..org <[email-masked]>

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 30 Apr 2020 14:29:43 -0700

On Thu, Apr 30, 2020 at 1:48 PM Brian E Carpenter <
[email-masked]> wrote:

> I hope you mean to Cc: them there. The main announcement should definitely
> be sent to ietf-announce, the one list that every IETF participant needs to
> be subscribed to. This is a specific requirement in RFC2026 (
> https://tools.ietf.org/html/rfc2026#page-19).
>

I definitely think they should be sent to both places. I take no position
on how it's done technically

-Ekr

---

From: Barry Leiba <[email-masked]>
Date: Thu, 30 Apr 2020 17:40:04 -0400

> I hope you mean to Cc: them there.

Of course; if we do that, it will be with CC.

Barry

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 1 May 2020 08:59:17 +1000

Unsurprisingly, I like it. Based on the criteria you give, I'd say 4; it's not perfect (others have already suggested interesting improvements), but it's substantially better than what was before, and we shouldn't go back.

Cheers,

> On 1 May 2020, at 1:15 am, Barry Leiba <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Rob Sayre <[email-masked]>
Date: Thu, 30 Apr 2020 16:22:02 -0700

> 4: I really like it and want to keep it.

4 or 5. Only saw this poll by chance.

thanks,
Rob

---

From: Loa Andersson <[email-masked]>
Date: Fri, 1 May 2020 11:08:10 +0800

Barry, IESG,

I'm neutral, either way works for me.

/Loa

-- 

My mail server it under a DOS attack, we are working to fix it but it
may take some time.

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: "Martin Thomson" <[email-masked]>
Date: Fri, 01 May 2020 14:56:51 +1000

On Fri, May 1, 2020, at 01:15, Barry Leiba wrote: ...
4: I can't see how this could be anything but an improvement.