Subject: [Last-Call] Genart last call review of draft-ietf-detnet-ip-over-mpls-05

From: Tim Evens via Datatracker <[email-masked]>
Date: Mon, 20 Apr 2020 15:19:03 -0700

Reviewer: Tim Evens
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-detnet-ip-over-mpls-??
Reviewer: Tim Evens
Review Date: 2020-04-20
IETF LC End Date: 2020-04-23
IESG Telechat date: Not scheduled for a telechat

Summary:

Major issues:

Minor issues:

Nits/editorial comments:

Some of the references refer to older revisions.  

Abbreviations:
* T-PE is referenced several times but not defined.
* d-CW is referenced in Figure 3 but not defined. 
* S-Label is referenced several times but not defined.

Figure 1 and 2 have the same label.

In Section 4.2:

* There is reference to section 5.1.1 and 5.1.2, but those sections 
do not exist in this draft.  Can you clarify which draft/RFC these
sections are referring to? 

* "Per [I-D.ietf-detnet-mpls], the DetNet MPLS data plane uses a single
   S-Label to support a single app flow.  Section 5.1.  DetNet IP Flow
   Identification Procedures ..."  

   Why is Section 5.1 referenced like this?

* "DetNet IP Flow Identification Procedures in [I-D.ietf-detnet-ip] states
   that a single DetNet flow is identified based on IP, and next level
   protocol, header information.  Section 4.4.  Aggregation..."  
   
   It would be more clear to specifically refer to the draft/rfc and section.

---

From: Balázs Varga A <[email-masked]>
Date: Mon, 27 Apr 2020 14:22:19 +0000

Hi Tim,

Thanks for the review. Your comments will be incorporated in the next version.

Feedbacks are inline below marked with <BV>.

Many thanks

Bala'zs

-----Original Message-----
From: Tim Evens via Datatracker <[email-masked]>
Sent: Tuesday, April 21, 2020 12:19 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Genart last call review of draft-ietf-detnet-ip-over-mpls-05

Reviewer: Tim Evens

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

Reviewer: Tim Evens

Review Date: 2020-04-20

Summary:

Major issues:

Minor issues:

Nits/editorial comments:

Abbreviations:

<BV> Right, they will be added to abbreviation section.

<BV> Right, first shows the architecture the second the location of DetNet functions.

I will update the titles.

In Section 4.2:

* There is reference to section 5.1.1 and 5.1.2, but those sections do not exist in this draft.  Can you clarify which draft/RFC these sections are referring to?

<BV> Right, they are referring to "https://datatracker.ietf.org/doc/draft-ietf-detnet-ip/". Reference is at the end of the sentence.

  "   ...   IP" and "NProto" indicate the fields described in

   Section 5.1.1.  IP Header Information and Section 5.1.2.  Other

   Protocol Header Information in [I-D.ietf-detnet-ip], respectively.

<BV> Again, this is referring to "https://datatracker.ietf.org/doc/draft-ietf-detnet-ip/".

<BV> Again, this is referring to "https://datatracker.ietf.org/doc/draft-ietf-detnet-ip/".

---

From: "Tim Evens (tievens)" <[email-masked]>
Date: Mon, 27 Apr 2020 23:48:15 +0000

Hi Bala'zs, 

For the most part, great.   See comments inline marked [tievens]...

On 4/27/20, 7:22 AM, "Balázs Varga A" <mailto:[email-masked]> wrote:

Hi Tim,
 
-----Original Message-----
 
Reviewer: Tim Evens
 
... 

In Section 4.2:

[tievens] The reference is assumed instead of being direct, such as "as defined in Section 5.1.1 of [<draft>]"

[tievens] the callout here is that this type of reference is on the side of being terse, not succinct and clear as to which document this section is belongs. Would it not be more succinct and clear as:

  "Per Section 5.1 of [I-D.ietf-detnet-mpls], the DetNet MPLS data plane uses a single
     S-Label to support a single app flow. DetNet IP Flow
     Identification Procedures in Section 4.4 of [I-D.ietf-detnet-ip] states that a
     single DetNet flow is identified based on IP, and next level
     protocol, header information."
?

 
[tievens] IMO, this would benefit from being more clear as stated above.  It doesn't add much verbosity to add "<section> of [<draft/rfc>].

---

From: Balázs Varga A <[email-masked]>
Date: Tue, 28 Apr 2020 09:32:56 +0000

Hi Tim,
Thanks for the explicit suggestions, I agree that makes text clearer.
I will update the draft accordingly in the suggested format.
Cheers
Bala'zs

-----Original Message-----
From: Tim Evens (tievens) <[email-masked]> 
Sent: Tuesday, April 28, 2020 1:48 AM
To: Balázs Varga A <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Genart last call review of draft-ietf-detnet-ip-over-mpls-05

Hi Bala'zs, 

Hi Tim,
 
-----Original Message-----
 
Reviewer: Tim Evens
 
... 

In Section 4.2:

---

From: "Tim Evens (tievens)" <[email-masked]>
Date: Tue, 28 Apr 2020 21:43:15 +0000

Thanks. 

On 4/28/20, 2:33 AM, "Balázs Varga A" <[email-masked]> wrote:

    Hi Tim,

    -----Original Message-----
    From: Tim Evens (tievens) <[email-masked]> 
    Sent: Tuesday, April 28, 2020 1:48 AM
    To: Balázs Varga A <[email-masked]>; [email-masked]
    Cc: [email-masked]; [email-masked]; [email-masked]
    Subject: Re: Genart last call review of draft-ietf-detnet-ip-over-mpls-05

    Hi Bala'zs, 

    Hi Tim,

    -----Original Message-----

    Reviewer: Tim Evens

    ... 

    In Section 4.2: