Subject: Re: [Last-Call] Yangdoctors last call review of draft-ietf-opsawg-tacacs-yang-03

From: "Wubo (lana)" <[email-masked]>
Date: Thu, 7 May 2020 08:58:45 +0000

Hi Lada,

Many thanks for the suggestion. Understood, will remove the "case".

Thanks,
Bo

-----邮件原件-----
发件人: Ladislav Lhotka [mailto:[email-masked]] 
发送时间: 2020年5月7日 14:56
收件人: Wubo (lana) <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]
主题: Re: Yangdoctors last call review of draft-ietf-opsawg-tacacs-yang-03

"Wubo (lana)" <[email-masked]> writes:
>
> - The "case" statements in ietf-system-tacacsplus:tacacsplus/source-type are unnecessary because each contains only one leaf of the same name; I suggest to remove them.
> [Bo] I need to wait for the further guidance from WG. The "choice case" is added based on the email discussion of the WG, which provides some flexibility in specifying the IP address for server communication. Some vendors prefer IP addresses, and some vendors derive IP addresses through interfaces.

I am not suggesting to remove this choice, this is of course not YANG Doctor's business. My comment is related exclusively to YANG syntax: if you have a "case" statement containing only one data node, then the "case" statement can be omitted, see sec. 7.9.2 in RFC 7950. Such a shorthand is IMO preferable (less clutter), unless you want to leave the possibility of augmenting the case node later - I don't think though it is an option here.

Thanks, Lada

-- 
Ladislav Lhotka 
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: "Wubo (lana)" <[email-masked]>
Date: Wed, 13 May 2020 06:10:34 +0000

Hi John,

Currently, the accounting and authorization methods are not defined in System model. Therefore, although Tacacs+ defines accounting and authorization type, there is no way to use it. 

Regards,
Bo

-----邮件原件-----
发件人: john heasley [mailto:[email-masked]] 
发送时间: 2020年5月11日 13:42
收件人: Wubo (lana) <[email-masked]>
抄送: john heasley <[email-masked]>; Ladislav Lhotka <[email-masked]>; tom petch <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
主题: Re: [Last-Call] Yangdoctors last call review of draft-ietf-opsawg-tacacs-yang-03

Fri, May 08, 2020 at 09:45:51AM +0000, Wubo (lana):
> I'll have to look at the model again; i do not recall if the model allows for particular accounting types w/o augmentation.
> 
> [Bo]  The accounting type you mentioned, I understand, is that the System model needs to be augmented. Currently, the System model only defines authentication.

Hey.  System model has no accounting that I see.  what am i missing; where are the accounting types defined?

> About the model, do you think the "all" bit is still necessary?

I am not advocating for nor against; only trying to explain how 'accounting'
type might be used, which seemed to be misunderstood.
[Bo] OK