Subject: [Last-Call] Genart last call review of draft-ietf-capport-api-07

From: Brian Carpenter via Datatracker <[email-masked]>
Date: Sun, 03 May 2020 21:29:55 -0700

Reviewer: Brian Carpenter
Review result: Ready with Nits

https://www.ietf.org/id/draft-ietf-capport-api-07.html

Gen-ART Last Call review of draft-ietf-capport-api-07

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-capport-api-07.html
Reviewer: Brian Carpenter
Review Date: 2020-05-04
IETF LC End Date: 2020-05-11
IESG Telechat date:  

Summary: Ready (almost...)
--------

Minor Issue:
------------

>      If the client is captive (i.e. captive=true),
>      it can still be allowed enough access for it to perform server
>      authentication Section 4.1.

What does "can" mean? MAY or perhaps SHOULD? Is this a local policy decision?

Nit:
----

>      If the client is captive (i.e. captive=true),
>      it can still be allowed enough access for it to perform server
>      authentication Section 4.1.

Missing parentheses around "Section 4.1"?

---

From: Tommy Pauly <[email-masked]>
Date: Fri, 08 May 2020 10:58:06 -0700

Hi Brian,

Thanks for the review! I’ve updated our working copy to fix the nits you mention:

https://github.com/capport-wg/api/commit/a9d1dabf8b8b1e4275b98cc5d022d12bece97e70

> On May 3, 2020, at 9:29 PM, Brian Carpenter via Datatracker <[email-masked]> wrote:
> 

Changed this to “will”. This does not need to be a normative claim here, as it is simply describing what the server deployment will do based on the referenced section.
> Missing parentheses around "Section 4.1"?

Fixed!

Best,
Tommy