Subject: [Last-Call] Genart last call review of draft-ietf-dots-signal-filter-control-04

From: Christer Holmberg via Datatracker <[email-masked]>
Date: Sat, 06 Jun 2020 02:27:14 -0700

Reviewer: Christer Holmberg
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-dots-signal-filter-control-04
Reviewer: Christer Holmberg
Review Date: 2020-06-06
IETF LC End Date: 2020-06-15
IESG Telechat date: Not scheduled for a telechat

Summary: The document is well written, and pretty much ready for publication. I
do have a couple of minor editorial comments that I'd like the authors to
address.

Major issues: None

Minor issues: None

Nits/editorial comments:

Q1:  Please expand DOTS on first occurence.

---

Q2:  The Security Considerations say:

   "This specification does not allow to create new filtering rules,
   which is the responsibility of the DOTS data channel."

Unless I missed it, I think it would be useful to state this also earlier in
the document, e.g., in the Introduction.

---

Q3: The Security Consideration say:

   "The security considerations discussed in
   [I-D.ietf-dots-signal-channel] and [I-D.ietf-dots-data-channel] need
   to be taken into account."

I think it is obvious that those security considerations need to be taken into
account. I would suggest to re-phrase, and say something like:

   "The generic security considerations for DOTS signal channels are
   defined in   [I-D.ietf-dots-signal-channel]. The generic security
   considerations for DOTS data channels are defined in
   [I-D.ietf-dots-data-channel]. This Section defines the security
   considerations that are specific to the DOTS extension defined
   in this document."

---

From: <[email-masked]>
Date: Mon, 8 Jun 2020 05:24:03 +0000

Hi Christer, 

Thank you for the review. 

OK with all your suggestions. 

FWIW, you can track the changes to address your review at: https://github.com/boucadair/filter-control/blob/master/Christer's%20Review.pdf 

Cheers,
Med

> -----Message d'origine-----
> De : Christer Holmberg via Datatracker [mailto:[email-masked]]
> Envoyé : samedi 6 juin 2020 11:27
> À : [email-masked]
> Cc : [email-masked]; last-
> [email-masked]; [email-masked]
> Objet : Genart last call review of draft-ietf-dots-signal-filter-
> control-04
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 8 Jun 2020 05:42:56 +0000

Hi,

>OK with all your suggestions. 

Thank You! :)

Regards,

Christer

FWIW, you can track the changes to address your review at: https://protect2.fireeye.com/v1/url?k=db0f6041-85afa3e8-db0f20da-86959e472243-5faeb82b3c90bf51&q=1&e=f43c50b7-ac0b-4eba-bc4b-55c0e7f8a2b9&u=https%3A%2F%2Fgithub.com%2Fboucadair%2Ffilter-control%2Fblob%2Fmaster%2FChrister's%20Review.pdf 

Cheers,
Med

> Envoyé : samedi 6 juin 2020 11:27 À : [email-masked] Cc : 
> [email-masked]; last- 
> [email-masked]; [email-masked] Objet : Genart last call review of 
> draft-ietf-dots-signal-filter-
> control-04
> 
> Review Team (Gen-ART) reviews all IETF documents being processed by 
> the IESG for the IETF Chair.  Please treat these comments just like 
> any other last call comments.
> 
> Summary: The document is well written, and pretty much ready for 
> publication. I do have a couple of minor editorial comments that I'd 
> like the authors to address.
> 
> Major issues: None
> 
> Minor issues: None
> 
> Nits/editorial comments:
> 
> Unless I missed it, I think it would be useful to state this also 
> earlier in the document, e.g., in the Introduction.
> 
> ---
> 
> I think it is obvious that those security considerations need to be 
> taken into account. I would suggest to re-phrase, and say something 
> like:
>

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 24 Jun 2020 15:30:15 -0400

Christer, thanks for your review. Med, thanks for addressing his comments. I entered a No Objection ballot.

Alissa

> On Jun 8, 2020, at 1:42 AM, Christer Holmberg <christer.holmberg=[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art