Subject: Re: [Last-Call] Last Call: <draft-ietf-ntp-mode-6-cmds-08.txt> (Control Messages Protocol for Use with Network Time Protocol Version 4) to Historic RFC

From: "Pete Resnick" <[email-masked]>
Date: Tue, 02 Jun 2020 12:17:24 -0500

This use of the "Historic" status seems utterly bizarre to me. It's 
certainly not how it's described in 2026.

1305 has already been obsoleted by 5905. This document simply gives 
information about what those control messages were and indicates that 
they ought no longer be used. This sounds like a fine candidate for 
Informational status. When 5905 (or it's successors) advance to 
Standard, this document can be included in the STD.

If eventually you want to move a document to Historic, it would be 1305.

I don't think publishing this straight to Historic makes sense.

pr

On 1 Jun 2020, at 14:31, The IESG wrote:

> The IESG has received a request from the Network Time Protocol WG 
> (ntp) to
> consider the following document: - 'Control Messages Protocol for Use 
> with
> Network Time Protocol Version 4'
>   <draft-ietf-ntp-mode-6-cmds-08.txt> as Historic RFC
>
> The IESG plans to make a decision in the next few weeks, and solicits 
> final
> comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2020-06-15. Exceptionally, 
> comments may
> be sent to [email-masked] instead. In either case, please retain the 
> beginning
> of the Subject line to allow automated sorting.
>
> Abstract
>
>
>    This document describes the structure of the control messages that
>    were historically used with the Network Time Protocol before the
>    advent of more modern control and management approaches.  These
>    control messages have been used to monitor and control the Network
>    Time Protocol application running on any IP network attached
>    computer.  The information in this document was originally 
> described
>    in Appendix B of RFC 1305.  The goal of this document is to provide 
> a
>    current, but historic, description of the control messages as
>    described in RFC 1305 and any additional commands implemented in 
> NTP.
>
>    The publication of this document is not meant to encourage the
>    developement and deployment of these control messages.  This 
> document
>    is only providing a current reference for these control messages
>    given the current status of RFC 1305.
>
>
>
>
> The file can be obtained via
> https://datatracker.ietf.org/doc/draft-ietf-ntp-mode-6-cmds/
>
>
>
> No IPR declarations have been submitted directly on this I-D.

-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

---

From: "Ulrich Windl" <[email-masked]>
Date: Thu, 04 Jun 2020 09:31:44 +0200

>>> "Pete Resnick" <[email-masked]> schrieb am 02.06.2020 um 19:17 in
Nachricht
<14808_1591124438_5ED6A1D6_14808_2895_1_45F5F313-BFC6-48BB-B5A3-D47C48AE87D6@epi
> they ought no longer be used. This sounds like a fine candidate for 

"They ought no longer to be used": ... once there is a well-established replacement!

So what to use instead? Mode-6 commands are essential for monitoring the service.

> I don't think publishing this straight to Historic makes sense.

With the argument given above, I also wouldn't name it "historic".

---

From: <[email-masked]>
Date: Fri, 5 Jun 2020 15:56:56 +0000

+1 for not making historic and "no longer used" until there is a standardized replacement. 

Greg Dowd  Microchip - Freq & Time Div.

Assoc. Technical Fellow - Engineering
3870 N First St, San Jose, CA 95134
Direct: 408-964-7643
[email-masked]

-----Original Message-----
From: ntp <[email-masked]> On Behalf Of Ulrich Windl
Sent: Thursday, June 4, 2020 12:32 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [Ntp] Antw: [EXT] Re: Last Call: <draft-ietf-ntp-mode-6-cmds-08.txt> (Control Messages Protocol for Use with Network Time Protocol Version 4) to Historic RFC

EXTERNAL EMAIL: Do not click links or open attachments unless you know the content is safe

Nachricht

_______________________________________________
ntp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ntp

---

From: Brian Haberman <[email-masked]>
Date: Fri, 12 Jun 2020 13:20:20 -0400

Hi Pete,

     While I am responding to your note, I will capture thoughts related
to what others have said so far...

> certainly not how it's described in 2026.

It is a bit strange, but was done for a reason...

> I don't think publishing this straight to Historic makes sense.

There are two intents with this document.

The first is to capture mode 6 commands that were not defined within RFC
1305, Appendix B. If you compare the command sets, you will see several
additions in this draft. Several people have asked since the publication
of 5905 about some of those commands as they were not documented anywhere.

The second intent is to signal that mode 6/7 commands aren't/shouldn't
be used going forward. If you do a quick search for NTP vulnerabilities,
you will find many that relate to abuse of these commands. Additionally,
I/we received input (e.g., chronyd) no longer use these commands to
accomplish their stated function. That is where making the document
Historic seemed to make sense.

In the grand scheme of things, either Historic or Informational is a
viable document status. I (as document author) did not see consensus for
Standards Track, but that is not my call.

Regards,
Brian