Subject: [Last-Call] Genart telechat review of draft-ietf-tcpm-rto-consider-16

From: Stewart Bryant via Datatracker <[email-masked]>
Date: Fri, 03 Jul 2020 06:29:31 -0700

Reviewer: Stewart Bryant
Review result: Ready with Issues

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair. Please wait for direction from your
document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-tcpm-rto-consider-16
Reviewer: Stewart Bryant
Review Date: 2020-07-03
IETF LC End Date: 2020-06-01
IESG Telechat date: 2020-07-09

Summary: This is a well written document and is much improved over the previous
version that I reviewed. I thank the author for their work in that regard.
However I do have one concern that I think the Area Directors need to consider
carefully.

Major issues:
     Whilst the document has undoubtedly gained consensus in the
     transport area, it is not clear whether the other areas that will
     be impacted have properly considered the implications
     of the text and proactively given their consensus to the text.

     In particular the following text in a BCP may be a burden on future
     protocols, particularly in the routing and OAM spaces, with the potential
     for disagreements in the closing stages of specification approval.

      - The requirements in this document may not be appropriate in all
        cases and, therefore, inconsistent deviations and variants may
        be necessary (hence the "SHOULD" in the last bullet).  However,
        inconsistencies MUST be (a) explained and (b) gather consensus.

     It is possible that I am over-reacting but experience tells me that this
     holds the seeds of future disagreements between areas, delays in
     publication, and possible re-engineering of what are in practice perfectly
     acceptable implementations.

Minor issues:

    None

Nits/editorial comments:
    There is a trivial nits issue in the abstract that the RFC editor will need
    to resolve.

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 8 Jul 2020 11:55:58 -0400

Stewart, thanks for your review.

> On Jul 3, 2020, at 9:29 AM, Stewart Bryant via Datatracker <[email-masked]> wrote:
> 
> Reviewer: Stewart Bryant

I can see the concern, but given that the key requirement is a SHOULD I expect there to be flexibility in interpretation.

Alissa 

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art