Subject: [Last-Call] Opsdir last call review of draft-ietf-mmusic-msrp-usage-data-channel-22

From: Al Morton via Datatracker <[email-masked]>
Date: Sat, 18 Jul 2020 16:21:43 -0700

Reviewer: Al Morton
Review result: Has Nits

OPS-DIR review of MSRP over Data Channels
draft-ietf-mmusic-msrp-usage-data-channel-21

   This document specifies how the Message Session Relay Protocol (MSRP)
   can be transported as a WebRTC data channel sub-protocol, using the
   SDP offer/answer generic data channel negotiation framework to
   establish such a channel.

Summary: Operational impact of this protocol appears to be minimal, if any.

Gen-ART review has found some Nits that must be resolved.

Key Notes from the Doc Shepherd's write-up [0]:
   It seems that this document was revived after being abandoned, when 3GPP
   noticed the change in status and recognized use of the draft as a normative
   reference in 3GPP Specifications.

   There are no known implementations of the protocol, and thus no operational
   issues at this time. However, some vendors (of???) have indicated plans to
   implement.

   Further investigation indicates that there are Normative References
   to drafts that are more than a year old. For example, the 2 refs below:
   ...the channel is
   negotiated using the SDP-based external negotiation method defined in
      [I-D.ietf-mmusic-data-channel-sdpneg].

   The following WebRTC data channel property values
   [I-D.ietf-rtcweb-data-channel] apply to an MSRP data channel:

Also, from the Normative References section:

   [I-D.ietf-rtcweb-data-protocol]
              Jesup, R., Loreto, S., and M. Tuexen, "WebRTC Data Channel
              Establishment Protocol", draft-ietf-rtcweb-data-
              protocol-09 (work in progress), January *2015*.

   [I-D.ietf-rtcweb-data-channel]
              Jesup, R., Loreto, S., and M. Tuexen, "WebRTC Data
              Channels", draft-ietf-rtcweb-data-channel-13 (work in
              progress), January *2015*.

Nits:

2.  Conventions
   The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALLNOT",
s/"SHALLNOT"/"SHALL NOT"/

[0]
https://datatracker.ietf.org/doc/draft-ietf-mmusic-msrp-usage-data-channel/shepherdwriteup/

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 19 Jul 2020 07:26:12 +0000

Hi Al,

Thank You for the review! Please see inline.

> Gen-ART review has found some Nits that must be resolved.

They were solved and implemented in the -22 version of the draft.

>   issues at this time. However, some vendors (of???) have indicated plans to

Based on my knowledge, vendors of both endpoints and network nodes (gateways etc).

>              progress), January *2015*.

All drafts mentioned above are part of cluster 238. Many drafts in the cluster are done, but the publications have been on hold for a while, as the idea is to publish them all at once.

---

Nits:

>2.  Conventions
>   The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALLNOT", s/"SHALLNOT"/"SHALL NOT"/

This has been fixed in version -22. Maybe you were looking at version -21?

Regards,

Christer

[0]

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Sun, 19 Jul 2020 14:16:37 +0000

> -----Original Message-----
> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Sunday, July 19, 2020 3:26 AM
> To: MORTON, ALFRED C (AL) <[email-masked]>; [email-masked]
> Cc: [email-masked]; draft-ietf-mmusic-msrp-usage-data-
> [email-masked]; [email-masked]
> Subject: RE: Opsdir last call review of draft-ietf-mmusic-msrp-usage-data-
> channel-22
> 
> Hi Al,
> 
<snip>
> This has been fixed in version -22. Maybe you were looking at version -21?
[acm] 
Yes, when I asked for the html-ized tools version, -21 is the version that appeared,
and I recorded this in the beginning of the review.  I don't control the subject line or
header generated by the review tool.

Al

> 
> Regards,
> 
> Christer
> 
> 
> 
> [0]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Dmmusic-2Dmsrp-2Dusage-2Ddata-
> 2Dchannel_shepherdwriteup_&d=DwIGaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=STZGgunKZhhZfnd2hdhbpcWd2FNcD
> 4TUCdc_bHAWew4&s=T_B-y_qO8-clmNexDOEiLgty5u4rN-1MJYOyXEjMdeI&e=
> 
>

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 19 Jul 2020 19:33:18 +0000

Hi,

>Yes, when I asked for the html-ized tools version, -21 is the version that appeared, and I recorded this in the beginning of the review.  I don't control the subject line or header generated by the review tool.

When you were assigned the review, -21 was the latest version :)

(I submitted a new version once the Gen-Art review issues had been solved.)

Regards,

Christer