Subject: [Last-Call] Opsdir last call review of draft-ietf-spring-srv6-network-programming-17

From: Dan Romascanu via Datatracker <[email-masked]>
Date: Thu, 20 Aug 2020 02:43:09 -0700

Reviewer: Dan Romascanu
Review result: Has Issues

This document together with the companion document
[I-D.filsfils-spring-srv6-net-pgm-illustration] defines the SRv6 Network
Programming concept and specifies the main segment routing behaviors to enable
the creation of interoperable overlays with underlay optimization (Service
Level Agreement).

The document is Ready.  There are a number of issues from an Operations and
Management perspective that need further work, and it is assumed that they will
be subject to work in the future. Some clarification on these issues would be
however welcome before document approval.

There are several references that are work-in-progress. For example basic
concepts need to be understood from
[I-D.filsfils-spring-srv6-net-pgm-illustration]. The control plane interaction
is based on BGP-LS  [I-D.ietf-idr-bgpls-srv6-ext] or on BGP IP/VPN/EVPN
[I-D.ietf-bess-srv6-services]. These documents are listed as Informative
References probably in order to avoid a downref for this Standards Track
document, but actually this document cannot be implemented or even understood
without stable versions of the later.

>From the operators point of view I would like to draw the attention on Sections
6 and 8. - Section 6 (Operation) recommends the implementation of a implement a
combined traffic counter (packets and bytes) per local SID entry. There is no
indication how an operator would retrieve this information and if and how the
values of these counters could be used for operational purposes. Adding such
information would be useful. - Section 8 (Control Plane) describes how the
controllers can explicitly provision the SIDs and/or discover them as part of a
service discovery function. Subsections describe the usage of IGP, BGP-LS, and
BGP IP/VPN/EVPN for these purposes. Operators should be aware that one or more
of these protocols also need to be supported in an SDN deployment.

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Fri, 21 Aug 2020 15:43:36 +0000

Hi Dan,

Thank you for the review. Please see comments inline with [PC].

Regards,
Pablo.

-----Original Message-----
From: Dan Romascanu via Datatracker <[email-masked]> 
Sent: jueves, 20 de agosto de 2020 11:43
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Opsdir last call review of draft-ietf-spring-srv6-network-programming-17

Reviewer: Dan Romascanu

This document together with the companion document [I-D.filsfils-spring-srv6-net-pgm-illustration] defines the SRv6 Network Programming concept and specifies the main segment routing behaviors to enable the creation of interoperable overlays with underlay optimization (Service Level Agreement).

The document is Ready.  There are a number of issues from an Operations and Management perspective that need further work, and it is assumed that they will be subject to work in the future. Some clarification on these issues would be however welcome before document approval.

There are several references that are work-in-progress. For example basic concepts need to be understood from [I-D.filsfils-spring-srv6-net-pgm-illustration]. 

[PC] The illustrations used to be part of this document originally but were moved to a separate informational document based on WG feedback. 

The control plane interaction is based on BGP-LS  [I-D.ietf-idr-bgpls-srv6-ext] or on BGP IP/VPN/EVPN [I-D.ietf-bess-srv6-services]. These documents are listed as Informative References probably in order to avoid a downref for this Standards Track document, but actually this document cannot be implemented or even understood without stable versions of the later.

[PC] After re-reading section 8 I don't see a need for the informative references to ietf-idr-bgpls-srv6-ext and ietf-bess-srv6-services. We will remove those two. This document specifies a set of SRv6 SID behaviors for supporting of TE and overlay services using SRv6; these TE and overlay services themselves are not new (e.g. they are available with MPLS data plane) and the document includes references to them. Control plane extensions are covered by documents progressing in other RTG WGs.

>From the operators point of view I would like to draw the attention on 
>Sections 6 and 8. 

- Section 6 (Operation) recommends the implementation of a implement a combined traffic counter (packets and bytes) per local SID entry. There is no indication how an operator would retrieve this information and if and how the values of these counters could be used for operational purposes. Adding such information would be useful. 

[PC] These counters are included in the draft draft-raza-spring-srv6-yang that was just recently adopted by the Spring WG. I'll update this section to indicate that retrieval of these counters via MIB, NETCONF/YANG or other means is outside the scope of this document.
 
- Section 8 (Control Plane) describes how the controllers can explicitly provision the SIDs and/or discover them as part of a service discovery function. Subsections describe the usage of IGP, BGP-LS, and BGP IP/VPN/EVPN for these purposes. Operators should be aware that one or more of these protocols also need to be supported in an SDN deployment.

[PC] I would propose the following diff
<old>
This section provides a high level overview of the control-plane protocols involved with SRv6 and their specification.
</old>
<new>
While not necessary for an SDN control plane, the remainder of this section provides a high-level illustrative overview of how control-plane protocols may be involved with SRv6. Their specification is outside the scope of this document.
</new>

---

From: Dan Romascanu <[email-masked]>
Date: Sat, 22 Aug 2020 00:14:06 +0300

Hi Pablo,

Thank you for your quick answer and for addressing my comments.

Your suggested edits are fine with me.

Regards,

Dan

On Fri, Aug 21, 2020 at 6:43 PM Pablo Camarillo (pcamaril) <
[email-masked]> wrote:

> Cc: [email-masked]; [email-masked];
> [email-masked];
> [email-masked]
> Subject: Opsdir last call review of
> draft-ietf-spring-srv6-network-programming-17
>
> Reviewer: Dan Romascanu
> Programming concept and specifies the main segment routing behaviors to
> enable the creation of interoperable overlays with underlay optimization
> (Service Level Agreement).
>
> The document is Ready.  There are a number of issues from an Operations
> and Management perspective that need further work, and it is assumed that
> they will be subject to work in the future. Some clarification on these
> issues would be however welcome before document approval.
>
> [I-D.filsfils-spring-srv6-net-pgm-illustration].
>
> [PC] The illustrations used to be part of this document originally but
> were moved to a separate informational document based on WG feedback.
>
> The control plane interaction is based on BGP-LS
> [I-D.ietf-idr-bgpls-srv6-ext] or on BGP IP/VPN/EVPN
> document, but actually this document cannot be implemented or even
> understood without stable versions of the later.
>
> [PC] After re-reading section 8 I don't see a need for the informative
> references to ietf-idr-bgpls-srv6-ext and ietf-bess-srv6-services. We will
> remove those two. This document specifies a set of SRv6 SID behaviors for
> supporting of TE and overlay services using SRv6; these TE and overlay
> services themselves are not new (e.g. they are available with MPLS data
> plane) and the document includes references to them. Control plane
> extensions are covered by documents progressing in other RTG WGs.
>
> - Section 6 (Operation) recommends the implementation of a implement a
> combined traffic counter (packets and bytes) per local SID entry. There is
> no indication how an operator would retrieve this information and if and
> how the values of these counters could be used for operational purposes.
> Adding such information would be useful.
>
> [PC] These counters are included in the draft draft-raza-spring-srv6-yang
> that was just recently adopted by the Spring WG. I'll update this section
> to indicate that retrieval of these counters via MIB, NETCONF/YANG or other
> means is outside the scope of this document.
>
> - Section 8 (Control Plane) describes how the controllers can explicitly
> provision the SIDs and/or discover them as part of a service discovery
> function. Subsections describe the usage of IGP, BGP-LS, and BGP
> IP/VPN/EVPN for these purposes. Operators should be aware that one or more
> This section provides a high level overview of the control-plane protocols
> involved with SRv6 and their specification.
> </old>
> <new>
> While not necessary for an SDN control plane, the remainder of this
> section provides a high-level illustrative overview of how control-plane
> protocols may be involved with SRv6. Their specification is outside the
> scope of this document.
> </new>
>
>
>
>